当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教高人如何给libldap2包降级??
帖子发表于 : 2008-11-04 11:55 

注册: 2008-02-04 0:45
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
我是8.10desktop版本。想安装个 lamp。
结果安装apache2时提示libldap2太新了。
内置版本是libldap-2.4-2
而我需要的是libldap2-2.1.30
我下载这个包安装说是不能安装。有更新的版本。
查询帖子,用这个命令
代码:
jessica@ubuntu:~/桌面$ sudo dpkg -i --ignore-depends=libldap-2.4-2 libldap2_2.1.30-13.4_i386.deb
dpkg:关于含有 libldap2 的 libldap2_2.1.30-13.4_i386.deb:
 libldap-2.4-2 冲突于 libldap2
  即将安装 libldap2 (版本为 2.1.30-13.4)。
dpkg:处理 libldap2_2.1.30-13.4_i386.deb (--install)时出错:
 软件包相互冲突 - 将不安装 libldap2
在处理时有错误发生:
 libldap2_2.1.30-13.4_i386.deb

不能降级。
再查询。得知在新德里里面强制版本,但是我够选不管用阿??为什么呢??
该怎么办??
不能删除这个包,如果删除会把我的gnome和ff都删除掉,会删除掉184个包。真可怕。请问如何降级。谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教高人如何给libldap2包降级??
帖子发表于 : 2008-11-04 12:13 
头像

注册: 2008-08-21 20:26
帖子: 810
送出感谢: 0 次
接收感谢: 0 次
试试aptitude

http://man.ddvip.com/linux/debian/aptitude/


_________________
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教高人如何给libldap2包降级??
帖子发表于 : 2008-11-04 12:58 

注册: 2008-02-04 0:45
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
我用了.也说有冲突.无法解决.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请教高人如何给libldap2包降级??
帖子发表于 : 2008-11-04 21:02 

注册: 2008-02-04 0:45
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
请问就没有办法了马??


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译