安装GD库出问题,我刚学这个弄不清楚发生什么问题了

重复贴和参考价值不大的帖子,版主维护
回复
zhfct123
帖子: 10
注册时间: 2008-10-13 16:39
送出感谢: 0
接收感谢: 0

安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#1

帖子 zhfct123 » 2008-11-05 13:46

我安装的是ubuntu-8.10-server-i386
安装GD库的时候,我输入apt-get install php5-gd,装gd库,结果出现这样子:

root@ubuntu:~# root@ubuntu:~# apt-get install php5-gd
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
php5-gd: 依赖: php5-common (= 5.2.4-2ubuntu5.3) 但是 5.2.6-2ubuntu4 正要被安装
E: 无法安装的软件包
root@ubuntu:~#


请大家帮帮忙,给个解决办法,怎么才能把gd库装上,谢谢了,谢谢了!!!
zhfct123
帖子: 10
注册时间: 2008-10-13 16:39
送出感谢: 0
接收感谢: 0

Re: 安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#2

帖子 zhfct123 » 2008-11-05 16:01

:em19 人呢。如果知道的朋友麻烦帮帮我这个新手。谢谢了!!!!!!
8wy326779
帖子: 1
注册时间: 2008-11-02 21:28
送出感谢: 0
接收感谢: 0

Re: 安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#3

帖子 8wy326779 » 2008-11-05 20:19

同样问题,求解。
tearsphoenix
帖子: 28
注册时间: 2008-11-03 7:27
送出感谢: 0
接收感谢: 0

Re: 安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#4

帖子 tearsphoenix » 2008-11-05 20:23

用新立得啊,它会自动匹配依赖关系。你安装GD库的时候,它会自动安上依赖的包。从信息看你的问题只是依赖关系不满足。不行的话用dpkg --configure -a自动修复一下再试试。
tearsphoenix
帖子: 28
注册时间: 2008-11-03 7:27
送出感谢: 0
接收感谢: 0

Re: 安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#5

帖子 tearsphoenix » 2008-11-05 20:30

还有,万一高速缓存损坏(一般是手动安装大软件包--比如游戏--卡住而强制退出),而一切修复无效时,可以手动修改/var/lib/dpkg/status文件,将坏掉的包的信息删掉就行了,这样包管理器的安装历史中就会没有错误了。但是一定记得备份。还有,这是最后的办法,不要乱用。
zhfct123
帖子: 10
注册时间: 2008-10-13 16:39
送出感谢: 0
接收感谢: 0

Re: 安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#6

帖子 zhfct123 » 2008-11-06 9:19

谢谢大家,继续求解!!!!!!!! :em05
zhfct123
帖子: 10
注册时间: 2008-10-13 16:39
送出感谢: 0
接收感谢: 0

Re: 安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#7

帖子 zhfct123 » 2008-11-06 13:13

:em36 帖子不能沉,解决了问题再沉,大家快来帮帮忙,谢谢了
头像
cnkilior
论坛版主
帖子: 4981
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

Re: 安装GD库出问题,我刚学这个弄不清楚发生什么问题了

#8

帖子 cnkilior » 2008-11-06 13:21

强制安装低版本。
回复

回到 “归档贴”