在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

重复贴和参考价值不大的帖子,版主维护
tomshi
帖子: 123
注册时间: 2006-12-25 21:15
送出感谢: 0
接收感谢: 0

在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#1

帖子 tomshi » 2008-11-09 2:34

一直在HP的6515b上用ubuntu,从7.04,依次升级到现在的8.10,总的感觉一次比一次升级功能要强大,配置要更省心。但发现8.04的时候,一切还都正常,但今天升级到8.10却遇到问题。

主要表现是,全部重新安装8.10,采用原有分区和挂接点方式,但分区都格式化成ext3格式。结果发现光盘启动的时候,就感觉非常慢,要等很久才出画面,而且,安装过程耗时将近两小时,每个步骤都要等待很长时间才有反应,且笔记本的风扇一直都在高速运转。这在以前是没有遇到过的。现在正在重新装回8.04,安装步骤几乎一样,除了画面精细美观不如8.10,但差不多30分钟就安装好基本系统。

在8.10下,安装好基本系统后,马上发现无法正常重启,每次都是卡在全部关闭程序和后台进程时,机器会定在一个黑屏状态下不动。必须硬关机。再就是进入桌面的启动时间明显长于8.04,从系统资源监测看,内存、硬盘占用情况没什么变化,就是CPU的占用率非常高,基本调用一次系统菜单,都会把CPU撑到100%。整个系统反应非常慢。

我想请教,这究竟时怎么回事?我下载的版本应该是8.10的32位桌面版的ISO,安装过程与8.04没有差别,为什么会出现这种状态?我开始以为是打开了显示特效,于是关闭特效。几乎没有变化。于是又重新安装ATI专用显示驱动,依然没有改进。现在我只能重装8.04,还计划再下一个xubuntu测试一下,是否也有同样的问题。
上次由 tomshi 在 2008-11-13 10:12,总共编辑 1 次。
头像
allarem
帖子: 1025
注册时间: 2008-05-31 17:27
来自: SUES
送出感谢: 0
接收感谢: 0
联系:

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因

#2

帖子 allarem » 2008-11-09 11:17

估计又是显卡驱动惹的祸……
thirdspeed
帖子: 4
注册时间: 2008-11-07 17:01
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因

#3

帖子 thirdspeed » 2008-11-10 10:44

我的hp6515b 安装64位版本Ubuntu 8.10 Amd cpu
结果出现了相同的情况
安装和运行都非常非常慢。 :em20
thirdspeed
帖子: 4
注册时间: 2008-11-07 17:01
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因

#4

帖子 thirdspeed » 2008-11-10 11:05

找到一个解决方法,
经我试验,可行,
但是安装好之后,风扇还是狂响。
无线网卡和显卡要另外安装 。
HP 6515b安装ubuntu 8.10心得(关闭ACPI,解决安装缓慢)

起初在6515b中安装ubuntu 8.10非常缓慢,后期使用也是相当缓慢,无论是live cd模式还是文本模式,甚之wubi模式都不行

后来看到一篇帖子发现新版本的ubuntu对有些笔记本的“高级程序中断控制(ACPI)“支持不好(其实8.04是支持没问题的)

所以也许就有方法在解决6515b中安装ubuntu 8.10缓慢的问题,选用windwos下wubi安装,重新启动后
grub启动后菜单最下5行如有乱码,
title 用正常模式启动安装程序
title 用安全图形模式启动安装程序(仅当您出现显示问题时)
title 用 ACPI 临时解决方案启动安装程序(仅当您出现 ACPI 问题时)
title 用详细模式启动安装程序
title Read-Only Demo (Live CD Desktop)

选用第三项“用 ACPI 临时解决方案启动安装程序(仅当您出现 ACPI 问题时)“安装ubuntu 8.10
果然解决了安装缓慢,后期使用也缓慢的问题

其原理是 /boot/grub/menu.lst启动项kernel后面加了参数 acpi=off noapic nolapic 关闭ACPI
title Ubuntu 8.10, kernel 2.6.27-7-generic
root ()/ubuntu/disks
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=B2280C1A68657B61loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio acpi=off noapicnolapic quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
其实,系统加载的时候,大家应注意看屏幕上给出的信息 特别是 error 信息,6515b在加载系统的时候会有 MP-BIOS 8254 timer can't connect to IO-APIC 出现的
所以造成运行缓慢还是ACPI模块的问题,当然也许还有其他问题
关闭ACPI,系统运行一切正常,值得称赞的是8.10这个版本对6515b的无线网络可以支持了,在“受限驱动”中激活broadcom STA无线驱动即可看见蓝色无线灯亮起,正常使用,不过有同学反应可能有时候对WEP加密支持有问题

总体感觉UBUNTU 8.10外观有改进,compiz也多了很多特效,“网络配置”改进很多,配置VPN,DSL,移动接入都很方便

yujan
帖子: 18
注册时间: 2005-06-14 11:33
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因

#5

帖子 yujan » 2008-11-11 17:38

这个应该是8.10与HP6515b的兼容问题,很普遍。要在启动选项中强制关闭ACPI(用参数ACPI=off或者noacpi);
无线也还是有问题,每次启动之后要手动关闭(Deactivate)无线驱动再重新激活。
风扇狂转可以看看是否已经加载powernow_k8模块,也许可以解决。也许...也是ACPI引发 :em20
tomshi
帖子: 123
注册时间: 2006-12-25 21:15
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因

#6

帖子 tomshi » 2008-11-12 18:14

这段时间,我反别测试了8.10的三个版本,Ubuntu、Xubuntu和Hweed,的确发现都存在不同程度的类似问题。其中Ubuntu和Xubuntu是一样的,反应速度超慢,风扇狂响不停,CPU占用率始终超高。Hiweed的CPU占用率不高,但风扇一样狂响,反应速度也存在一定程度的延迟。
其实,在8.04上,有限驱动安装程序就可以支持对6515b无线网卡的自动加载,配合wicd,可以很好地适应各种环境下的无线应用。但从效果看,的确在信号的识别强度和稳定上,还不如在Windows下,在同样环境下的效果。现在正在设法搞定直接从live CD安装时,如何直接关闭ACPI。之前几个版本中,启动时ACPI的错误提示一直都有,但并没有类似的问题。不知这次怎么回事。风扇狂响的问题,依然找不到解决办法。
tomshi
帖子: 123
注册时间: 2006-12-25 21:15
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因

#7

帖子 tomshi » 2008-11-13 10:11

现在基本搞定了安装和运行缓慢的问题,具体方法如下:

1、采用Live CD启动或安装;
2、进入启动画面,先选择具体需要的启动方式,比如是直接运行LiveCD,还是直接安装;
3、按F6调出启动参数,再按F6调出可调整的启动参数。这时启动画面又下角会出现一个弹出窗口,分别显示四项启动参数选择,分别是ACPI=off、noapic、nolapic、还有一个似乎是exx on什么的。在前三项上用回车选择,显示上会提示一个“x”,然后再按Esc回到启动画面;
4、直接回车进入上面选定的启动项目,开始进入正式的运行。

效果是明显的,CPU占用率正常了,风扇狂响似乎也有一定的缓解。

但又出现新问题,关机不能!经搜索似乎也是老问题,在Bate时就已经出现,貌似和声卡、网卡的设置有关,需要手工修正/etc/init.d/alsa-utils中的设置,但有几种不同修正模式。目前还没有一一测试,等我测试之后再向大家汇报。
上次由 tomshi 在 2008-11-14 8:55,总共编辑 1 次。
tigersmith
帖子: 53
注册时间: 2008-10-21 16:09
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#8

帖子 tigersmith » 2008-11-13 13:17

关机到最后一个单词是不是Halt
zywwzy
帖子: 2
注册时间: 2006-07-09 22:42
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#9

帖子 zywwzy » 2008-11-14 17:17

我也用的6515B。
这个问题不是ubuntu的问题。而是2.6.27内核的问题。用了2.6.27内核的所有Linux发行版都一样。8.04升级到2.6.27内核也是一样的效果。
都是由于apic支持引起的问题。在启动的时候加入 noapic就好了。
希望下个内核版本能解决这个bug.
ustchwzhou
帖子: 5
注册时间: 2008-11-14 19:39
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#10

帖子 ustchwzhou » 2008-11-14 20:37

不会吧?我还正想装呢,现在看着有些怕怕。不加电源管理,那笔记本从电源切到电池,会不会出问题啊?
tomshi
帖子: 123
注册时间: 2006-12-25 21:15
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#11

帖子 tomshi » 2008-11-14 21:42

估计没什么了不起的,反正从我在6515b上用ubuntu以来,绝大多数时间里,貌似启动的时候,apic就永远是报错的。结果就是电池消耗要比用XP快不少,但也不至于有什么根本性的影响。毕竟现在本本都是到处可以找到电源的。
thirdspeed
帖子: 4
注册时间: 2008-11-07 17:01
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#12

帖子 thirdspeed » 2008-11-15 22:56

我安装了多次 ubuntu 8.10 。
除了这个问题之外,还有显卡驱动的问题,ati xpress 1250 的显卡驱动是有很大的问题,风扇狂响可能和显卡没有装好有关。
11月13日,出了一个新版驱动,还没有试过。
tomshi
帖子: 123
注册时间: 2006-12-25 21:15
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#13

帖子 tomshi » 2008-11-16 9:36

我已经安装了ATI新出的驱动,显示控制方面的确比以前有增强,但风扇响的问题没有改善。另外,6515b的无线网卡,在8.04上虽然灵敏度比Windows下稍差,但还是比较稳定的。但在8.10下,基本无法正常工作,网卡激活后,经常扫描不到AP,即便偶尔找到了AP,WEP加密模式也很难握手成功,掉线更是每几分钟一次,基本没有实用性。我测试了几天,感觉运行同样的程序,8.10比8.04耗费的资源,尤其是CPU资源明显增加,即便采用LXDE也是一样。所以,我正准备改回8.04。
shierji
帖子: 93
注册时间: 2008-02-24 13:56
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#14

帖子 shierji » 2008-11-20 22:57

= =
我 用noacpi装上了

但是电源管理不见了 = =
头像
vmmm
帖子: 458
注册时间: 2008-10-23 19:01
来自: 乌有之乡
送出感谢: 0
接收感谢: 0

Re: 在HP 6515b上装8.10CPU占用量极大,反应超慢,求教原因(已基本解决,但又发现新的关机不能问题。)

#15

帖子 vmmm » 2008-11-21 12:02

驱动是linux很难解决的一个问题,必须要有厂商的大规模支持。在我的硬件上安装除了关机时间超长,升级后开关机都是超快的。
心中自是的,便是愚昧人
回复

回到 “归档贴”