zh_CN.GBK下乱码的问题

重复贴和参考价值不大的帖子,版主维护
回复
youngc527
帖子: 5
注册时间: 2008-03-19 23:56
送出感谢: 0
接收感谢: 0

zh_CN.GBK下乱码的问题

#1

帖子 youngc527 » 2008-11-16 13:29

我在新电脑上装了双系统XP和Ubunt8.10,
完成后在Ubuntu下面访问XP的分区时,打开zip里面中文文件名是乱码
把 /etc/environment 和 /etc/default/locale 的 LANG 设置成 zh_CN.GBK 之后,
打开zip时候乱码问题解决了,
可是用OpenOffice打开中文文档的时候出错了,打不开
并且shell下面也是中文文件名也是乱码,一些图形界面也有乱码(比如访问xp分区时候的那个认证对话框)

哪位大哥指点一下阿,拜托 :em06

附配置文件:
[ /etc/environment ]
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANGUAGE="zh_CN:zh:en_US:en"
LANG="zh_CN.GBK"
LC_ALL="zh_CN.GBK"
LC_CTYLE="zh_CN.GBK"
GST_ID3_TAG_ENCODING=GBK

[ /etc/default/locale ]
LANG="zh_CN.GBK"
LANGUAGE="zh_CN:zh:en_US:en"
mwwstuday
帖子: 88
注册时间: 2008-10-30 17:02
送出感谢: 0
接收感谢: 0

Re: zh_CN.GBK下乱码的问题

#2

帖子 mwwstuday » 2008-11-16 13:32

试试。LANGUAGE=‘zh_CN.UTF'
youngc527
帖子: 5
注册时间: 2008-03-19 23:56
送出感谢: 0
接收感谢: 0

Re: zh_CN.GBK下乱码的问题

#3

帖子 youngc527 » 2008-11-16 16:13

不好用哦,依旧的乱~
头像
kelen
帖子: 734
注册时间: 2008-05-02 19:50
送出感谢: 0
接收感谢: 0

Re: zh_CN.GBK下乱码的问题

#4

帖子 kelen » 2008-11-16 19:16

用GBK的编码,不乱才怪,
用UTF-8的编码啊。这是ubuntu的默认编码。
LANG=en_US.UTF-8
wujch
帖子: 8
注册时间: 2008-11-03 15:31
送出感谢: 0
接收感谢: 0

Re: zh_CN.GBK下乱码的问题

#5

帖子 wujch » 2008-12-19 19:06

LANG="zh_CN.UTF-8"试试
头像
lyp069
帖子: 272
注册时间: 2005-10-25 13:54
送出感谢: 0
接收感谢: 0
联系:

Re: zh_CN.GBK下乱码的问题

#6

帖子 lyp069 » 2008-12-19 21:35

所有软件都是以UTF8为基础的,你把环境变量改为GBK,肯定会出问题的。改回默认就好了
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊
http://www.freeearth.org.cn
头像
xiooli
帖子: 6956
注册时间: 2007-11-19 21:51
来自: 成都
送出感谢: 0
接收感谢: 3 次
联系:

Re: zh_CN.GBK下乱码的问题

#7

帖子 xiooli » 2008-12-19 21:48

要win不乱码改fstab,将挂载locale改成utf8
回复

回到 “归档贴”