当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教高手一个vim问题
帖子发表于 : 2008-11-17 8:50 

注册: 2008-10-26 21:24
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
我使用vim的新手,请问如何让vim支持高亮显示和缩进呢? 教程上说应该把vimrc_example的内容拷贝到~/.vimrc中,请问~/.vimrc在那里呢?

如果用vim开发python和php还需要安装什么插件呢?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教高手一个vim问题
帖子发表于 : 2008-11-17 9:17 

注册: 2007-04-26 9:22
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
python.vim - Enhanced version of the python syntax highlighting

Python and vim: Two great tastes that go great together

VIM for (PHP) Programmers

php.vim - PHP Syntax :

用google比这里答案更多、更快。

~/.vimrc指的是你的用户目录下的.vimrc文件。 /home/你的用户名/.vimrc


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教高手一个vim问题
帖子发表于 : 2008-11-17 9:59 

注册: 2006-10-18 8:48
帖子: 497
送出感谢: 0 次
接收感谢: 2
Vim默认根据文件的后缀名类型来进行语法高亮和格式缩进。
vim目前支持的类型有C,C++,html,XML,SHELL编程脚本,TEX等等上百种类型。所以很多人把它当成了“唯一”的编辑器。

你如果要自定义语法,用命令:
:set syntax=c
设置C语法。同理可以设置任何的语法。

其实你并不需要设置,vim会自动检测的。你可以用命令
:set syntax
查看当前使用了哪个语法。

或者关闭文件再打开一次,vim就会检测到了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请教高手一个vim问题
帖子发表于 : 2008-11-17 10:16 

注册: 2006-10-18 8:48
帖子: 497
送出感谢: 0 次
接收感谢: 2
要注意你的命令输入:
:set syntax

在vim是先输入一个冒号,光标会到左下角,并出现一个冒号的命令窗口,然后你再输入set syntax。为了防止错误,请用tab键来补全。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 请教高手一个vim问题
帖子发表于 : 2008-11-17 10:20 

注册: 2006-10-18 8:48
帖子: 497
送出感谢: 0 次
接收感谢: 2
使用语法高亮


黑白的文字让人厌倦了,增加一些色彩能为你的文件带来生气。这不但看起来漂亮,
还能够提高你的工作效率。本章介绍如何使用不同颜色显示不同文本并把它打印出来。
*06.1* 功能激活

一切从一个简单的命令开始: >

:syntax enable

大多数情况下,这会让你的文件带上颜色。Vim 会自动检测文件的类型,并调用合适的语
法高亮。一下子注释变成蓝色,关键字变成褐色,而字符串变成红色了。这使你可以很容
易浏览整个文档。很快你就会发现,黑白的文本真的会降低你的效率!

如果你希望总能看到语法高亮,把 "syntax enable" 命令加入到 |vimrc| 文件中。

颜色显示不出来或者显示出错误的颜色怎么办?

有很多因素会让你看不到颜色:

- 你的终端不支持彩色。
这种情况下,Vim 会用粗体,斜体和下划线区分不同文字,但这不好看。你可能
会希望找一个支持彩色的终端。对于 Unix,我推荐 XFree86 项目的 xterm:
|xfree-xterm|。

- 你的终端其实支持颜色,可是 Vim 不知道。
确保你的 $TERM 设置正确。例如,当你使用一个支持彩色的 xterm 终端: >

setenv TERM xterm-color

<
或者 (基于你用的控制台终端) >

TERM=xterm-color; export TREM
<
终端名必须与你使用的终端一致。如果这还是不行,参考一下 |xterm-color|,
那里介绍了一些使 Vim 显示彩色的方法 (不仅是 xterm)。

- 文件类型无法识别。
Vim 不可能识别所有文件,而且有时很难说一个文件是什么类型的。试一下这个
命令: >

:set filetype
<
如果结果是 "filetype=",那么问题就是出在文件类型上了。你可以手工指定文
件类型: >

:set filetype=fortran
<
要知道哪些类型是有效的,查看一下 $VIMRUNTIME/syntax 目录。对于 GUI 版
本,你还可以使用 Syntax 菜单。设置文件类型也可以通过 |modeline|,这种
方式使得该文件每次被编辑时都被高亮。例如,下面这行可用于 Makefile (把
它放在接近文件首和文件末的地方) >

# vim: syntax=make
<
你可能知道怎么检测自己的文件类型,通常的方法是检查文件的扩展名 (就是点后面的内容)。|new-filetype| 说明如何告知 Vim 进行那种文件类型的检查。

- 你的文件类型没有语法高亮定义。

你可以找一个相似的文件类型并人工设置为那种类型。如果觉得不好,你可以自
己写一个,参见 |mysyntaxfile|。


或者颜色是错的:

- 彩色的文字难以辨认。
Vim 自动猜测你使用的背景色。如果是黑的 (或者其它深色的色彩),它会用浅
色作为前景色。如果是白的 (或者其它浅色),它会使用深色作为前景色。如果
Vim 猜错了,文字就很难认了。要解决这个问题,设置一下 'background' 选
项。对于深色: >

:set background=dark
<
而对于浅色: >

:set background=light
<
这两个命令必须在 ":syntax enable" 命令前调用,否则不起作用。如果要在这
之后设置背景,可以再调用一下 ":syntax reset" 使得 Vim 重新进行缺省颜色
的设置。

- 在自下往上滚屏的过程中颜色显示不对。
Vim 在分析文本的时候不对整个文件进行处理,它只分析你要显示的部分。这
样能省不少时间,但也会因此带来错误。一个简单的修正方法是敲 CTRL-L。
或者往回滚动一下再回来。要彻底解决这个问题,请参见 |:syn-sync|。有些
语法定义文件有办法自己找到前面的内容,这可以参见相应的语法定义文件。
例如,|tex.vim| 中可以查到 Tex 语法定义。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译