当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 运行apt-get install出错!出现了好多未配置!求大侠指点!
帖子发表于 : 2008-11-29 13:56 

注册: 2008-11-26 17:36
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
lingtianyi@lingtianyi-home:~$ sudo apt-get install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 12 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
正在设置 exim4-daemon-light (4.69-2) ...
* Starting MTA exim: incompatible command-line options or arguments
invoke-rc.d: initscript exim4, action "start" failed.
dpkg:处理 exim4-daemon-light (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 exim4 的配置工作不能继续:
exim4 依赖于 exim4-daemon-light | exim4-daemon-heavy | exim4-daemon-custom;然而:
软件包 exim4-daemon-light 还没有被配置。
未曾安装软件包“exim4-daemon-heavy”。
未曾安装软件包“exim4-daemon-custom”。
dpkg:处理 exim4 (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 mailx 的配置工作不能继续:
mailx 依赖于 exim4 | mail-transport-agent;然而:
软件包 exim4 还没有被配置。
未曾安装软件包“mail-transport-agent”。
软件包 exim4-daemon-light 提供了 mail-transport-agent,但是它还没有配置好。
dpkg:处理 mailx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-core 的配置工作不能继续:
lsb-core 依赖于 No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
mailx | mailutils;然而:
软件包 mailx 还没有被配置。
未曾安装软件包“mailutils”。
lsb-core 依赖于 postfix | mail-transport-agent;然而:
未曾安装软件包“postfix”。
未曾安装软件包“mail-transport-agent”。
软件包 exim4-daemon-light 提供了 mail-transport-agent,但是它还没有配置好。
dpkg:处理 lsb-core (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-cxx 的配置工作不能继续:
lsb-cxx 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-cxx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-graphics 的配置工作不能继续:
lsb-graphics 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-graphics (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-desktop 的配置工作不能继续:
lsb-desktop 依赖于 lsb-graphics;然而:
软件包 lsb-graphics 还没有被配置。
dpkg:处理 lsb-desktop (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-languages 的配置工作不能继续:
lsb-languages 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-languages (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-multimedia 的配置工作不能继续:
lsb-multimedia 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-multimedia (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-printing 的配置工作不能继续:
lsb-printing 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-printing (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb 的配置工作不能继续:
lsb 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
lsb 依赖于 lsb-cxx;然而:
软件包 lsb-cxx 还没有被配置。
lsb 依赖于 lsb-desktop;然而:
软件包 lsb-desktop 还没有被配置。
lsb 依赖于 lsb-graphics;然而:
软件包 lsb-graphics 还没有被配置。
lsb 依赖于 lsb-languages;然而:
软件包 lsb-languages 还没有被配置。
lsb 依赖于 lsb-multimedia;然而:
软件包 lsb-multimedia 还没有被配置。
lsb 依赖于 lsb-printing;然而:
软件包 lsb-printing 还没有被配置。
dpkg:处理 lsb (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 realplay 的配置工作不能继续:
realplay 依赖于 lsb (>= 3.1);然而:
软件包 lsb 还没有被配置。
dpkg:处理 realplay (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
exim4-daemon-light
exim4
mailx
lsb-core
lsb-cxx
lsb-graphics
lsb-desktop
lsb-languages
lsb-multimedia
lsb-printing
lsb
realplay
E: Sub-process /usr/bin/dpkg returned an error code (1)

不知道为什么会有这样的错误,现在安装或者卸载很多软件都会出现这样的情况而导致无法继续,苦闷ing


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 运行apt-get install出错!出现了好多未配置!求大侠指点!
帖子发表于 : 2008-11-29 13:58 
头像

注册: 2006-09-02 14:18
帖子: 5308
地址: 汉桑城
送出感谢: 1
接收感谢: 1
代码:
sudo apt-get install

这个命令是什么意思要搞清楚在发问


_________________
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 运行apt-get install出错!出现了好多未配置!求大侠指点!
帖子发表于 : 2008-11-29 14:12 

注册: 2008-11-26 17:36
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
dogfox 写道:
代码:
sudo apt-get install

这个命令是什么意思要搞清楚在发问


我只用sudo apt-get install来在终端中把问题显示出来以便复制,现在不管是安装新的软件或是卸载都会因为这个问题而无法成功,还请大侠明示阿。
如:
lingtianyi@lingtianyi-home:~$ sudo apt-get install chromium
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
chromium-data libalut0 libglpng libopenal0a libsmpeg0
下列【新】软件包将被安装:
chromium chromium-data libalut0 libglpng libopenal0a libsmpeg0
共升级了 0 个软件包,新安装了 6 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 12 个软件包没有被完全安装或卸载。
需要下载 1497kB 的软件包。
解压缩后会消耗掉 2863kB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://mirror.lupaworld.com hardy/universe chromium-data 0.9.12-3 [1107kB]
获取:2 http://mirror.lupaworld.com hardy/main libopenal0a 1:0.0.8-7 [127kB]
获取:3 http://mirror.lupaworld.com hardy/main libalut0 1.1.0-1 [33.2kB]
获取:4 http://mirror.lupaworld.com hardy/universe libglpng 1.45-4ubuntu1 [14.1kB]
获取:5 http://mirror.lupaworld.com hardy/main libsmpeg0 0.4.5+cvs20030824-2 [103kB]
获取:6 http://mirror.lupaworld.com hardy/universe chromium 0.9.12-13ubuntu4 [113kB]
下载 1497kB,耗时 16s (88.2kB/s)
选中了曾被取消选择的软件包 chromium-data。
(正在读取数据库 ... 系统当前总共安装有 122482 个文件和目录。)
正在解压缩 chromium-data (从 .../chromium-data_0.9.12-3_all.deb) ...
选中了曾被取消选择的软件包 libopenal0a。
正在解压缩 libopenal0a (从 .../libopenal0a_1%3a0.0.8-7_i386.deb) ...
选中了曾被取消选择的软件包 libalut0。
正在解压缩 libalut0 (从 .../libalut0_1.1.0-1_i386.deb) ...
选中了曾被取消选择的软件包 libglpng。
正在解压缩 libglpng (从 .../libglpng_1.45-4ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 libsmpeg0。
正在解压缩 libsmpeg0 (从 .../libsmpeg0_0.4.5+cvs20030824-2_i386.deb) ...
选中了曾被取消选择的软件包 chromium。
正在解压缩 chromium (从 .../chromium_0.9.12-13ubuntu4_i386.deb) ...
正在处理用于 man-db 的触发器...
正在设置 exim4-daemon-light (4.69-2) ...
* Starting MTA exim: incompatible command-line options or arguments
invoke-rc.d: initscript exim4, action "start" failed.
dpkg:处理 exim4-daemon-light (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 exim4 的配置工作不能继续:
exim4 依赖于 exim4-daemon-light | exim4-daemon-heavy | exim4-daemon-custom;然而:
软件包 exim4-daemon-light 还没有被配置。
未曾安装软件包“exim4-daemon-heavy”。
未曾安装软件包“exim4-daemon-custom”。
dpkg:处理 exim4 (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 mailx 的配置工作不能继续:
mailx 依赖于 exim4 | mail-transport-agent;然而:
软件包 exim4 还没有被配置。
未曾安装软件包“mail-transport-agent”。
软件包 exim4-daemon-light 提供了 mail-transport-agent,但是它还没有配置好。
dpkg:处理 mailx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-core 的配置工作不能继续:
lsb-core 依赖于 No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
mailx | mailutils;然而:
软件包 mailx 还没有被配置。
未曾安装软件包“mailutils”。
lsb-core 依赖于 postfix | mail-transport-agent;然而:
未曾安装软件包“postfix”。
未曾安装软件包“mail-transport-agent”。
软件包 exim4-daemon-light 提供了 mail-transport-agent,但是它还没有配置好。
dpkg:处理 lsb-core (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-cxx 的配置工作不能继续:
lsb-cxx 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-cxx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-graphics 的配置工作不能继续:
lsb-graphics 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-graphics (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-desktop 的配置工作不能继续:
lsb-desktop 依赖于 lsb-graphics;然而:
软件包 lsb-graphics 还没有被配置。
dpkg:处理 lsb-desktop (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-languages 的配置工作不能继续:
lsb-languages 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-languages (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-multimedia 的配置工作不能继续:
lsb-multimedia 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-multimedia (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-printing 的配置工作不能继续:
lsb-printing 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-printing (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb 的配置工作不能继续:
lsb 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
lsb 依赖于 lsb-cxx;然而:
软件包 lsb-cxx 还没有被配置。
lsb 依赖于 lsb-desktop;然而:
软件包 lsb-desktop 还没有被配置。
lsb 依赖于 lsb-graphics;然而:
软件包 lsb-graphics 还没有被配置。
lsb 依赖于 lsb-languages;然而:
软件包 lsb-languages 还没有被配置。
lsb 依赖于 lsb-multimedia;然而:
软件包 lsb-multimedia 还没有被配置。
lsb 依赖于 lsb-printing;然而:
软件包 lsb-printing 还没有被配置。
dpkg:处理 lsb (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 realplay 的配置工作不能继续:
realplay 依赖于 lsb (>= 3.1);然而:
软件包 lsb 还没有被配置。
dpkg:处理 realplay (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 chromium-data (0.9.12-3) ...
正在设置 libopenal0a (1:0.0.8-7) ...

正在设置 libalut0 (1.1.0-1) ...

正在设置 libglpng (1.45-4ubuntu1) ...

正在设置 libsmpeg0 (0.4.5+cvs20030824-2) ...

正在设置 chromium (0.9.12-13ubuntu4) ...

正在处理用于 libc6 的触发器...
ldconfig deferred processing now taking place
在处理时有错误发生:
exim4-daemon-light
exim4
mailx
lsb-core
lsb-cxx
lsb-graphics
lsb-desktop
lsb-languages
lsb-multimedia
lsb-printing
lsb
realplay
E: Sub-process /usr/bin/dpkg returned an error code (1)

再如卸载:
lingtianyi@lingtianyi-home:~$ sudo apt-get remove lsb
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包将被【卸载】:
lsb realplay
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 2 个软件包,有 0 个软件未被升级。
有 12 个软件包没有被完全安装或卸载。
解压缩后将会空出 21.5MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 122620 个文件和目录。)
正在删除 realplay ...
正在删除 lsb ...
正在设置 exim4-daemon-light (4.69-2) ...
* Starting MTA exim: incompatible command-line options or arguments
invoke-rc.d: initscript exim4, action "start" failed.
dpkg:处理 exim4-daemon-light (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 exim4 的配置工作不能继续:
exim4 依赖于 exim4-daemon-light | exim4-daemon-heavy | exim4-daemon-custom;然而:
软件包 exim4-daemon-light 还没有被配置。
未曾安装软件包“exim4-daemon-heavy”。
未曾安装软件包“exim4-daemon-custom”。
dpkg:处理 exim4 (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 mailx 的配置工作不能继续:
mailx 依赖于 exim4 | mail-transport-agent;然而:
软件包 exim4 还没有被配置。
未曾安装软件包“mail-transport-agent”。
软件包 exim4-daemon-light 提供了 mail-transport-agent,但是它还没有配置好。
dpkg:处理 mailx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-core 的配置工作不能继续:
lsb-core 依赖于 No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
mailx | mailutils;然而:
软件包 mailx 还没有被配置。
未曾安装软件包“mailutils”。
lsb-core 依赖于 postfix | mail-transport-agent;然而:
未曾安装软件包“postfix”。
未曾安装软件包“mail-transport-agent”。
软件包 exim4-daemon-light 提供了 mail-transport-agent,但是它还没有配置好。
dpkg:处理 lsb-core (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-cxx 的配置工作不能继续:
lsb-cxx 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-cxx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-graphics 的配置工作不能继续:
lsb-graphics 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-graphics (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-desktop 的配置工作不能继续:
lsb-desktop 依赖于 lsb-graphics;然而:
软件包 lsb-graphics 还没有被配置。
dpkg:处理 lsb-desktop (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-languages 的配置工作不能继续:
lsb-languages 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-languages (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-multimedia 的配置工作不能继续:
lsb-multimedia 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-multimedia (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-printing 的配置工作不能继续:
lsb-printing 依赖于 lsb-core (>= 3.2);然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-printing (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
exim4-daemon-light
exim4
mailx
lsb-core
lsb-cxx
lsb-graphics
lsb-desktop
lsb-languages
lsb-multimedia
lsb-printing
E: Sub-process /usr/bin/dpkg returned an error code (1)

始终都是这样的出错而无法继续……


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 运行apt-get install出错!出现了好多未配置!求大侠指点!
帖子发表于 : 2008-11-29 15:12 

注册: 2008-11-08 10:48
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
更新源再重新载入。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译