当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 通过硬盘安装8.10终极版后没有反应?
帖子发表于 : 2008-11-30 10:26 

注册: 2007-12-27 19:21
帖子: 52
送出感谢: 2
接收感谢: 0 次
我按照如下方法从硬盘安装8.10
引用:
我用的是grub.exe grldr方式:
1、取得guub.exe、grldr,复制到C:/

2、从ubuntu-8.10-dvd-amd64.iso中解压出casper至C:/,其中的vmlinuz、initrd.gz复制到C:/

2、从iso中解压出.disk至C:/,其中内容复制到C:/

4、C:/下建menu.lst文件,内容:

title Install Ubuntu 8.10

root (hd0,0)

kernel /vmlinuz boot=casper iso-scan/filename=/ubuntu-8.10-dvd-amd64.iso ro quiet splash locale=zh_CN.UTF-8

initrd /initrd.gz

boot

5、编辑boot.ini,在最后加一行:C:\GRLDR="Grub"

6、将ubuntu-8.10-desktop-i386.iso移至其他硬盘根目录(不是其他分区),待安装硬盘上若有则改名。

7、重启,在安装过程中遇到无法发现硬盘进行分区时,按CTRL_ALT_F2进入控制台方式,进入根目录后ls,目录中有isodevice,利用指令sudo umount -l isodevice后,按CTRL_ALT_F7进入图形模式,再进行安装就正常了。



顺利地安装完成,重启后,发现启动引导栏里仍旧只有xp和Grub两项,没有出现ubuntu,选grub进入后仍然只是Install Ubuntu 。在windows检查硬盘,发现硬盘容量已经变小了。说明已经安装了啊。请问这是怎么回事呢?是不是引导信息没有写入呢??


最后由 sir_wolf 编辑于 2008-11-30 12:16,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 硬盘安装后没有反应?
帖子发表于 : 2008-11-30 12:05 

注册: 2007-12-27 19:21
帖子: 52
送出感谢: 2
接收感谢: 0 次
顺便说一下,我用的镜像是终极版的,ultimate-edition-2.0-x86.iso
安装时已经把上面的filename改过了

现在boot.ini内容:
引用:
[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\GRLDR="Grub"


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 通过硬盘安装8.10终极版后没有反应?
帖子发表于 : 2008-11-30 12:46 

注册: 2007-12-27 19:21
帖子: 52
送出感谢: 2
接收感谢: 0 次
把menu.lst删除了也没有用 :em18


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译