当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]却是找不到解决办法了。关于OpenSSH!!!
帖子发表于 : 2008-12-02 17:09 
头像

注册: 2008-01-07 17:46
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我用的是 Ubuntu8.04.1 。
locale 设置为
LANG=zh_CN.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

1.在本机一切都正常,重启 locale 也不会变(在putty里就会,下面进一步说明症状)
2.通过putty连接,locale 显示的是
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
无法显示中文。
我用export LANG=zh_CN.UTF-8 或者 export LC_ALL=zh_CN.UTF-8 设置以后便能正常显示中文。
但是当我退出 putty,再连接的时候 locale 又回复原样了。
即:LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
...............

请问这是什么原因啊?要怎么样才能使putty里一直都能正常显示中文,不用每次都去 export LANG=zh_CN.UTF-8 。

这个问题困扰我好久了。请高手给新人一点指点吧~~~~在此谢过了!!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译