当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : smplayer升级问题
帖子发表于 : 2008-12-24 12:46 

注册: 2008-12-05 17:40
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
E: /var/cache/apt/archives/smplayer_4%3a0.7+svn080915+i_i386.deb:

正试图覆盖

“/usr/share/smplayer/translations/smplayer_uk_UA.qm”,

它属于软件包 smplayer-translations

我用管理员权限把这个文件删除了 可是重新更新还是提示这样的问题

请问有没有人知道问题阿


页首
 用户资料  
 
2 楼 
 文章标题 : Re: smplayer升级问题
帖子发表于 : 2008-12-24 15:52 
头像

注册: 2008-03-28 10:18
帖子: 578
地址: 淮安and徐州
送出感谢: 1
接收感谢: 3
把这个包smplayer-translations删除了就行了


_________________
今天下午和一群女的聊天,突然有人说我不是男人。
我火了,我说,你说我不是,我掏出来给你看。
女生都笑了,有一个最牛,说,你掏啊……
于是我就把身份证掏出来了。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: smplayer升级问题
帖子发表于 : 2009-02-07 12:41 

注册: 2007-10-27 17:14
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
lin@lin-desktop:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
下列软件包是自动安装的并且现在不再被使用了:
smplayer-translations nvidia-kernel-common
使用'apt-get autoremove'来删除它们
将会安装下列额外的软件包:
smplayer
下列【新】软件包将被安装:
smplayer
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 3 个软件包没有被完全安装或卸载。
需要下载 0B/2287kB 的软件包。
解压缩后会消耗掉 6668kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
smplayer
不经验证就安装这些软件包么?[y/N] y
(正在读取数据库 ... 系统当前总共安装有 135624 个文件和目录。)
正在解压缩 smplayer (从 .../smplayer_4%3a0.7+svn080915+i_amd64.deb) ...
dpkg:处理 /var/cache/apt/archives/smplayer_4%3a0.7+svn080915+i_amd64.deb (--unpack)时出错:
正试图覆盖“/usr/share/smplayer/translations/smplayer_ka.qm”,它属于软件包 smplayer-translations
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
/var/cache/apt/archives/smplayer_4%3a0.7+svn080915+i_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: smplayer升级问题
帖子发表于 : 2009-02-07 12:51 

注册: 2007-10-27 17:14
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
本人实践:成功!!
按照提示进行如下操作:
lin@lin-desktop:~$ sudo apt-get autoremove smplayer-translations

[sudo] password for lin:

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

您可能需要运行“apt-get -f install”来纠正下列错误:

下列的软件包有不能满足的依赖关系:

smplayer-themes: 依赖: smplayer 但是它将不会被安装

E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

lin@lin-desktop:~$ sudo apt-get autoremove smplayer-themes

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

下列软件包是自动安装的并且现在不再被使用了:

smplayer-translations nvidia-kernel-common

下列软件包将被【卸载】:

nvidia-kernel-common smplayer-themes smplayer-translations

共升级了 0 个软件包,新安装了 0 个软件包,要卸载 3 个软件包,有 0 个软件未被升级。

有 1 个软件包没有被完全安装或卸载。

解压缩后将会空出 8155kB 的空间。

您希望继续执行吗?[Y/n]y

(正在读取数据库 ... 系统当前总共安装有 135623 个文件和目录。)

正在删除 smplayer-themes ...

正在删除 nvidia-kernel-common ...

正在删除 smplayer-translations ...

lin@lin-desktop:~$ sudo apt-get upgrade

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。

lin@lin-desktop:~$

lin@lin-desktop:~$ sudo apt-get install smplayer

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

将会安装下列额外的软件包:

smplayer-themes

下列【新】软件包将被安装:

smplayer smplayer-themes

共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。

需要下载 0B/4191kB 的软件包。

解压缩后会消耗掉 11.2MB 的额外空间。

您希望继续执行吗?[Y/n]y

【警告】:下列的软件包不能通过验证!

smplayer smplayer-themes

不经验证就安装这些软件包么?[y/N] y

(正在读取数据库 ... 系统当前总共安装有 134647 个文件和目录。)

正在解压缩 smplayer (从 .../smplayer_4%3a0.7+svn080915+i_amd64.deb) ...

选中了曾被取消选择的软件包 smplayer-themes。

正在解压缩 smplayer-themes (从 .../smplayer-themes_2%3a0.7+svn080809+intrepid_all.deb) ...

正在处理用于 man-db 的触发器...

正在设置 smplayer (4:0.7+svn080915+i) ...



正在设置 smplayer-themes (2:0.7+svn080809+intrepid) ...

lin@lin-desktop:~$


成功了!---林明者


页首
 用户资料  
 
5 楼 
 文章标题 : Re: smplayer升级问题
帖子发表于 : 2009-02-14 23:27 

注册: 2007-09-20 23:52
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也遇到同样的问题,按照4楼的方法可以搞定,但是我还是想问一下,为什么会出现这样的问题,其机理和解决的原理是什么。不知道哪位牛人能解释下?同时向那些帮助别人的同志们致敬!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: smplayer升级问题
帖子发表于 : 2009-02-14 23:53 
头像

注册: 2007-10-23 12:54
帖子: 1688
送出感谢: 0 次
接收感谢: 13
混源了吧,那出什么故障都是正常的。打包那位也很牛,起个名字 smplayer 0.7,还没有那个发行有 0.7 呢。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: smplayer升级问题
帖子发表于 : 2009-02-15 0:00 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
话说啥版本啊?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译