弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

重复贴和参考价值不大的帖子,版主维护
头像
JokerCai
帖子: 18
注册时间: 2008-12-18 16:46
来自: 广州大学华软软件学院
送出感谢: 0
接收感谢: 0

弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#1

帖子 JokerCai » 2008-12-25 15:50

弱弱的问一下,是不是Ubuntu里不能使用RPM包的?
IT荒漠上的一迷途小小生,只想寻找到属于自己的一片绿洲
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#2

帖子 Element » 2008-12-25 15:54

可以使用,不过要转化,不过有时候会有问题
最好装deb包或者自己编译安装
软件到新利得里去找
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
JokerCai
帖子: 18
注册时间: 2008-12-18 16:46
来自: 广州大学华软软件学院
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#3

帖子 JokerCai » 2008-12-25 16:27

楼上的前辈您好,我是超级菜鸟,不明白你的解析。
转化?怎么转化?
还有不知道deb的包在哪里找,到网上找吗?
还有如果发现linux系统里的某些软件想用,就不能在ubuntu下安装了吗?
IT荒漠上的一迷途小小生,只想寻找到属于自己的一片绿洲
robinjwj
帖子: 119
注册时间: 2008-01-30 11:56
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#4

帖子 robinjwj » 2008-12-25 16:31

去新立德里找,软件安装本来就是ubuntu的优点,不要放着新立德不用啊……
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#5

帖子 Element » 2008-12-25 16:31

先修改你的源,找一个对你下载比较快的源
然后到新利得里安装软件
rpm 针对 Redhat 系的
deb 针对 Debian 系的
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
JokerCai
帖子: 18
注册时间: 2008-12-18 16:46
来自: 广州大学华软软件学院
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#6

帖子 JokerCai » 2008-12-25 16:32

请问新利得里安是什么?
IT荒漠上的一迷途小小生,只想寻找到属于自己的一片绿洲
头像
JokerCai
帖子: 18
注册时间: 2008-12-18 16:46
来自: 广州大学华软软件学院
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#7

帖子 JokerCai » 2008-12-25 16:34

在网上找到这个解决方法,不知道行不

“ubuntu 是基于debian的linux ,不能直接使用rpm .

如果直接 rpm -vih *.rpm 则出现:
rpm: To install rpm packages on Debian systems, use alien. See README.Debian.

照着提示意思sudo apt-get install alien安装alien , 接着终端执行 alien *.rpm,又弹出提示:
Must run as root to convert to deb format (or you may use fakeroot).

再尝试sudo apt-get install fakeroot 安装 fakeroot,然后执行 fakeroot alien *.rpm
这次行了,将rpm 包直接转换成了在ubuntu下可直接安装的deb包。

接下来在窗口管理器中找到要安装的deb包双击直接安装或者执行 sudo dpkg -i *.deb安装。这样就把rpm软件包成功装在了ubuntu系统上。有的程序可能需要重启才能执行。

IT荒漠上的一迷途小小生,只想寻找到属于自己的一片绿洲
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#8

帖子 Element » 2008-12-25 16:38

是可以这样做,不过有时候会有依赖问题的
新利得在:系统-->管理-->新利得包管理器
选择你想安装的软件,然后选择应用,它会自动下载并安装的
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
JokerCai
帖子: 18
注册时间: 2008-12-18 16:46
来自: 广州大学华软软件学院
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#9

帖子 JokerCai » 2008-12-25 16:49

继续问一下,楼上的前辈,什么叫"依赖问题"
IT荒漠上的一迷途小小生,只想寻找到属于自己的一片绿洲
头像
Benhon
帖子: 8
注册时间: 2008-12-10 16:47
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#10

帖子 Benhon » 2008-12-25 19:07

JokerCai 写了:继续问一下,楼上的前辈,什么叫"依赖问题"
@_@ “依赖”你字面理解嘛……

街机模拟器玩过没?有时下载一些什么加强、修改版的游戏包rom文件,
单独的玩不了的(而且比正式版原版的游戏小得多),
因被都需要正式版的游戏包支持(你还得把正式版的游戏包也下载下来放到一起),
其实什么加强修改版主要文件调用的还是原版的游戏文件,
这些个增强修改只是在原版的基础上做了扩展和修改,
所以那些修改的增强版游戏离开了原版的游戏包(文件)就跑不起咯
这就是依赖关系,修改、增强版要依赖原版才能运行。
删原版游戏包那些个增强、修改版的游戏就不能玩鸟。

举个例子,Ubuntu 下有个 MPlayer ,还有个 SMPlayer,
SMPlayer 备注写的是基于的 MPlayer 的前端什么的
SMPlayer 操作界面什么的都比 MPlayer 要好看和方便
这里 SMPlayer 就是修改增强版的游戏,MPlayer 是原版游戏
SMPlayer 只是 MPlayer 加了华丽好看的外壳
你把 MPlayer 删了,SMPlayer 也就没办法运行了
这就时依赖关系

我时这么理解的
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#11

帖子 Element » 2008-12-25 19:38

如果你要安装软件a,但是要a运行,必须需要软件b,如果软件b没安装,那么软件a就不能运行,也不能安装。
所以软件a依赖于软件b,这就是依赖关系

不知道说清楚没
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
gong_max
帖子: 134
注册时间: 2008-12-12 10:48
来自: 北京 西城
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#12

帖子 gong_max » 2008-12-25 20:03

强烈建议楼主wiki一下(论坛右上角,有一个wiki),里面有关于Ubuntu的设置的。
新力得是Ubuntu默认安装的一个图形化的软件包管理器,可以在其中找到你所需要的软件。
我也是刚刚接触Ubuntu,和楼主同进步
头像
JokerCai
帖子: 18
注册时间: 2008-12-18 16:46
来自: 广州大学华软软件学院
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#13

帖子 JokerCai » 2008-12-25 21:09

感谢楼上给位的指点,感谢这么详细的回复~相信有你们的指导我会很快进步的
IT荒漠上的一迷途小小生,只想寻找到属于自己的一片绿洲
头像
JokerCai
帖子: 18
注册时间: 2008-12-18 16:46
来自: 广州大学华软软件学院
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#14

帖子 JokerCai » 2008-12-25 21:12

因为我装的Ubuntu是E文的所以,一是不知道是指那个,原来就是指Synaptic
IT荒漠上的一迷途小小生,只想寻找到属于自己的一片绿洲
巴黎海岸
帖子: 4
注册时间: 2008-12-21 17:28
送出感谢: 0
接收感谢: 0

Re: 弱弱的问一下,是不是Ubuntu里不能使用RPM包的?

#15

帖子 巴黎海岸 » 2008-12-27 16:15

下一个deb版本的不就好了
回复

回到 “归档贴”