关于”MySQL安装时出现包依赖错误“的问题!

重复贴和参考价值不大的帖子,版主维护
回复
绿色植物
帖子: 35
注册时间: 2008-12-22 19:40
送出感谢: 0
接收感谢: 0

关于”MySQL安装时出现包依赖错误“的问题!

#1

帖子 绿色植物 » 2008-12-26 16:44

---------------------引用-----------------------
MySQL安装时经常提示包依赖错误 不知如何解决
正在解压缩将用于更替的包文件 mysql-server-5.0 ...
dpkg:依赖关系问题使得 mysql-server-5.0 的配置工作不能继续:
mysql-server-5.0 依赖于 mysql-client-5.0 (>= 5.0.21-3ubuntu1);然而:
软件包 mysql-client-5.0 还没有被配置。
mysql-server-5.0 依赖于 libdbi-perl;然而:
软件包 libdbi-perl 还没有被配置。
dpkg:处理 mysql-server-5.0 (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
mysql-server-5.0
--------------------引用结束--------------------------

:em03 我是初学者。
用apt-get -f install mysql-server不行。

看见论坛里一位高手留了一个网址,viewtopic.php?t=24111

sudo aptitude install mysql mysql-admin mysql-client-5.0 mysql-navigator mysql-query-browser mysql-server-5.0

就成功了 :em11
但我也不明白为啥 :em02
哪位高手能给解释一下?
yb0327
帖子: 196
注册时间: 2006-06-27 12:30
送出感谢: 0
接收感谢: 0

Re: 关于”MySQL安装时出现包依赖错误“的问题!

#2

帖子 yb0327 » 2008-12-26 20:47

你给出的错误信息中已经说明你错在哪里了,自己看看,软件依赖问题,他说你没有配置什么你见装什么就是了,也可以看看http://wiki.ubuntu.org.cn/index.php?tit ... iant=zh-cn
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

Re: 关于”MySQL安装时出现包依赖错误“的问题!

#3

帖子 Element » 2008-12-26 20:52

用apt-get -f install mysql-server不行
你这个包名就不对
用 aptitude 来安装的时候会自动解决依赖关系的,或者你去新利得安装,也会自动解决以来关系的
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
绿色植物
帖子: 35
注册时间: 2008-12-22 19:40
送出感谢: 0
接收感谢: 0

Re: 关于”MySQL安装时出现包依赖错误“的问题!

#4

帖子 绿色植物 » 2008-12-26 21:57

yb0327 写了:你给出的错误信息中已经说明你错在哪里了,自己看看,软件依赖问题,他说你没有配置什么你见装什么就是了,也可以看看http://wiki.ubuntu.org.cn/index.php?tit ... iant=zh-cn
那么ubuntu文档(https://help.ubuntu.com/8.04/serverguide/C/mysql.html)里写的就不全了,它没写mysql-client.
而且依赖的软件好多啊。一个依赖于另一个,排了一小队才停下。
哈哈,我也真笨的,怎么忘了看wiki呢 :em04
绿色植物
帖子: 35
注册时间: 2008-12-22 19:40
送出感谢: 0
接收感谢: 0

Re: 关于”MySQL安装时出现包依赖错误“的问题!

#5

帖子 绿色植物 » 2008-12-26 22:14

Element 写了: 你这个包名就不对
用 aptitude 来安装的时候会自动解决依赖关系的,或者你去新利得安装,也会自动解决以来关系的
Synaptic好像不能自动解决依赖关系,我在那要装mysql-server-5.0也会提示包依赖错误。

那个aptitude我查了一下,好像说:“apt-get也是Debian最基本的包管理程序,aptitude功能比apt-get强大。安装软件的时候aptitude会加上所需依赖而 apt-get不会,删除软件的时候aptitude会去掉依赖而apt-get不会。所以apt-get只安装或删除指定包,而aptitude会把一些它认为不需要的包给删掉。所以我一般用apt-get下载源码,用apitude安装软件。“

下次我要试试。现在这个mysql好不容易装上了,再卸掉真是不容易,我还没学卸载呢,呵呵。 :em02
绿色植物
帖子: 35
注册时间: 2008-12-22 19:40
送出感谢: 0
接收感谢: 0

Re: 关于”MySQL安装时出现包依赖错误“的问题!

#6

帖子 绿色植物 » 2008-12-28 21:02

新发现一点:要想用mysql进行数据库开发,还要安装libmysqlclient15-dev才行。也用aptitude install. :em02
回复

回到 “归档贴”