最近编译kile遇到的一个问题

重复贴和参考价值不大的帖子,版主维护
回复
vanillahill
帖子: 2
注册时间: 2007-06-25 1:33
送出感谢: 0
接收感谢: 0

最近编译kile遇到的一个问题

#1

帖子 vanillahill » 2008-12-28 23:04

说找不到kde的头文件
于是装kdelibs4-dev
结果不让装,查来查去根源在libasound2-dev装不上,说是libasound2-dev依赖于libasound2的1.5.XXX版的,而系统里的是1.6.XXX版的
最后倒是解决了,用新立得里的强制版本把libasound2设为上一个版本,不过心里总是很不舒服

想来是ubuntu忘了把新版的alsa开发库放到源里了
头像
AutoXBC
帖子: 1750
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 最近编译kile遇到的一个问题

#2

帖子 AutoXBC » 2008-12-28 23:24

软件包 libasound2-dev
dapper (libdevel): ALSA library development files
1.0.10-2ubuntu4: amd64 i386 powerpc
feisty (libdevel): ALSA library development files
1.0.13-1ubuntu5: amd64 i386 powerpc
gutsy (libdevel): ALSA library development files
1.0.14-1ubuntu8: amd64 i386 powerpc
hardy (libdevel): ALSA library development files
1.0.15-3ubuntu4: amd64 i386

intrepid (libdevel): ALSA library development files
1.0.17a-0ubuntu4: amd64 i386
jaunty (libdevel): shared library for ALSA applications. Development files
1.0.18-1ubuntu1: amd64 i386

**********************

hardy

ALSA library development files

This package contains files required for developing software that makes use of libasound2, the ALSA library.

ALSA 是 Advanced Linux Sound Architecture(高级 Linux 音频架构)的缩写。
其它与 libasound2-dev 有关的软件包依赖 推荐 建议

libasound2 (= 1.0.15-3ubuntu4)
ALSA library
libc6-dev
GNU C Library: Development Libraries and Header Files
或者 libc-dev
本虚包由这些包填实: libc6-dev
libasound2-doc
ALSA library developer documentation

*********************

软件包 libasound2
dapper (libs): ALSA library
1.0.10-2ubuntu4: amd64 i386 powerpc
feisty (libs): ALSA library
1.0.13-1ubuntu5: amd64 i386 powerpc
gutsy (libs): ALSA library
1.0.14-1ubuntu8: amd64 i386 powerpc
hardy (libs): ALSA library
1.0.15-3ubuntu4: amd64 i386

intrepid (libs): ALSA library
1.0.17a-0ubuntu4: amd64 i386
jaunty (libs): shared library for ALSA applications
1.0.18-1ubuntu1: amd64 i386

***************

hardy 中都是平行的 1.0.15,楼主怎么会装出一个 1.0.16 的 libasound2 。intrepid 中都是平行的 1.0.17,怎么会装出一个依赖 1.0.15 libasound2 的 libasound2-dev 。
头像
pt0079
帖子: 82
注册时间: 2007-02-07 17:53
来自: SEU_Radio
送出感谢: 0
接收感谢: 0
联系:

Re: 最近编译kile遇到的一个问题

#3

帖子 pt0079 » 2008-12-31 0:25

vanillahill 写了:说找不到kde的头文件
于是装kdelibs4-dev
结果不让装,查来查去根源在libasound2-dev装不上,说是libasound2-dev依赖于libasound2的1.5.XXX版的,而系统里的是1.6.XXX版的
最后倒是解决了,用新立得里的强制版本把libasound2设为上一个版本,不过心里总是很不舒服

想来是ubuntu忘了把新版的alsa开发库放到源里了
LTS对开发者确实是比较恶心的,可以到launchpad把1.0.16的libasound2-dev的deb下载下来,也是for hardy的,装上就没事了

类似的问题也可以通过launchpad解决
头像
pt0079
帖子: 82
注册时间: 2007-02-07 17:53
来自: SEU_Radio
送出感谢: 0
接收感谢: 0
联系:

Re: 最近编译kile遇到的一个问题

#4

帖子 pt0079 » 2008-12-31 0:27

AutoXBC 写了:软件包 libasound2-dev
dapper (libdevel): ALSA library development files
1.0.10-2ubuntu4: amd64 i386 powerpc
feisty (libdevel): ALSA library development files
1.0.13-1ubuntu5: amd64 i386 powerpc
gutsy (libdevel): ALSA library development files
1.0.14-1ubuntu8: amd64 i386 powerpc
hardy (libdevel): ALSA library development files
1.0.15-3ubuntu4: amd64 i386

intrepid (libdevel): ALSA library development files
1.0.17a-0ubuntu4: amd64 i386
jaunty (libdevel): shared library for ALSA applications. Development files
1.0.18-1ubuntu1: amd64 i386

**********************

hardy

ALSA library development files

This package contains files required for developing software that makes use of libasound2, the ALSA library.

ALSA 是 Advanced Linux Sound Architecture(高级 Linux 音频架构)的缩写。
其它与 libasound2-dev 有关的软件包依赖 推荐 建议

libasound2 (= 1.0.15-3ubuntu4)
ALSA library
libc6-dev
GNU C Library: Development Libraries and Header Files
或者 libc-dev
本虚包由这些包填实: libc6-dev
libasound2-doc
ALSA library developer documentation

*********************

软件包 libasound2
dapper (libs): ALSA library
1.0.10-2ubuntu4: amd64 i386 powerpc
feisty (libs): ALSA library
1.0.13-1ubuntu5: amd64 i386 powerpc
gutsy (libs): ALSA library
1.0.14-1ubuntu8: amd64 i386 powerpc
hardy (libs): ALSA library
1.0.15-3ubuntu4: amd64 i386

intrepid (libs): ALSA library
1.0.17a-0ubuntu4: amd64 i386
jaunty (libs): shared library for ALSA applications
1.0.18-1ubuntu1: amd64 i386

***************

hardy 中都是平行的 1.0.15,楼主怎么会装出一个 1.0.16 的 libasound2 。intrepid 中都是平行的 1.0.17,怎么会装出一个依赖 1.0.15 libasound2 的 libasound2-dev 。
这个要问ubuntu的人啊
头像
AutoXBC
帖子: 1750
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 最近编译kile遇到的一个问题

#5

帖子 AutoXBC » 2008-12-31 10:24

我说的比较明白了吧,Ubuntu 中的包都是版本匹配的,出现问题的原因应该是混源使用,或者自己手动编译了什么包,这不是系统的问题。
回复

回到 “归档贴”