已有xp,又安装了Ubuntu(DVD光盘版),安装完成之后重新启动,怎么没有出现双系统菜单呢?

重复贴和参考价值不大的帖子,版主维护
回复
helloworld222
帖子: 577
注册时间: 2008-11-17 13:46
送出感谢: 1 次
接收感谢: 0

已有xp,又安装了Ubuntu(DVD光盘版),安装完成之后重新启动,怎么没有出现双系统菜单呢?

#1

帖子 helloworld222 » 2009-01-01 14:40

安装完成之后,提示拿出光盘,重新启动,却没有看到啊
应该是要有的,对吗?
头像
akg240s
帖子: 45
注册时间: 2008-10-24 20:44
送出感谢: 0
接收感谢: 0

Re: 已有xp,又安装了Ubuntu(DVD光盘版),安装完成之后重新启动,怎么没有出现双系统菜单呢?

#2

帖子 akg240s » 2009-01-01 16:08

我是在windows xp下采用Wubi安装,重启后就出现双启动菜单了。
好像只有wubi和多重引导方式安装才能双系统菜单
xtr
帖子: 4
注册时间: 2009-01-01 8:45
送出感谢: 0
接收感谢: 0

Re: 已有xp,又安装了Ubuntu(DVD光盘版),安装完成之后重新启动,怎么没有出现双系统菜单呢?

#3

帖子 xtr » 2009-01-01 17:14

现在windows下建立空白分区在装。。手动分区。。
helloworld222
帖子: 577
注册时间: 2008-11-17 13:46
送出感谢: 1 次
接收感谢: 0

Re: 已有xp,又安装了Ubuntu(DVD光盘版),安装完成之后重新启动,怎么没有出现双系统菜单呢?

#4

帖子 helloworld222 » 2009-01-01 17:30

:em11 终于搞定了!

1、复制两个文件到C盘
grldr(网上下载的)
menu.list(从安装后的Ubuntu的/boot/grub这个文件夹里复制出来)

2、在C盘创建一个名为 boot 的文件夹
从Ubuntu安装光盘里复制下面这两个文件到 boot 文件夹里
initrd.img-2.6.27-7-generic
vmlinuz-2.6.27-7-generic

3、修改 boot.ini
增加一行:
c:\grldr="Ubuntu"

重新启动计算机,OK!

第1个步骤是从论坛的另一个版块学的
第2个步骤为什么要复制那两个文件,是刚要启动Ubuntu的时候,提示文件不存在。我就照着文件名复制了
头像
jimhu
帖子: 1322
注册时间: 2006-01-25 22:29
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

Re: 已有xp,又安装了Ubuntu(DVD光盘版),安装完成之后重新启动,怎么没有出现双系统菜单呢?

#5

帖子 jimhu » 2009-01-01 21:35

引导程序没有安装。

是不是因为LZ有两块硬盘?如果是的话,调整一下启动顺序。
还有就是安装到最终开始前,是不是选择过“高级”,把Grub装到其他地方去了?或者甚至没有安装?
* MACBOOK MB063CH/B
OS:Snow Leopard/XP
* AMD X2 3600+/2G RAM/160GB+500GB Seagate/7300GT
OS:Arch/Vista

Kubuntu User #18899

=================================
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊
http://www.freeearth.org.cn
helloworld222
帖子: 577
注册时间: 2008-11-17 13:46
送出感谢: 1 次
接收感谢: 0

Re: 已有xp,又安装了Ubuntu(DVD光盘版),安装完成之后重新启动,怎么没有出现双系统菜单呢?

#6

帖子 helloworld222 » 2009-01-01 21:56

jimhu 写了:引导程序没有安装。

是不是因为LZ有两块硬盘?如果是的话,调整一下启动顺序。
还有就是安装到最终开始前,是不是选择过“高级”,把Grub装到其他地方去了?或者甚至没有安装?
我只有一块硬盘。
估计是"高级“那里出了问题。我曾经打开过“高级“,也忘了也没有修改过设置了。
回复

回到 “归档贴”