当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-01-13 14:58 

注册: 2008-11-03 19:06
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
升级到9.04后 显卡驱动挂掉了 重装显卡驱动依然不行
显卡是 ATI HD 3200
技嘉780G的主板 集成HD3200 出错代码 部分 是:
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0xdc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@1:5:0) ATI Technologies Inc Radeon HD 3200 Graphics rev 0, Mem @ 0xd8000000/134217728, 0xfdfe0000/65536, 0xfde00000/1048576, I/O @ 0x0000ee00/256
(II) Open ACPI successful (/var/run/acpid.socket)
……
……
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
dlopen: /usr/lib/xorg/modules/extensions//libglx.so: undefined symbol: miInitVisualsProc
(EE) Failed to load /usr/lib/xorg/modules/extensions//libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.5.99.3, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 7.4.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(EE) module ABI major version (1) doesn't match the server's version (2)
(II) UnloadModule: "dri"
(II) Unloading /usr/lib/xorg/modules/extensions//libdri.so
(EE) Failed to load module "dri" (module requirement mismatch, 0)


_________________
支持Linux 发展 灭掉Windows


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-01-14 15:37 

注册: 2007-02-19 16:07
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
recovery mode, xfix
重启
进桌面,卸载与fglrx相关内容
sudo apt-get remove fglrx-amdcccle fglrx-kernel-source fglrx-modaliases
重启

OK


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-01-20 14:17 

注册: 2008-03-05 13:25
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
jemy.zhang 写道:
recovery mode, xfix
重启
进桌面,卸载与fglrx相关内容
sudo apt-get remove fglrx-amdcccle fglrx-kernel-source fglrx-modaliases
重启

OK

这里的ok指的是能进桌面了还是?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-01-20 20:27 

注册: 2009-01-20 20:19
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
:em20
楼主幽默!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-01-31 14:22 

注册: 2009-01-31 8:47
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
9.04的ATI 显卡驱动问题的问题有没有解决阿???我这里也在等哦!!!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-02-01 17:05 

注册: 2008-01-30 19:19
帖子: 794
送出感谢: 0 次
接收感谢: 0 次
排队吧,俺也是一个
等解决方案


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-02-01 17:35 

注册: 2008-11-13 22:56
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
前几天刚解决了9.04的显卡问题。
不过,我用的是nvidia的卡,希望对楼主有帮助。

看错误信息应该和我当时碰到是类似的错误:ABI不匹配。

在/etc/X11/xorg.conf中加入:

Section "ServerFlags"
Option "IgnoreABI" "TRUE"
EndSection


YY几句:
就个人使用感觉来说:ext4比ext3要快很多啊,而且不知是2.26.8-6内核还是gnome2.25的原因,整体桌面环境的响应速度提高了一些,cpu占用低了不少(top看的话,裸桌面环境下,cpu的idle在95%左右,原来8.10时在85%左右)
虽然,现在声音还是时不时的出点毛病,另外为了干净的ext4,重装的系统,连带恢复数据折腾了好几天,不过不后悔当了一回alpha版的小白鼠。

ps:alpha3 iso中是2.26.8-4的内核,有很多的问题,装好后速度升级到2.26.8-6内核先,呵呵。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-02-02 18:44 

注册: 2008-01-30 19:19
帖子: 794
送出感谢: 0 次
接收感谢: 0 次
楼上的兄弟,这个方法只搞掉了abi,
还是搞不定xwindow


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-02-02 18:51 

注册: 2008-11-13 22:56
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我用的n卡,sudo nvidia-xconfig自动重做xorg.conf,然后手工加上IgnoreABI就可以了。
ati的卡没搞过。。。 :em06


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-02-03 11:02 

注册: 2008-01-30 19:19
帖子: 794
送出感谢: 0 次
接收感谢: 0 次
总算可以进入桌面了
一通修理搞定的,大概是我编译Gnome games造成的吧,当时编译安装了一些可能和桌面冲突的东西:
atk-1.25.2
cairo-1.8.6
glib-2.19.4
libpng-1.2.34
pango-1.22.4
pixman-0.12.0
我把它们全部重新 make uninstall 了


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-04-17 11:57 
头像

注册: 2008-03-30 11:42
帖子: 621
送出感谢: 0 次
接收感谢: 1
不知道今天发行的RC版本怎么样啊,有没有解决ATI显卡问题。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-04-17 13:30 
头像

注册: 2007-05-07 8:21
帖子: 170
送出感谢: 0 次
接收感谢: 0 次
rc对ati驱动没变化


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-04-17 13:42 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
HD2600
没有问题


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-04-17 13:46 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
坚决不做小白在没有证实ati3200可以用受限制驱动之前,开源也不错,不过不能玩游戏了


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 9.04的ATI 显卡驱动问题
帖子发表于 : 2009-04-17 14:39 
头像

注册: 2007-07-22 12:13
帖子: 396
送出感谢: 1
接收感谢: 0 次
原先安装受限驱动,结果桌面都进不去。
卸载驱动后屏闪得厉害,今天更新系统后重启,效果又如安装时,不过也就安装了mesa什么的,并不是针对ATI的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译