当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 【已解决】痛苦了整整两天的 开机启动配置
帖子发表于 : 2009-01-18 21:13 

注册: 2009-01-18 20:55
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我的utuntu是8.04

1. 首先我要说的是,如果我直接修改 /etc/init.d/rc.local 文件,在它的尾部加入我要开机启动的脚本:
/opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin/startServer.sh server1
是可以正常启动, 但必须是输入完用户名和密码后,登录系统后才可以启动, 有没有办法在机器启动完后,就自己起来了?

2.我想通过第二种方法看看行不行。于是照着google上的答案, 在/etc/init.d/建立一个叫 websphere 的文件,内容为:
#! /bin/sh
/opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin/startServer.sh server1

然后在 init.d 目录下测试一下,该脚本是否正常:

**@**:/etc/init.d$ ./websphere

发现一切正常。

然后回到 /etc/rc3.d
进行软连接: ln ../init.d/websphere ./S60websphere

继续在 rc3.d 目录下测试一下,该脚本是否正常:

**@**:/etc/rc3.d$ ./websphere

仍然可以起来, 也就是说 init.d的脚本 和 rc3.d下的软连接是完全没有问题。


现在问题是,我重启utuntu后,发现我的那个服务还是起不来。 请问大家我这样的步骤有错误吗? 网上千篇一律都是这样的, 大家遇到过这样的问题吗?

已经痛苦两天了,希望星期一能解决。


-----------------------无语的解决方法------------------------------
解决方法其实非常简单,目前的解决方法是将原来处于 rc3.d 级别下的 S20websphere 转到 rc2.d级别下即可。

真是非常奇怪,又非常郁闷的问题。

如果大家有更好的方法,希望不吝赐教。


最后由 superleo 编辑于 2009-01-18 22:47,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 痛苦了整整两天的 开机启动配置
帖子发表于 : 2009-01-18 21:18 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
问题1. 自动登录,在gdm设置那里找


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 痛苦了整整两天的 开机启动配置
帖子发表于 : 2009-01-18 21:22 
头像

注册: 2009-01-13 12:45
帖子: 150
地址: 【火星第6空间站】
送出感谢: 0 次
接收感谢: 0 次
:em06
不懂,帮顶了


_________________
上述内容仅代表我个人观点。若有不对之处请指出,谢谢!
我的论坛:http://freecool.5d6d.com
我的博客:http://yinjia.wordpress.com.cn/
我的邮箱: 198410111@qq.com
我的QQ: 198410111
有任何问题只要在我论坛提问,我一定尽量回答噢


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 痛苦了整整两天的 开机启动配置
帖子发表于 : 2009-01-18 21:39 

注册: 2009-01-18 20:55
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
lerosua 写道:
问题1. 自动登录,在gdm设置那里找


感谢,这个问题已经解决了,我目前的做法是在 /etc/init.d/gdm 的脚本里加上那句脚本即可。

关于 2. 真的没有办法了吗? 呵呵


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 痛苦了整整两天的 开机启动配置
帖子发表于 : 2009-01-18 21:48 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
很奇怪,第一项应该是不用登录就能启动的..


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 痛苦了整整两天的 开机启动配置
帖子发表于 : 2009-01-18 22:04 

注册: 2009-01-18 20:55
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我发现我那个在 /etc/init.d/websphere 脚本根本没有运行

因为我在 websphere 加一个句跟踪信息

echo "hello. rc.local" >>/home/superleo/rc.local

发现系统启动后,根本没有生成这个文件

而如果采用第一种方式都能生成。 真是奇怪啊。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译