分页: 1 / 1

很多软件装不了,说Wrong architecture 'i386'怎么办?

发表于 : 2009-01-26 3:29
boomboom_vicky
刚刚开始用Linux,觉得比vista快很多

不过装不上Skype 也装不上 Flash player 什么的,
都说Wrong architecture 'i386'
我按网上说的从终端里装,他说我少两个东西,一个是 libqt4-core, 还有一个是什么不记得了

这个问题怎么解决啊 ?

谢谢大家!!

Re: 很多软件装不了,说Wrong architecture 'i386'怎么办?

发表于 : 2009-01-26 10:11
topbluecat
你装的是64位版的Ubuntu,当然默认情况下装不上32位软件。
Flash Player 10有64位版的,在论坛内能找到。Skype可以在命令行下输入: dpkg -i --force-architecture (你要安装的.deb的文件名)

Re: 很多软件装不了,说Wrong architecture 'i386'怎么办?

发表于 : 2009-01-26 14:10
jimhu
在论坛搜索ai32

Re: 很多软件装不了,说Wrong architecture 'i386'怎么办?

发表于 : 2009-01-26 16:20
boomboom_vicky
我用了dpkg -i --force-architecture skype-debian_2.0.0.72-1_i386.deb
他跟我说需要‘超级用户权限’是怎么回事阿?

Re: 很多软件装不了,说Wrong architecture 'i386'怎么办?

发表于 : 2009-01-26 17:32
yyu0378
sudo dpkg -i --force-architecture skype-debian_2.0.0.72-1_i386.deb然后输入密码就可以了

Re: 很多软件装不了,说Wrong architecture 'i386'怎么办?

发表于 : 2009-01-26 19:23
topbluecat
3楼,是ia32

Re: 很多软件装不了,说Wrong architecture 'i386'怎么办?

发表于 : 2009-01-27 14:00
jimhu
topbluecat 写了:3楼,是ia32
So Sorry,误人子弟了。