当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Problem / how to install the Ubuntu Tweak....
帖子发表于 : 2009-01-28 17:19 

注册: 2009-01-28 13:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
Read from http://jandy.cn/blog/?p=1147 regarding the Ubuntu Tweak which I downloaded and extract to my home folder. I follow the README and try to make the program but FAILED. Would someone please help on this.....

README...
How to build & test
========================
./configure --sysconfdir=/etc --prefix=/usr
make
sudo make install


gabriel@GY-UbuntuLINUX:~/ubuntu-tweak-0.4.4$ ./configure --sysconfdir=/etc --prefix=/usr
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.19... yes
checking for a Python interpreter with version >= 2.5... python
checking for python... /usr/bin/python
checking for python version... 2.5
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.5/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.5/site-packages
checking for TWEAK... configure: error: Package requirements (gtk+-2.0 >= 2.10
pygtk-2.0 >= 2.10
pygobject-2.0 >= 2.10
gnome-python-2.0 >= 2.10
) were not met:

No package 'gtk+-2.0' found
No package 'pygtk-2.0' found
No package 'pygobject-2.0' found
No package 'gnome-python-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables TWEAK_CFLAGS
and TWEAK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

gabriel@GY-UbuntuLINUX:~/ubuntu-tweak-0.4.4

gabriel@GY-UbuntuLINUX:~/ubuntu-tweak-0.4.4$ make
make: *** No targets specified and no makefile found. Stop.
gabriel@GY-UbuntuLINUX:~/ubuntu-tweak-0.4.4$ make install
make: *** No rule to make target `install'. Stop.
gabriel@GY-UbuntuLINUX:~/ubuntu-tweak-0.4.4$ sudo make install
make: *** No rule to make target `install'. Stop.
:em20 :em20 :em20 :em20 :em20 :em06 :em06 :em06 :em06 :em06 :em06


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Problem / how to install the Ubuntu Tweak....
帖子发表于 : 2009-01-28 22:44 
头像

注册: 2008-04-02 13:26
帖子: 3331
地址: 上海
送出感谢: 0 次
接收感谢: 1
If u use Ubuntu, just download the deb file: http://ubuntu-tweak.googlecode.com/file ... d1_all.deb

and then double click the deb file.


_________________
Blog: http://ttboke.com/ubuntu/
Google+: http://gplus.to/jandyzhu


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Problem / how to install the Ubuntu Tweak....
帖子发表于 : 2009-01-28 22:50 
头像

注册: 2008-08-11 14:35
帖子: 291
地址: Galaxy 581
送出感谢: 0 次
接收感谢: 0 次
It means that you haven't install something that ubuntutweak needed.
According to your console message, you should install gtk+ 2.0, pygtk-2.0, pygobject-2.0, gnome-python-2.0.

but I also agree with jandyzhu, for his method is faster and easier.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Problem / how to install the Ubuntu Tweak....
帖子发表于 : 2009-01-28 22:50 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
用 deb 包啊


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译