当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : GD库安装失败求助
帖子发表于 : 2009-02-04 17:51 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
安装php5-gd库,发现安装失败,信息如下:
引用:
linux@ubuntu:~$ sudo apt-get install php5-gd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-gd: Depends: php5-common (= 5.2.4-2ubuntu5.4) but 5.2.6-2ubuntu4 is to be installed
E: Broken packages
linux@ubuntu:~$


请问如何才能成功安装? 难道是php5.2.6默认已经支持gd库?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: GD库安装失败求助
帖子发表于 : 2009-02-04 18:40 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
引用:
onopoc at gmail dot com
22-Nov-2008 09:08
When using Ubuntu Server 8.04.1 & PHP5. If your GD installation isn't working properly or features are missing. You can install a complete bundled (forked) GD libraries without the need to recompile. The following worked for me: http://drupal.org/node/134331#comment-1120427


页首
 用户资料  
 
3 楼 
 文章标题 : Re: GD库安装失败求助
帖子发表于 : 2009-02-04 18:42 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
引用:
Thanks Djamu
Onopoc - November 22, 2008 - 00:28

Thanks Djamu your solution works for me.

Here is the steps for Ubuntu Server 8.04.1 and PHP5. Like Djamu said it will install a GD pre-compiled working version. It is a complete bundled (forked) GD libraries:

1. If not already done removing your current GD package and its configurations.
sudo apt-get --purge remove

2. Adding 2 lines to your file /etc/apt/sources.list

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

3. Updating your current apt-get list
apt-get update

4. Installing working GD package.
apt-get install php5-gd

It will complain about non-authenticated sources, just ignore, it will also update some additional php libs.

When prompt select keep_current modified php.ini

5. Restarting Apache
/etc/init.d/apache2 restart

Enjoy



页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译