当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 奇怪的依赖关系,求助!
帖子发表于 : 2009-02-09 23:51 
头像

注册: 2009-01-11 22:10
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
在用新立得装 libsvn-javahl 时,

标记它的时候提示“将会删除的软件包:libsvn-java”,

确认标记之后,却又提示“无法为安装或升级标记全部软件包” “下列软件包具有未满足的依赖关系……”

    libsvn-javahl:
    依赖: libsvn-java 但是此软件包将不会被安装

但是我标记 libsvn-java 重新安装的时候没有提示缺少依赖关系的软件包啊……

求助 :em20


_________________
Future more.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 奇怪的依赖关系,求助!
帖子发表于 : 2009-02-10 0:01 
头像

注册: 2007-08-08 16:12
帖子: 96
送出感谢: 0 次
接收感谢: 0 次
试一试
sudo aptitude install libsvn-javahl


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 奇怪的依赖关系,求助!
帖子发表于 : 2009-02-10 0:45 
头像

注册: 2009-01-11 22:10
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
行了,感谢,好像是以为以前的 libsvn-java 版本高于新立得上面的,这次安装的时候自动降级了

------------------

但是现在又出现了个问题,更新管理器会一直提示我需要升级那些软件包……orz

而升级那些软件包的,而升级的过程又要删除 libsvn-java :em20


_________________
Future more.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 奇怪的依赖关系,求助!
帖子发表于 : 2009-02-10 13:05 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
把那些提示升级的软件包lock了


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 奇怪的依赖关系,求助!
帖子发表于 : 2009-02-11 19:24 
头像

注册: 2009-01-11 22:10
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
怎么lock啊?我现在更新管理器那里都是灰色的,不能勾选什么的,一开更新管理器就提示需要升级……


_________________
Future more.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译