当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 13:44 
头像

注册: 2009-01-21 13:06
帖子: 89
送出感谢: 0 次
接收感谢: 0 次
~$ sudo apt-get install postfix
E: 无法获得锁 /var/lib/dpkg/lock - open (11 资源临时不可用)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

现在不能在线安装任何软件了,总是出来上述错误,请问怎么回事? :em20


_________________
分享是一种文化


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 13:45 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
is another process using it?


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 13:49 
头像

注册: 2009-01-21 13:06
帖子: 89
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
is another process using it?


问题出在安装postfix后出现configure界面 我选择 no configure 推出后就这样了,上面说的another process 不明白是是指哪个进程.


_________________
分享是一种文化


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 14:00 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
你是不是还开新利得?
或者还有个终端在安装软件?


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 14:09 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
如果没有其它apt程序运行的话,
代码:
rm /var/lib/dpkg/lock

删除掉锁就行了


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 14:12 
头像

注册: 2009-01-21 13:06
帖子: 89
送出感谢: 0 次
接收感谢: 0 次
Element 写道:
你是不是还开新利得?
或者还有个终端在安装软件?


恩 可能有其他终端在安装 我重启后在装 出现了新问题
~$ sudo apt-get install postfix
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
exim4-daemon-light: 依赖: exim4-base (>= 4.69) 但是它将不会被安装
冲突: mail-transport-agent
postfix: 冲突: mail-transport-agent

又糊涂了?用新得利说是exim4这个软件包受损,迷茫了 :em20 (以前apt-get install装软件都好好的)


_________________
分享是一种文化


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 15:45 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
您可能需要运行“apt-get -f install”来纠正下列错误:
sudo apt-get -f install


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 16:19 
头像

注册: 2009-01-21 13:06
帖子: 89
送出感谢: 0 次
接收感谢: 0 次
问题解决了 就在新的利下删除包再安装吧 谢谢大家指导


_________________
分享是一种文化


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 执行sudo apt-get install xxx 时碰到问题
帖子发表于 : 2009-02-17 17:23 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
加了翻译了

这个信息 E 得也够久了


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译