当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 大家帮帮我,找不到编译器!!
帖子发表于 : 2009-02-27 19:59 

注册: 2009-02-27 15:12
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
有个问你想请各位帮个忙都急死了!想编译无线网卡的驱动,
可是无论敲入 make 、make intall、还是gcc都会提示 :not found
【机子用的是华芯飞〔君正〕JZ4740的芯片】不会用喔,貌似主频是336mhz的,这个cpu的构架能什么软件呢?
刚刚入门,大家耐心看完我的问题,感激不尽!
我用敲入cat /proc/version
显示为:linux version 2.6.24.3 (zhaoyf@zhaoyf - desktop)
(gcc version 4.1.2)#30 PREEMPT Fri Aug 29 17:39:40 HKT 2008
的确安装了gcc,按照上面的显示的应该是 gcc 4.1.2
google了一下有人说要配置环境变量才能用。我把那个profile给拷了出来了,下面就是文件里的内容:
export PS1='# '
export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin
export PATH=$PATH:/usr/cpufreqd/sbin:/usr/alsa/bin:/usr/tslib/bin
export LD_LIBRARY_PATH=/lib:/usr/cpufreqd/lib:/usr/alsa/lib:/usr/tslib/lib
export TSLIB_ROOT=/usr/tslib
export TSLIB_CONSOLEDEVICE=none
export TSLIB_FBDEVICE=/dev/fb
export TSLIB_TSDEVICE=/dev/ts
export TSLIB_CALIBFILE=/etc/pointercal
export TSLIB_CONFFILE=$TSLIB_ROOT/etc/ts.conf
export TSLIB_PLUGINDIR=$TSLIB_ROOT/lib/ts
export ALSA_CONFIG_PATH=/usr/alsa/share/alsa.conf
我是个新手!初来乍到,又都看不懂//(ㄒoㄒ)//自己在bin文件夹找到了很多命令文件,可是没有找到make gcc 一类的命令不晓得是怎么回事?是不是缺少什么文件呢,都好多天了,一点进展都没有,希望各位能够帮帮我,不胜感激!谢谢
::>_<::


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 大家帮帮我,找不到编译器!!
帖子发表于 : 2009-02-27 21:15 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
先上Wiki看下,把编译工具链和一些基础库装全了,再来编译,使用Locate命令可以看下你要找的命令或软件可执行程序在哪里!


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 大家帮帮我,找不到编译器!!
帖子发表于 : 2009-02-27 23:57 

注册: 2009-02-27 15:12
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
嗯!谢谢!O(∩_∩)O~~
可是看得不太懂喔,编译工具链和基础库可以直接装吗,要怎么才能装呢?cpu构架不同,软件不能通用,是不是可以通过编译解决呢?
可以说的详细点吗?要怎么用命令呢?或者给我个链接也行,在google找了好久都没什么收获…
谢谢啦 :)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 大家帮帮我,找不到编译器!!
帖子发表于 : 2009-02-28 0:00 

注册: 2009-02-27 15:12
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
#locate
-sh: locate: not found


好像又缺文件了\(╯-╰)/


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 大家帮帮我,找不到编译器!!
帖子发表于 : 2009-02-28 0:04 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
引用:
准备基本编译工具
打开新立得,搜索“build-essential、autoconf、automake1.10、cvs、subversion”五个软件包,依次标记,最后点击“应用”即可安装。
或者粘贴下面命令一键安装:
代码:
sudo apt-get install build-essential autoconf automake cvs subversion


来自wiki
多看下wiki


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 大家帮帮我,找不到编译器!!
帖子发表于 : 2009-02-28 11:06 

注册: 2009-02-27 15:12
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
嗯!谢谢!我试试看


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译