当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:30 

注册: 2009-03-04 12:26
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
如题,小弟在安装软件时出现如下错误,软件不能安装,请教各位高手这是为什么??
小弟十万火急,谢谢
checking build system type... x86_64-unknown-linux-gnu
checking architecture... amd64
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf90... no
checking for pathf95... no
checking for g95... no
checking for gfortran... no
checking for f90... no
checking for Fortran 77 compiler default output file name... configure: error: Fortran 77 compiler cannot create executables
See `config.log' for more details.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:33 
头像

注册: 2008-06-08 13:31
帖子: 361
地址: 福州
送出感谢: 0 次
接收感谢: 1
编译器没装?什么软件?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:38 
头像

注册: 2008-05-31 17:27
帖子: 1025
地址: SUES
送出感谢: 0 次
接收感谢: 0 次
sudo?

话说这难道不是deb?


_________________
我的Ubuntu相关
--------------------
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:39 

注册: 2009-03-04 12:26
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
我开始也以为是,但是装gcc时提示版本为最新,小弟安装的是材料模拟计算用的一个软件,叫pw什么


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:40 

注册: 2009-03-04 12:26
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
是tar.gz,是不是这种格式的就需要解压编译阿??


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:42 
头像

注册: 2008-06-08 13:31
帖子: 361
地址: 福州
送出感谢: 0 次
接收感谢: 1
你运行下面这个命令再试一下
sudo apt-get install gfortran


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:43 
头像

注册: 2008-06-08 13:31
帖子: 361
地址: 福州
送出感谢: 0 次
接收感谢: 1
cheapskate 写道:
是tar.gz,是不是这种格式的就需要解压编译阿??

一个软件如果以 .tar.gz 发布则通常是源码包,源码包当然需要编译安装咯


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:46 

注册: 2009-03-04 12:26
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install gfortran
这个命令是干什么用的,小弟新学


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:47 

注册: 2009-03-04 12:26
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
upsuper 写道:
cheapskate 写道:
是tar.gz,是不是这种格式的就需要解压编译阿??

一个软件如果以 .tar.gz 发布则通常是源码包,源码包当然需要编译安装咯

呵呵,谢大侠教导,小弟新学,什么也不懂


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:49 
头像

注册: 2008-06-08 13:31
帖子: 361
地址: 福州
送出感谢: 0 次
接收感谢: 1
cheapskate 写道:
sudo apt-get install gfortran
这个命令是干什么用的,小弟新学

这个是从源里安装gfortran的,看到你给的错误我给你解释一下吧
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf90... no
checking for pathf95... no
checking for g95... no
checking for gfortran... no
checking for f90... no
表示上面这些东西都没找到,然后告诉你
checking for Fortran 77 compiler default output file name... configure: error: Fortran 77 compiler cannot create executables
就是说没找到Fortran 77的编译器,这说明上面那群就是可用的编译器,有一个即可编译……
我查了一下,只有gfortran在ubuntu源里有现成的,出于方便考虑,就建议你执行那个了


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:50 
头像

注册: 2008-06-08 13:31
帖子: 361
地址: 福州
送出感谢: 0 次
接收感谢: 1
cheapskate 写道:
upsuper 写道:
cheapskate 写道:
是tar.gz,是不是这种格式的就需要解压编译阿??

一个软件如果以 .tar.gz 发布则通常是源码包,源码包当然需要编译安装咯

呵呵,谢大侠教导,小弟新学,什么也不懂

其实我也刚接触ubuntu不久……一路在众人的帮助下慢慢懂了些东西……


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 12:56 

注册: 2009-03-04 12:26
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
upsuper 写道:
cheapskate 写道:
sudo apt-get install gfortran
这个命令是干什么用的,小弟新学

这个是从源里安装gfortran的,看到你给的错误我给你解释一下吧
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf90... no
checking for pathf95... no
checking for g95... no
checking for gfortran... no
checking for f90... no
表示上面这些东西都没找到,然后告诉你
checking for Fortran 77 compiler default output file name... configure: error: Fortran 77 compiler cannot create executables
就是说没找到Fortran 77的编译器,这说明上面那群就是可用的编译器,有一个即可编译……
我查了一下,只有gfortran在ubuntu源里有现成的,出于方便考虑,就建议你执行那个了

谢谢了,正在安装,希望能行


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-03-04 13:02 
头像

注册: 2008-06-08 13:31
帖子: 361
地址: 福州
送出感谢: 0 次
接收感谢: 1
cheapskate 写道:
upsuper 写道:
cheapskate 写道:
sudo apt-get install gfortran
这个命令是干什么用的,小弟新学

这个是从源里安装gfortran的,看到你给的错误我给你解释一下吧
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf90... no
checking for pathf95... no
checking for g95... no
checking for gfortran... no
checking for f90... no
表示上面这些东西都没找到,然后告诉你
checking for Fortran 77 compiler default output file name... configure: error: Fortran 77 compiler cannot create executables
就是说没找到Fortran 77的编译器,这说明上面那群就是可用的编译器,有一个即可编译……
我查了一下,只有gfortran在ubuntu源里有现成的,出于方便考虑,就建议你执行那个了

谢谢了,正在安装,希望能行

这个好像不大吧……你源要配置好的……快的源(如网易)每秒可以下载2MB……慢的几百字节的就……


页首
 用户资料  
 
14 楼 
 文章标题 : Re: [求助]在ubuntu8.04下安装软件是的错误
帖子发表于 : 2009-05-25 6:30 

注册: 2008-12-25 13:57
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
装好了能用pathf95命令马?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译