[求助}您的系统里有 1 个(依赖关系)毁损的软件包! 请使用“Broken”过滤器定位它们。

重复贴和参考价值不大的帖子,版主维护
回复
dynamic0603
帖子: 259
注册时间: 2008-11-14 20:35
送出感谢: 0
接收感谢: 1 次

[求助}您的系统里有 1 个(依赖关系)毁损的软件包! 请使用“Broken”过滤器定位它们。

#1

帖子 dynamic0603 » 2009-03-04 20:49

[求助}您的系统里有 1 个(依赖关系)毁损的软件包! 请使用“Broken”过滤器定位它们。怎么办?
dynamic0603
帖子: 259
注册时间: 2008-11-14 20:35
送出感谢: 0
接收感谢: 1 次

Re: [求助}您的系统里有 1 个(依赖关系)毁损的软件包! 请使用“Broken”过滤器定位它们。

#2

帖子 dynamic0603 » 2009-03-04 20:55

[补充]:
正在解压缩 libglib1.2ldbl (从 .../libglib1.2ldbl_1.2.10-19build1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/libglib1.2ldbl_1.2.10-19build1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/libglib-1.2.so.0.0.10”,它属于软件包 glib
在处理时有错误发生:
/var/cache/apt/archives/libglib1.2ldbl_1.2.10-19build1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
zw026
帖子: 89
注册时间: 2009-01-21 13:06
送出感谢: 0
接收感谢: 0

Re: [求助}您的系统里有 1 个(依赖关系)毁损的软件包! 请使用“Broken”过滤器定位它们。

#3

帖子 zw026 » 2009-03-04 21:16

dynamic0603 写了:[补充]:
正在解压缩 libglib1.2ldbl (从 .../libglib1.2ldbl_1.2.10-19build1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/libglib1.2ldbl_1.2.10-19build1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/libglib-1.2.so.0.0.10”,它属于软件包 glib
在处理时有错误发生:
/var/cache/apt/archives/libglib1.2ldbl_1.2.10-19build1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
两种方法:
1.新利得 --> 点左边窗口全部下面的已损坏 --> 选择损坏的依赖关系的关键包 --> 执行(左上的那个勾) --> ok
2. $sudo dpkg --configure -a 好像 $ sudo apt-get check 也可以
分享是一种文化
jond
帖子: 38
注册时间: 2008-06-18 17:49
送出感谢: 0
接收感谢: 0

Re: [求助}您的系统里有 1 个(依赖关系)毁损的软件包! 请使用“Broken”过滤器定位它们。

#4

帖子 jond » 2009-04-28 9:20

学习了,谢谢!
回复

回到 “归档贴”