求救:开机usplash不显示. ( menu.lst中添加"vga=791"后不能进入X。)

重复贴和参考价值不大的帖子,版主维护
回复
头像
haosir2
帖子: 55
注册时间: 2007-09-07 17:55
送出感谢: 0
接收感谢: 0
联系:

求救:开机usplash不显示. ( menu.lst中添加"vga=791"后不能进入X。)

#1

帖子 haosir2 » 2009-03-06 2:11

我在menu.lst启动菜单中添加了一句vga=791后,不能进入X,错误如下:
Failed to start the X sever(your graphical interface)
The X sever can not run in framebuffer mode.Please specify busIDs for all framebuffer divices.

我用recover模式进入,把vga=791去掉然后就能正常进入X了。但是我想知道为什么,希望高手指导。我希望既使用vga=791 这个参数使我的ubuntu在字符界面也是1024x768分辨率,又能正常进入X。
上面的问题已解决
adagio 写了:
haosir2 写了:很奇怪,我的ubuntu的 /etc/X11/ 下没有xorg.conf 这个文件。
:shock: 这个这个……
确实没有。原来我用ubuntu的时候是有的,后来从8.04开始就没了,也可以进入X,设置分辨率。
安装9.04后,因为分辨率设置不好,我就自己编了一个。而且如果我的Ubuntu因为X配置错误不能进入图形界面,我把xorg.conf删除就能进了。

现在VGA问题已经解决了,安装了5楼 eexpress 所说的几个软件包就可以了。
现在的问题是开机不会显示我自己安装的usplash画面。(原来是ubuntu studio的,太难看就卸了,自己安了个usplash-theme-fingerprint)
我是按照readme里安装的;
sudo cp usplash-theme-fingerprint.so /usr/lib/usplash
sudo update-alternatives --install /usr/lib/usplash/usplash-artwork.so usplash-artwork.so /usr/lib/usplash/usplash-theme-fingerprint.so 10
sudo update-alternatives --config usplash-artwork.so
sudo update-initramfs -u

预览:
sudo usplash -c
提示:

代码: 全选

usplash: can't get console font: Invalid argument
usplash: No usable theme found for 1024x768
screen init failed
换回默认的就没问题,不过也有错误提示:usplash: can't get console font: Invalid argument
上次由 haosir2 在 2009-03-06 15:35,总共编辑 1 次。
头像
daf3707
论坛版主
帖子: 12667
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#2

帖子 daf3707 » 2009-03-06 8:30

要启用framebuffer
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#3

帖子 eexpress » 2009-03-06 8:58

启用就是vga这句。
是要安装fb。
● 鸣学
头像
haosir2
帖子: 55
注册时间: 2007-09-07 17:55
送出感谢: 0
接收感谢: 0
联系:

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#4

帖子 haosir2 » 2009-03-06 12:40

eexpress 写了:启用就是vga这句。
是要安装fb。
怎么安装fb呢,ubuntu默认不支持吗?我以前就直接用了啊,还能用zhcon。我现在是9.04,怎么会不支持呢?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#5

帖子 eexpress » 2009-03-06 12:44

从某个版本开始,ub默认不安装fb的。你自己安装吧。

☎ as ~i~dframebuffer
id liballegro4.2 - portable library for cross-platform game a
i A libggi2 - General Graphics Interface runtime librari
i libsdl1.2debian - Simple DirectMedia Layer
i libsdl1.2debian-alsa - Simple DirectMedia Layer (with X11 and ALS
i A libxine1-console - libaa/libcaca/framebuffer/directfb related
i libxxf86dga1 - X11 Direct Graphics Access extension libra
i usplash - Userspace bootsplash utility
i w3m-img - inline image extension support utilities f
i xserver-xorg-video-fbdev - X.Org X server -- fbdev display driver
i zhcon - A Fast Console CJK System Using FrameBuffe
● 鸣学
头像
HuntXu
论坛版主
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#6

帖子 HuntXu » 2009-03-06 12:46

你的xorg.conf指定显卡的busid
HUNT Unfortunately No Talent...
头像
haosir2
帖子: 55
注册时间: 2007-09-07 17:55
送出感谢: 0
接收感谢: 0
联系:

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#7

帖子 haosir2 » 2009-03-06 13:38

HuntXu 写了:你的xorg.conf指定显卡的busid
很奇怪,我的ubuntu的 /etc/X11/ 下没有xorg.conf 这个文件。
头像
adagio
论坛版主
帖子: 22109
注册时间: 2008-02-17 23:47
来自: 美丽富饶的那啥星球
送出感谢: 7 次
接收感谢: 74 次

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#8

帖子 adagio » 2009-03-06 14:40

haosir2 写了:很奇怪,我的ubuntu的 /etc/X11/ 下没有xorg.conf 这个文件。
:shock: 这个这个……
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 求救:menu.lst中添加"vga=791"后不能进入X

#9

帖子 eexpress » 2009-03-06 14:49

和xorg.conf 何关啊。不要管的。
● 鸣学
回复

回到 “归档贴”