安装sunpinyin 问题

重复贴和参考价值不大的帖子,版主维护
回复
ewha
帖子: 13
注册时间: 2009-03-08 10:05
送出感谢: 0
接收感谢: 0

安装sunpinyin 问题

#1

帖子 ewha » 2009-03-09 14:03

编译好debian官方sunpinyin,安装出问题,我以为编译的不行(刚学习),下载人家的编译好的,也不行。
我系统是AMD64环境,安装ubuntu64 8.04。出现这个问题:
dependency is not satisfiable: libgtk2.0-0 (依附文件不符合要求)

我试着在网上找libgtk2.0的包,安装,系统提示有更高版本的libgtk。请问高手怎么解决?

注:下载安装的sunpinyin也是64位包
头像
boreascn
帖子: 385
注册时间: 2008-03-26 14:28
送出感谢: 0
接收感谢: 0

Re: 安装sunpinyin 问题

#2

帖子 boreascn » 2009-03-09 15:23

命令行强行安装。
ewha
帖子: 13
注册时间: 2009-03-08 10:05
送出感谢: 0
接收感谢: 0

Re: 安装sunpinyin 问题

#3

帖子 ewha » 2009-03-09 22:31

dpkg-checkbuilddeps:未满足的构建依赖关系: build-essential libscim-dev (>= 1.4.6) cdbs (>= 0.4.41) debhelper (>= 5) intltool-debian autotools-dev libgtk2.0-dev


还是依存关系的问题,郁闷!先前安装deb报也是整个问题,现在编译安装也是整个问题。

楼上说强行安装,试了,导致系统进不去,在输入帐户密码那不断注销。只好进行修复,修复完毕,编译安装也是出现这个依存关系的问题

望高手给个解决的办法
头像
AutoXBC
帖子: 1744
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 安装sunpinyin 问题

#4

帖子 AutoXBC » 2009-03-09 23:36

viewtopic.php?f=8&t=188063&hilit=sunpinyin

这类开发中的程序依赖都是很新的,初学编译的不容易上手,还是先从源里的软件开始,慢慢积累经验。
头像
wc_111191
帖子: 471
注册时间: 2008-02-02 23:05
来自: 天津
送出感谢: 0
接收感谢: 0

Re: 安装sunpinyin 问题

#5

帖子 wc_111191 » 2009-03-10 12:37

viewtopic.php?f=8&t=187963&start=16
这个帖子和你的问题一样,我当时回答的是:
wc_111191 写了:
iscapee 写了:64bit 8.04,提示依赖性错误…… :em20
dpkg:依赖关系问题使得 scim-sunpinyin 的配置工作不能继续:
scim-sunpinyin 依赖于 libgtk2.0-0 (>= 2.14.1);然而:
系统中 libgtk2.0-0 的版本为 2.12.9-3ubuntu5。
scim-sunpinyin 依赖于 libpango1.0-0 (>= 1.21.6);然而:
系统中 libpango1.0-0 的版本为 1.20.5-0ubuntu1。
dpkg:处理 scim-sunpinyin (--install)时出错:
依赖关系问题 - 仍未被配置
8.04的不行,这个是8.10 only的。当然,你可以换8.10的源然后安装这个,不过我没试过,风险自担吧。。
浪漫是一种天赋!!!!
ewha
帖子: 13
注册时间: 2009-03-08 10:05
送出感谢: 0
接收感谢: 0

Re: 安装sunpinyin 问题

#6

帖子 ewha » 2009-03-10 19:10

wc_111191 写了:viewtopic.php?f=8&t=187963&start=16
这个帖子和你的问题一样,我当时回答的是:
wc_111191 写了:
iscapee 写了:64bit 8.04,提示依赖性错误…… :em20
dpkg:依赖关系问题使得 scim-sunpinyin 的配置工作不能继续:
scim-sunpinyin 依赖于 libgtk2.0-0 (>= 2.14.1);然而:
系统中 libgtk2.0-0 的版本为 2.12.9-3ubuntu5。
scim-sunpinyin 依赖于 libpango1.0-0 (>= 1.21.6);然而:
系统中 libpango1.0-0 的版本为 1.20.5-0ubuntu1。
dpkg:处理 scim-sunpinyin (--install)时出错:
依赖关系问题 - 仍未被配置
8.04的不行,这个是8.10 only的。当然,你可以换8.10的源然后安装这个,不过我没试过,风险自担吧。。
:em20 ,难道还得换回8.10?算了,所有问题都解决了,就这个输入法问题。凑合用SCIM自带的输入法得了。等9.04下来了,安装9.04,挂载home
头像
kumox
帖子: 2114
注册时间: 2008-04-14 23:29
来自: 曾也在NB大学呆过
送出感谢: 3 次
接收感谢: 10 次
联系:

Re: 安装sunpinyin 问题

#7

帖子 kumox » 2009-03-10 21:33

用8.10的源,装好这些依赖关系,然后再换回8.04的源~
头像
kumox
帖子: 2114
注册时间: 2008-04-14 23:29
来自: 曾也在NB大学呆过
送出感谢: 3 次
接收感谢: 10 次
联系:

Re: 安装sunpinyin 问题

#8

帖子 kumox » 2009-03-10 21:33

我是这样装的
回复

回到 “归档贴”