启动时候swap fail,还有u盘挂不上,每次都手动

重复贴和参考价值不大的帖子,版主维护
回复
zxdvd_Zhang
帖子: 150
注册时间: 2007-11-19 12:51
送出感谢: 0
接收感谢: 0
联系:

启动时候swap fail,还有u盘挂不上,每次都手动

#1

帖子 zxdvd_Zhang » 2009-03-11 19:25

有两个问题
一个是启动时候显示 active swapfile swap fail,貌似交换分区用不上了,而且我用系统监视器看发现swap果然是0%的使用阿,顺便想知道,交换分区到底给多大呢,我给了2G,又听说现在内存大,不需要大么多,而且我发现我现在swap没有激活用得也还好阿,而且物理内存一般也就是几百M而已阿

另一个就是,用vbox装了个red hat 9,启用了usb设备。貌似那只后就u盘不能自动挂载了,不是u盘的问题,每次都得手动输很长一串命令,到底是那个配置文件被改了呢,该怎么改回去呢,vbox的usb共享我关了还是这样阿
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

Re: 启动时候swap fail,还有u盘挂不上,每次都手动

#2

帖子 BigSnake.NET » 2009-03-11 19:34

fail 看一下有什么原因
是不是没格式化
是不是有坏区了
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
zxdvd_Zhang
帖子: 150
注册时间: 2007-11-19 12:51
送出感谢: 0
接收感谢: 0
联系:

Re: 启动时候swap fail,还有u盘挂不上,每次都手动

#3

帖子 zxdvd_Zhang » 2009-03-11 19:44

以前是好的,不知道什么时候坏了,
我看了下fstab里面的/dev/sda8(就是我的swap),id没有错误,
至于你说分区坏了,该怎么检查呢
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

Re: 启动时候swap fail,还有u盘挂不上,每次都手动

#4

帖子 BigSnake.NET » 2009-03-11 19:50

sudo swapon /dev/sda8
看说什么吧
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
zxdvd_Zhang
帖子: 150
注册时间: 2007-11-19 12:51
送出感谢: 0
接收感谢: 0
联系:

Re: 启动时候swap fail,还有u盘挂不上,每次都手动

#5

帖子 zxdvd_Zhang » 2009-03-11 19:59

谢谢你阿
提示
swapon: /dev/sda8: Device or resource busy
Codefresher
帖子: 62
注册时间: 2008-04-13 9:39
来自: china
送出感谢: 0
接收感谢: 0

Re: 启动时候swap fail,还有u盘挂不上,每次都手动

#6

帖子 Codefresher » 2009-03-12 14:03

交换分区真正用得少,除非是什么服务器之类的
Linux c ,it is now my favourite.
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

Re: 启动时候swap fail,还有u盘挂不上,每次都手动

#7

帖子 BigSnake.NET » 2009-03-12 14:07

zxdvd_Zhang 写了:谢谢你阿
提示
swapon: /dev/sda8: Device or resource busy
那不是已经启用了嘛 =。= 。..
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
回复

回到 “归档贴”