这是?

重复贴和参考价值不大的帖子,版主维护
回复
lu8
帖子: 8
注册时间: 2009-03-13 22:18
送出感谢: 0
接收感谢: 0

这是?

#1

帖子 lu8 » 2009-03-15 14:16

系统不能下载更新

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
头像
Jarson
帖子: 2371
注册时间: 2008-07-21 9:44
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

Re: 这是?

#2

帖子 Jarson » 2009-03-15 14:21

lu8 写了:系统不能下载更新

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
照提示去做

代码: 全选

dpkg --configure -a
也许需要在命令前加个sudo
lu8
帖子: 8
注册时间: 2009-03-13 22:18
送出感谢: 0
接收感谢: 0

Re: 这是?

#3

帖子 lu8 » 2009-03-15 15:20

无法下载 cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/main/binary-i386/Packages.gz 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。
无法下载 cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/restricted/binary-i386/Packages.gz 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。
有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。
头像
greco
帖子: 2487
注册时间: 2007-04-06 10:24
来自: ~/Shanghai
送出感谢: 0
接收感谢: 0

Re: 这是?

#4

帖子 greco » 2009-03-15 15:39

lu8 写了:无法下载 cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/main/binary-i386/Packages.gz 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。
无法下载 cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/restricted/binary-i386/Packages.gz 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。
有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。
http://silenceisdefeat.com/~greco

代码: 全选

''.join([chr(ord(c)-2) for c in 'O{"G/ockn"ku<"itgeq0ujkBiockn0eqo'])
echo -n "Z3JlY28uc2hpQGdtYWlsLmNvbQ==" | base64 -d
头像
Jarson
帖子: 2371
注册时间: 2008-07-21 9:44
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

Re: 这是?

#5

帖子 Jarson » 2009-03-15 16:18

lu8 写了:无法下载 cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/main/binary-i386/Packages.gz 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。
无法下载 cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/restricted/binary-i386/Packages.gz 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。
有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。
你用光盘更新系统?
如果不是可以修改默认的源列表
sudo vi /etc/apt/sources.lst
把第一行给注释掉(加一个#号)。
lu8
帖子: 8
注册时间: 2009-03-13 22:18
送出感谢: 0
接收感谢: 0

Re: 这是?

#6

帖子 lu8 » 2009-03-15 17:17

上面那些都解决拉
问题又来拉
这个又是什么意思阿?

E: /var/cache/apt/archives/linux-image-2.6.24-23-generic_2.6.24-23.49_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-23-generic”做一个符号链接备份

E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.41_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份

就差这俩项没有更新拉
linux-image-2.6.24-19-genetic
linux-image-2.6.24-23-genetic
lu8
帖子: 8
注册时间: 2009-03-13 22:18
送出感谢: 0
接收感谢: 0

Re: 这是?

#7

帖子 lu8 » 2009-03-19 19:59

lu8 写了:
E: /var/cache/apt/archives/linux-image-2.6.24-23-generic_2.6.24-23.49_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-23-generic”做一个符号链接备份

E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.41_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份

就差这俩项没有更新拉
linux-image-2.6.24-19-genetic
linux-image-2.6.24-23-genetic
哪位大大帮帮忙解决阿
头像
pcbird
帖子: 2337
注册时间: 2008-12-19 13:44
来自: 东8区
送出感谢: 0
接收感谢: 0

Re: 这是?

#8

帖子 pcbird » 2009-03-19 20:04

你的是wubi安装的吗?是的话很麻烦

代码: 全选

 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| *  
 
dragon261
帖子: 42
注册时间: 2009-04-23 8:27
送出感谢: 0
接收感谢: 0

Re: 这是?

#9

帖子 dragon261 » 2009-04-28 21:18

pcbird 写了:你的是wubi安装的吗?是的话很麻烦
很多人都是有wubi安装的,8楼说很多麻烦? 此话不错阿!
回复

回到 “归档贴”