当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-19 8:22 

注册: 2009-02-28 11:37
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我换主板和CPU了,这个板子的网卡是,RTL8168/8111类型的,现在问题是上不了网(装不上驱动),怎么解决呢?
我上网找了一些资料也不行,请高手详细说一下。谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-19 11:48 

注册: 2006-11-27 12:25
帖子: 458
送出感谢: 0 次
接收感谢: 0 次
如果你仍使用原来的硬盘及系统的话,请检查一下下面的文件:
/etc/udev/rules.d/70-persistent-net.rules
看一下里面是不是有你以前的网卡和现在的网卡,如果我没估计错的话,应该是有的。此时你将配置以前的网卡的那行注释掉,然后将现有的网卡的配置中NAME="eth1"改为NAME="eth0",再重启系统,看一下新网卡有没有起来。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-19 19:48 

注册: 2009-02-28 11:37
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
发现了两个,一个是以前的8139,一个是现在这个的,我按你的方法去掉了,但重启还是找不到网卡,我对这个系统实在不了解,怎么办?能说详细一点吗?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-19 19:55 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
还要改 NAME="eth0"
我的如下:
引用:
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:11:09:2a:c6:1d", ATTRS{type}=="1", NAME="eth0"


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
5 楼 
 文章标题 : Re: RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-19 20:12 

注册: 2006-11-27 12:25
帖子: 458
送出感谢: 0 次
接收感谢: 0 次
如果你在这个文件里面找到了新的网卡,说明系统已识别网卡了,应该是其他的配置问题,你运行一下ifconfig,看一下是什么结果?
你可能要手动配置一下网卡。具体方法是编辑/etc/network/interfaces文件,按你的具体情况将网卡设置成动态IP或者是静态IP。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-19 20:43 

注册: 2009-02-28 11:37
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我才进linux了,下面发一下信息,是不是没有驱动上呀,怎么驱动呢?

//////////////interfaces文件内容如下:////////////////
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp



//////////////resolv.conf文件内容/////////////////////
#domain domain
#search domain
nameserver 202.98.5.68
nameserver 202.98.0.68





//////////////运行 /etc/init.d/networking restart出现如下信息////////////////////
* Reconfiguring network interfaces...
eth0: ERROR while getting interface flags: No such device
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth0.


/////////////在设备-网络管理里://///////////////////
网络设备:网络设备未找到
下面所有的信息都显示不可用


//////////////etc/udev/rules.d/70-persistent-net.rules的内容为://///////////////////////
# This file was automatically generated by the /lib/udev/write_net_rules
# program run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:24:1d:03:3c:4f", ATTR{type}=="1", KERNEL=="eth*", NAME="ethO"


///////////////运行:ifconfig -a 结果如下:///////////////////////////////
ethO Link encap:以太网 硬件地址 00:24:1d:03:3c:4f
BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)
中断:221 基本地址:0xc000

lo Link encap:本地环回
LOOPBACK MTU:16436 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)

pan0 Link encap:以太网 硬件地址 3e:27:8e:44:17:96
BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)


页首
 用户资料  
 
7 楼 
 文章标题 : Re: RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-19 20:55 

注册: 2006-11-27 12:25
帖子: 458
送出感谢: 0 次
接收感谢: 0 次
引用:
# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:24:1d:03:3c:4f", ATTR{type}=="1", KERNEL=="eth*", NAME="ethO"


这里打错了 ,是 NAME="eth0" 是数字0,不是字母O!!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: RTL8168/8111网卡上不了网
帖子发表于 : 2009-03-20 6:44 

注册: 2009-02-28 11:37
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我的神阿,终于成功了,万分感谢呀,再不好使,我就要崩溃了!
我对vim用的不熟悉,我可能在非插入模式下按0了,所在根本就没有改过来呀,你看的太仔细了,再次表示感谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译