当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : amule装不了
帖子发表于 : 2009-03-21 11:04 

注册: 2009-03-05 22:20
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
用sudo pat -get install amule老是显示不能满足依赖关系
代码:
下列的软件包有不能满足的依赖关系:
  amule: 依赖: libwxgtk2.6-0 (>= 2.6.1.2ubuntu2) 但是它将不会被安装
         推荐: amule-utils 但是它将不会被安装

然后安装libwxgtk2.6-0又显示
代码:
下列的软件包有不能满足的依赖关系:
  libwxgtk2.6-0: 依赖: libgtk2.0-0 (>= 2.8.0) 但是它将不会被安装
E: 无法安装的软件包

好吧,安装 libgtk2.0-0 又显示
代码:
libgtk2.0-0 已经是最新的版本了。

如此循环。怎么办,实在是搞不定啊


页首
 用户资料  
 
2 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-21 11:09 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
你的源贴出来看看?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-21 11:47 

注册: 2009-03-19 9:15
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我装成功了电驴,方法是:
使用apt-get命令,则在“应用程序”→“附件”下找到“终端”项,单击该项,则打开一个GNOME终端窗口,在该窗口中输入如下命令:
sudo apt-get install amule amule-utils
命令执行后,将自动在线下载并安装Amule软件,当前下载的Amule软件的版本为2.2.2。
第一次运行好像也出现了 “下列的软件包有不能满足的依赖关系”
但我再运行一次sudo apt-get install amule amule-utils 全部都搞定了。

请看我的帖子:http://forum.ubuntu.org.cn/viewtopic.php?f=48&t=190505


页首
 用户资料  
 
4 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-21 19:08 
头像

注册: 2006-01-25 22:29
帖子: 1322
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
把软件源换成中文官方源,不要使用任何第三方源。然后再试试看安装。


_________________
* MACBOOK MB063CH/B
OS:Snow Leopard/XP
* AMD X2 3600+/2G RAM/160GB+500GB Seagate/7300GT
OS:Arch/Vista

Kubuntu User #18899

=================================
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊
http://www.freeearth.org.cn


页首
 用户资料  
 
5 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-22 10:40 

注册: 2008-11-06 22:59
帖子: 108
送出感谢: 0 次
接收感谢: 3
最好用新立得安装管理器安装,省事又省力


页首
 用户资料  
 
6 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-22 11:55 

注册: 2007-12-31 11:40
帖子: 389
送出感谢: 0 次
接收感谢: 0 次
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com B948431914FFEBADC98CD8AFA3CD88794B2C459E
-------------------------------
Ubuntu Jaunty Jackalope 9.04
Last aMule release available in Ubuntu official repositories
Ubuntu Intrepid Ibex 8.10
deb http://ppa.launchpad.net/amule-releases/ppa/ubuntu intrepid main
Ubuntu Hardy Heron 8.04
deb http://ppa.launchpad.net/amule-releases/ppa/ubuntu hardy main
引用;
http://www.amule.org/amule/index.php?PH ... ic=16647.0


页首
 用户资料  
 
7 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-22 12:02 

注册: 2007-08-12 18:47
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
ruffy 写道:
用sudo pat -get install amule老是显示不能满足依赖关系
代码:
下列的软件包有不能满足的依赖关系:
  amule: 依赖: libwxgtk2.6-0 (>= 2.6.1.2ubuntu2) 但是它将不会被安装
         推荐: amule-utils 但是它将不会被安装

然后安装libwxgtk2.6-0又显示
代码:
下列的软件包有不能满足的依赖关系:
  libwxgtk2.6-0: 依赖: libgtk2.0-0 (>= 2.8.0) 但是它将不会被安装
E: 无法安装的软件包

好吧,安装 libgtk2.0-0 又显示
代码:
libgtk2.0-0 已经是最新的版本了。

如此循环。怎么办,实在是搞不定啊


装libgtk2.0-dev 试试


_________________
Core2 T5670
Ram 3G
NV9300MGS
Fedora 15

Celeon 1.7
Ram 512M
i845G
Debian5+Awesome2


页首
 用户资料  
 
8 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-22 12:20 
头像

注册: 2007-07-11 20:59
帖子: 3922
送出感谢: 0 次
接收感谢: 0 次
估计是你的源的问题。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: amule装不了
帖子发表于 : 2009-03-27 21:12 

注册: 2009-03-05 22:20
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
谢谢各位热心的解答


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译