当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu下装kdevelop
帖子发表于 : 2009-03-23 16:09 

注册: 2009-03-23 16:06
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
最近要整个linux下的桌面程序,想用QT实现,买了本精通QT4编程的书。以前都没接触过linux,朋友推荐选用了ubuntu。于是下了个8.10的发行版,刻成盘,其他的发行版本似乎都有可以选安装,ubuntu没有,好像是通过软件仓库网上更新吧。于是需要自己装QT,自己装kdevelop。但是遇到了不少问题,装QT比较顺利,按照书上附录的步骤装下了个QT4.5.x,configure make make install而且装完后自己用gedit编写了一个最简单的hello world的QT程序,没问题。按照书中的附录2,下了个gdb6.8,安装,编译发现要break,原因是werror把warning当error了,于是找到对应*.c文件目录下找到Makefile修改掉werror编译选项,通过。于是想把kdevelop,装上。下了个kdevelop3.5.x,一configure说一个重要的程序kde-config没有,于是google,说没有kdelib,于是又下了个kdelib,编译安装也不对还是提示kde-config没找到,再下了kdebase,也不对,想也许是我用的是ubuntu而非kubuntu没装kde,于是apt-get install kde,装好后编译还是出现kde-config没有,一查kde版本,竟然说没有安装kde,编译kdelib就说我的QT版本高了,按照书中介绍应该是可以的啊,但是kdevelop也说需要QT>=3.5&&QT<4的,没折了,整疲了,那位给个建议怎么办?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译