当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无法打开新立得了!!
帖子发表于 : 2009-03-24 23:04 

注册: 2009-03-24 21:38
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
先按着速配指南安装完全后,发现不能使用更新了!!错误如下!


====================================
不能够初始化包信息

初始化包信息时遇到无法解决的问题。

请汇报这个此 'update-manager' 软件包的错误,并且将如下信息包含在报告中:

'E:无法打开文件 /var/lib/dpkg/status - open (116 Stale NFS file handle), E:无法解析或打开软件包的列表或是状态文件。'
=====================================

然后按照别人的提示:运行sudo cp -i /var/backups/dpkg.status.0 /var/lib/dpkg/status
=====================================
然后能进入更新管理了!然后安装更新,出现
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

继续输入命令: sudo dpkg --configure -a

继续出现这样的错误:
dpkg: 语法分析错误,在“/var/lib/dpkg/updates/0000”文件的第“6”行附近 软件包“libgomp1”:
在字段“Maintainer”的值中间发现了 EOF 字符(缺少最后结尾的换行符)
ooxx@ubuntu:~$ sudo dpkg --configure -a

现在打开新立得就显示:E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

请问怎么解决,谢谢了~


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 无法打开新立得了!!
帖子发表于 : 2009-03-25 22:50 

注册: 2009-03-24 21:38
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
这个问题貌似有点难??没人解答么~~ :em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 无法打开新立得了!!
帖子发表于 : 2009-03-26 12:41 

注册: 2009-03-24 21:38
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
难道要重装了。。不会吧。。悲剧了~~ :em20


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 无法打开新立得了!!
帖子发表于 : 2009-03-26 12:48 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
你不好好看提示,没有学习过英语吗?

dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.


------------
dpkg被中断了,你必须手动运行dpkg --configure -a来纠正这个错误。


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 无法打开新立得了!!
帖子发表于 : 2009-03-26 13:11 

注册: 2009-03-24 21:38
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
cnkilior 写道:
你不好好看提示,没有学习过英语吗?

dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.


------------
dpkg被中断了,你必须手动运行dpkg --configure -a来纠正这个错误。


--------------------
:em20 没仔细看我的问题呢!!你看我问题的倒数第8行~ 我已经输入sudo dpkg --configure -a

再贴一遍我输入后出现的错误!
-------------------------
ooxx@ubuntu:~$ sudo dpkg --configure -a //这里已经输入了
dpkg: 语法分析错误,在“/var/lib/dpkg/updates/0000”文件的第“6”行附近 软件包“libgomp1”:
在字段“Maintainer”的值中间发现了 EOF 字符(缺少最后结尾的换行符)
--------------------
我想能不能把更新的全部删除?重新下载呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译