编译Linux内核2.26.29版本的问题

重复贴和参考价值不大的帖子,版主维护
回复
ewha
帖子: 13
注册时间: 2009-03-08 10:05
送出感谢: 0
接收感谢: 0

编译Linux内核2.26.29版本的问题

#1

帖子 ewha » 2009-03-25 14:49

2.26.28的,论坛里有,我照做弄好了,但2.26.29照2.26.28做,不行,郁闷。搞得我现在dpkg出问题,用“dpkg --configure -a”修复,说是找不到img2.26.29。造成这个问题的原因是我把不成功的内核删除了。现在不知道怎么解决,新立得软件工具也不能用,和dpkg一样的问题。

问题如下:
root@SwordsmanTec:/home/ewha# dpkg --configure -a
\u6b63\u5728\u8bbe\u7f6e initramfs-tools (0.92bubuntu16) ...
update-initramfs: deferring update (trigger activated)

\u6b63\u5728\u5904\u7406\u7528\u4e8e initramfs-tools \u7684\u89e6\u53d1\u5668...
update-initramfs: Generating /boot/initrd.img-2.6.29david0.67
Cannot find /lib/modules/2.6.29david0.67
update-initramfs: failed for /boot/initrd.img-2.6.29david0.67
dpkg: \u5b50\u8fdb\u7a0b post-installation script \u8fd4\u56de\u4e86\u9519\u8bef\u53f7 1


还有一个补丁的问题:

The text leading up to this was:
--------------------------
|diff --git a/arch/arm/mach-ep93xx/include/mach/dma.h b/arch/arm/mach-ep93xx/include/mach/dma.h
|deleted file mode 100644
|index d0fa965..0000000
|--- a/arch/arm/mach-ep93xx/include/mach/dma.h
|+++ /dev/null
--------------------------
File to patch:
一连串的Reversed (or previously applied) patch detected! Assume -R? [n] y

然后:
The text leading up to this was:
--------------------------
|diff --git a/arch/arm/mach-ep93xx/include/mach/dma.h b/arch/arm/mach-ep93xx/include/mach/dma.h
|deleted file mode 100644
|index d0fa965..0000000
|--- a/arch/arm/mach-ep93xx/include/mach/dma.h
|+++ /dev/null
--------------------------
File to patch:

那么多文件,总不能一个个补吧,这怎么处理?
回复

回到 “归档贴”