升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

重复贴和参考价值不大的帖子,版主维护
回复
zxdvd_Zhang
帖子: 150
注册时间: 2007-11-19 12:51
送出感谢: 0
接收感谢: 0
联系:

升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#1

帖子 zxdvd_Zhang » 2009-03-26 13:01

实在是忍耐不住诱惑就升级啦,然后重启就进不了图形界面啦,用了一年多了,装了很多软件啊,vbox里虚拟了两个系统,都是很重要的,实在是不想重装啊,早知道不升级啦。
揣测是受限驱动得问题,我装了受限驱动,但是没有开3D特效,也没有装那个compiz。
我把那个log文件贴出来啦,

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 25 22:48:31 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) No Layout section. Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Configured Monitor"
(**) | |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) No FontPath specified. Using compiled-in default.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81d9a40
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on linux
(--) using VT number 2

(--) PCI:*(0@1:0:0) ATI Technologies Inc M52 [Mobility Radeon X1300] rev 0, Mem @ 0xd8000000/0, 0xe4400000/0, I/O @ 0x00004000/0, BIOS @ 0x????????/131072
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 7.4.0, module version = 1.0.0
(II) Loading extension GLX
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.5.2, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "record"


这是你部分的,我感觉应该是字体的问题,大家看看怎么办呢,问题好像没有严重到显卡问题得程度吧,希望只是字体的问题吧

真的不想重装了,大家帮我出出主意吧,谢谢啦
头像
adagio
论坛版主
帖子: 22110
注册时间: 2008-02-17 23:47
来自: 美丽富饶的那啥星球
送出感谢: 7 次
接收感谢: 75 次

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#2

帖子 adagio » 2009-03-26 13:32

好像没啥问题
把font /usr/share/fonts/X11/cyrillic这行注释掉试试
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手
zxdvd_Zhang
帖子: 150
注册时间: 2007-11-19 12:51
送出感谢: 0
接收感谢: 0
联系:

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#3

帖子 zxdvd_Zhang » 2009-03-26 13:35

谢谢啦,抱歉,实在X11/xorg.conf里面注释么,
那个文件里面好像没有这一行啊

我后来用recovery模式fix了X,登陆界面就是很严重得花屏,什么都看不到
头像
adagio
论坛版主
帖子: 22110
注册时间: 2008-02-17 23:47
来自: 美丽富饶的那啥星球
送出感谢: 7 次
接收感谢: 75 次

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#4

帖子 adagio » 2009-03-26 14:16

代码: 全选

cat /var/log/Xorg.0.log | grep EE
看看有没有输出
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手
lc2beyond
帖子: 6
注册时间: 2008-09-06 9:46
送出感谢: 0
接收感谢: 0

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#5

帖子 lc2beyond » 2009-03-26 21:04

一般卸载掉fglrx,并删除xorg.conf后重启就好了。
zxdvd_Zhang
帖子: 150
注册时间: 2007-11-19 12:51
送出感谢: 0
接收感谢: 0
联系:

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#6

帖子 zxdvd_Zhang » 2009-03-26 22:23

grep EE
no device detect

我感觉是那个什么字体的问题,我是菜鸟,揣测而已,
No FontPath specified. Using compiled-in default.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.

我按网上查得修复X得方法,发现我连xfs(就是那个 fonts server都没有了,貌似升级时候被删了,估计新版本又没有)
头像
zuiw
帖子: 34
注册时间: 2008-10-15 20:44
送出感谢: 0
接收感谢: 0

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#7

帖子 zuiw » 2009-03-27 20:20

我的也一样,陪你等
-- 我的城市我的梦 http://www.iamlintao.com
dean1977
帖子: 1
注册时间: 2007-05-27 9:09
送出感谢: 0
接收感谢: 0

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#8

帖子 dean1977 » 2009-03-28 22:08

备份之后删掉/etc/X11 下的xorg.conf,然后用dpkg-reconfigure xserver-xorg 生成一个通用的xorg.conf,
可以凑合用用,等解决办法吧。
hepha
帖子: 23
注册时间: 2008-06-19 4:54
送出感谢: 0
接收感谢: 0

Re: 升級到9.04圖形界面沒了,該怎麼辦呢,裝了很多軟件,不想重裝,在線等

#9

帖子 hepha » 2009-03-29 0:02

cyrillic是字型有裝沒裝都沒差…

代码: 全选

sudo aptitude install xfonts-cyrillic
ati的話可以用aticonfig產生一份正確的xorg.conf

代码: 全选

sudo aticonfig --initial -f
fird
帖子: 81
注册时间: 2007-12-14 20:45
送出感谢: 0
接收感谢: 0
联系:

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#10

帖子 fird » 2009-03-29 13:36

LZ和我一样是ATI x1300移动版吧。

我全新安装的9.04,装完ATI受限驱动就进不了登录界面了。后来到恢复模式

sudo apt-get remove xorg-driver-fglrx

删除ATI驱动就能正常进入了。

PS:9.04的开源驱动不错,3D桌面用得挺好。
头像
速腾1994
论坛版主
帖子: 17366
注册时间: 2008-11-01 20:43
系统: Arch+gnome
送出感谢: 23 次
接收感谢: 8 次

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#11

帖子 速腾1994 » 2009-03-29 17:57

sudo apt-get remove xorg-driver-fglrx :em11
domilander
帖子: 43
注册时间: 2008-09-24 21:40
送出感谢: 0
接收感谢: 0

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#12

帖子 domilander » 2009-03-31 2:36

我是intel的显卡,和lz情况一样。。。
restar
帖子: 322
注册时间: 2007-11-06 13:38
送出感谢: 0
接收感谢: 0

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#13

帖子 restar » 2009-04-08 9:37

我的是NVIDIA的显卡,和LZ一样,也进不了系统啊
头像
totem
帖子: 221
注册时间: 2007-10-21 14:48
送出感谢: 0
接收感谢: 0

Re: 升级到9.04图形界面没了,该怎么办呢,装了很多软件,不想重装,在线等

#14

帖子 totem » 2009-04-08 11:31

还是下个ISO来wubi吧。多快好省。没那么多乱七八糟的问题。
回复

回到 “归档贴”