当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装时断电。。于是它就不能再更新了,怎么办
帖子发表于 : 2009-03-26 20:39 
头像

注册: 2008-09-18 1:22
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
我的UBUNTU出现了一次断电,那时它正在更新安装。。于是,出现了这个问题,
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
于是我又运行 了:
duck@duck-desktop:~/桌面$ sudo dpkg --configure -a

于是。。。。数秒后:


正在设置 libc6 (2.7-10ubuntu4) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
/sbin/ldconfig.real: /usr/lib/libartskde.so.1.2.0.dpkg-tmp is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig.real: /usr/lib/libkdecore.so.4.2.0.dpkg-tmp is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig.real: /usr/lib/libkabc.so.1.2.0.dpkg-tmp is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig.real: /usr/lib/libkabc_file.so.1.0.0.dpkg-tmp is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig.real: /usr/lib/libDCOP.so.4.2.0.dpkg-tmp is not an ELF file - it has the wrong magic bytes at the start.

Aborted
dpkg: 子进程 post-installation script 返回了错误号 134

可是安了安装更新又出现:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

我该怎么办??现在不能更新,那个红色的箭头让我很郁闷。


附件:
文件注释: 不能进行更新的错误提示
Screenshot.png
Screenshot.png [ 958.21 KiB | 被浏览 96 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装时断电。。于是它就不能再更新了,怎么办
帖子发表于 : 2009-03-26 20:40 
头像

注册: 2008-09-18 1:22
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
我急需帮助~~好无奈啊,原来断电的危害如此之大。。 :em30


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装时断电。。于是它就不能再更新了,怎么办
帖子发表于 : 2009-03-26 21:19 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
进恢复模式修复下! :em02 :em02


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装时断电。。于是它就不能再更新了,怎么办
帖子发表于 : 2009-03-26 21:37 
头像

注册: 2008-05-31 17:27
帖子: 1025
地址: SUES
送出感谢: 0 次
接收感谢: 0 次
不急不急,有一个偏方,如果还是失败的话就第2行代码来恢复
可能引起系统大混乱……三思后行
代码:
cd ~/;mkdir libc6backup;cp /var/lib/dpkg/info/libc6* ~/libc6backup;sudo rm /var/lib/dpkg/info/libc6*;sudo apt-get upgrade

直到完成

代码:
sudo cp ~/libc6backup/* /var/lib/dpkg/info/;sudo apt-get upgrade


_________________
我的Ubuntu相关
--------------------
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装时断电。。于是它就不能再更新了,怎么办
帖子发表于 : 2009-03-27 18:41 
头像

注册: 2008-09-18 1:22
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
wangdu2002 写道:
进恢复模式修复下! :em02 :em02

大侠~~~怎么个修复法????


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译