当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 11:13 
头像

注册: 2009-04-09 10:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
第一次安装Ubuntu8.10,不了解Linux,因为要安装LAMP的缘故,所以接触了它,当我安装好系统后,并且更新了系统后,想运行.bin文件,但发现运行不了,再终端没有任何反应,也不报错,也不弹出安装页面。我的操作如下:
chmod 755 bitnami-lampstack-1.0-beta-3-linux-installer.bin
./bitnami-lampstack-1.0-beta-3-linux-installer.bin 回车后没有反应。我的环境是在VBox虚拟机上,安装的是ubuntu 8.10 (64位)。希望得到大家指点!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 11:19 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
sudo tasksel install lamp-server


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 11:41 
头像

注册: 2009-04-09 10:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
不是太明白楼上的意思,作用是什么?我安装的是一个bin文件集成了PHP+MYSQL+APACHE2,不需要他们单独再安装了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 11:48 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
https://help.ubuntu.com/community/ApacheMySQLPHP


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 17:21 
头像

注册: 2009-04-09 10:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
看来上面的链接,是讲怎么安装的,并没有提到为什么bin文件不运行


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 18:13 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
try
chmod a+x bitnami-lampstack-1.0-beta-3-linux-installer.bin
then
./bitnami-lampstack-1.0-beta-3-linux-installer.bin


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 19:41 
头像

注册: 2009-04-09 10:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
试过楼上的代码,不是chmod有问题,chmod 755已经解锁,问题是为什么不运行,很奇怪。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 20:02 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
难道要
sudo ./bitnami-lampstack-1.0-beta-3-linux-installer.bin

任何提示都没有?


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 20:03 
头像

注册: 2009-04-09 10:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
让提示输入密码,没了,--!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 20:05 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
所以楼主还是安安稳稳的用为Ubuntu编译的版本吧。

通用版本问题可能性更大。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 20:13 
头像

注册: 2009-04-09 10:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
不理解啥意思?麻烦帮我解释下:“为Ubuntu编译的版本”是什么?“通用版本”是什么?谢谢


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Ubuntu8.10(64bit) 运行bin文件没有反应
帖子发表于 : 2009-04-09 21:08 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
./bin安装包是因为Linux之间的软件包管理不通用,不像windows一样,Linux的开源软件习惯性对应自己的发行版编译,而且目录结构使用的其他软件依赖可能不同。所以Debian和Ubuntu的软件包都未必兼容。
源里的是为了这个版本Ubuntu专门定制的────专门编译的。你应该比我懂。。。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译