当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-09 12:41 

注册: 2009-04-06 23:08
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我刚刚接触ubuntu,纯粹一个菜鸟,高手其实就不用往下看拉(本文语言是菜鸟语言)~我只是想把自己的经历与方法和大家分享一下,让一些和我有相似情况的朋友少走些弯路。 :em02

先说一下自己本本的基本信息。Dell 1520
Intel 酷睿2双核 T550
主板芯片组 Intel PM965
显卡 NVIDIA GeForce 8600M GT
是在去年5.12时候买的。回来的路上在老校区等去新校区的校车时候,突然觉得有点晕,以为自己大中午跑出去上火了。后开发现校门口突然聚集了很多人,我仍然继续等车,只是以为校门口发生了车祸。再一会儿,发现,周围挤满了人,听人议论才知道是地震了~ :em20
还好,是在重庆,没什么事情。这里再为四川坚强的人民表示一下心里的祝福~

遭遇1

几天前第一次装好了ubuntu,8.10版本。初次感觉很不错,被它的那种特效吸引的很深。于是自己在那里设置compiz settings ,而且设置成了开机启动。结果不知怎么搞的弄得一下子重启后,进入桌面,等到compiz一出来(任务栏的那个蓝色方块)就白屏了。晕。于是切换到xp下找方法,主要有两种方法。

第一种我试过不管用,见下面:

1)登录界面

2)左下角option(选项)里选择change section(选择会话), 选择failsafe terminal (安全模式终端命令)

3)输入帐号密码进入后,在命令行输入gconf-editor

4)依次选择Desktop->Gnome->Applications->window_manager , 把两处/usr/bin/compiz改成/usr/bin/metacity

5)ctrl+alt+backspace注销切换到登录界面,change section 选择gnome

第二种我忘记在哪里看到的了,所以找不到他(她)的原帖了,在这里再次谢谢了!~ :em11

方法见下:
同样在安全模式终端命令中去输入:
sudo apt-get remove compizconfig-settings-manager
sudo apt-get remove emerald
sudo apt-get remove fusion-icon

这样就把compiz那些搞特效的删除了,等到可以进桌面了,再安装。我估计白屏的原因是里面的某几个特效冲突了,所以设置的时候要注意点。

遭遇2

特效弄得确实不错,可是还是有个毛病。我每次重新启动进入系统特效都是关闭的,每次都要到视觉效果里面把它从哦“无”调到“正常”或者“扩展”。我的显卡是NVIDIA 8600GT,驱动是在系统-系统管理,硬件驱动里面安装的,记得当时激活的是180那个。昨天重新装了ubuntu,想一次性搞定这个问题,就没有激活任何系统里面的限制驱动,直接想安装官方驱动试一试,就到NVIDIA官方网站下载linux 32的驱动,下载好了发现直接点击不能装,于是网上找方法,先要把驱动放到ailai的主文件夹下面,记住驱动的文件名,再按ctrl+Alt+F1进入一个什么命令界面,然后输入用户名,密码,再输入
sudo /etc/init.d/gdm stop 这一步是把和显示什么东西的显关掉,才能安装显卡驱动。

再输入:

sudo sh /home/ailai/NVIDIA-Linux-x86-180.44-pkg1.run (这个命令是以我的为例,我的用户名ailai,驱动的文件名NVIDIA-Linux-x86-180.44-pkg1.run )

就开始安装了。

大家输入命令的时候要仿照前面那个安装命令来输入。

等到安装完毕后,输入sudo reboot 就重新启动了。如果你在登录画面出现之前看到NVIDIA标志界面闪过,那么恭喜你,安装成功了 :em02

显卡弄好后,在视觉效果里面设置为正常,重启,还是正常。问题解决了。 :em09

遭遇3

之后就开始了升级的过程,不知道怎么弄的,升级后发现显卡又出问题了,我记得不太清楚了,好像是进入系统成了低分辨率,然后发现任务栏里面应用程序,位置,系统,里面的项目都有变化~汗~我又按照遭遇2里面的步骤重新安装显卡驱动,可是安装完后,重启,总是提示什么系统里面有个 0:x,什么我以记不清了。让选Yes和No,我两个都试着选过,都不行。幸亏我以前看到一个帖子,然后抄到了笔记本上,然后按照帖子里面说的,就做好了。下面是链接
http://seraphimdom.spaces.live.com/blog ... 1654.entry

里面说是参照了一个外国朋友的方法,我然后又到那个外国链接里面
http://ubuntuforums.org/showthread.php?t=514161

把7个步骤的命令抄了下来。(貌似本来不用抄,可以在以后输入命令的时候调用,我怕万一不可以就抄了下来)其实我只是按照7个步骤的前5个就好了。
这里是原帖:(加自己的一些说明)
How I got the latest NVIDIA 100.14.11 drivers installed
=======================================================

Tip: press <TAB> to complete long file or directory names
where possible, ie. NVIDIA<TAB>

1) Download the latest driver from http://www.nvidia.com, and save
it to your home directory, eg.

~/NVIDIA-Linux-x86_64-100.14.11-pkg2.run
就是说到官方网站下载驱动,然后放到你的主目录下面。例如我就是放到了ailai的主目录下。然后记住驱动的文件名。

2) Group-select these instructions (in the top code box,
not the whole HTML page) by left-hold-clicking in the
upper-left corner, then dragging down to the bottom.
When all of the text is highlighted in reverse, press
right-click and select 'copy'.

Open gedit (Applications->Text Editor), then right-click
and select 'paste'. Save the contents to a file called
'how' in your home directory, eg.

~/how

You will then be able to view these instructions as often
as you'd like after you've quit out of Gnome, simply by
entering this command at the console prompt:

less ~/how

(Use <PgUp>, <PgDn>, <Up-Arrow> and <Down-Arrow> to move
around in the file).

其实这一步不是主要步骤,只是说,让你把他这篇帖子保存成一个文本也放到主目录下面,下面输入命令的时候可以用命令打开这个文本,一边参照一边输入。我为了保险直接把命令抄了一遍。
3) Exit out of Gnome by pressing <CTRL-ALT-F6>, logging in
at the text prompt, and typing:

sudo /etc/init.d/gdm stop

(A confirmation message that Gnome has stopped should
appear).
按下 <CTRL-ALT-F6>,进入命令输入模式了,然后输入
sudo /etc/init.d/gdm stop

(如果进入模式后有login提示就先输入你的用户名,然后提示输入密码,再输入密码)
4) Backup your current xorg.conf file with:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.justin
备份你的某个文件,照办就可以了。

5) Enter the following commands:

sudo apt-get remove nvidia* linux-restricted-modules*
sudo apt-get install linux-headers-$(uname -r) \
build-essential pkg-config xorg-dev
sudo sh ~/NVIDIA-Linux-x86_64-100.14.11-pkg2.run

Follow the prompts, selecting Y or ACCEPT to everything.
(Don't worry if a couple of warnings appear, such as
'Unable to check for libGL.so.1')
他说输入一下命令
sudo apt-get remove nvidia* linux-restricted-modules*
sudo apt-get install linux-headers-$(uname -r) \
build-essential pkg-config xorg-dev
sudo sh ~/NVIDIA-Linux-x86_64-100.14.11-pkg2.run

我就输入了
sudo apt-get remove nvidia* linux-restricted-modules*
回车
sudo apt-get install linux-headers-$(uname -r) \
build-essential pkg-config xorg-dev
回车
sudo sh /home/ailai/NVIDIA-Linux-x86-180.44-pkg1.run

之后安装成功后我就输入sudo reboot 重启,然后就大功告成了。下面的步骤我就没有用到。
6) At this point, if you tried restarting, you would get
'failed to load module wfb, need libwfb' error messages
in /etc/X11/Xorg.0.log

To fix this, extract the files from the Nvidia driver
package, like so:

sh ~/NVIDIA-Linux-x86_64-100.14.11-pkg2.run -x

Copy the missing wfb module over with:

cd ~/NVIDIA-Linux-x86_64-100.14.11-pkg2/usr/X11R6/lib/modules
sudo cp libnvidia-wfb.so.100.14.11 /usr/lib/xorg/modules

Then change directories and create a symbolic link with:

cd /usr/lib/xorg/modules
sudo ln -s libnvidia-wfb.so.100.14.11 libwfb.so

7) At this point, if you tried restarting, you would get the
errors 'lrm-video not found' and 'failed to load the
NVIDIA kernel module!'

To fix this, change directories and edit the lrm-video
file (after changing update permissions) with:

cd /etc/modprobe.d
sudo chmod go=rw lrm-video
sudo vim lrm-video

Comment out the 'nvidia' line by pressing the following
keys in this order:

<DOWN> <DOWN> i # <ESC><ESC> : x <ENTER>

To examine the edited file, type:

cat lrm-video

It should now look like this:

Code:

install fglrx /sbin/lrm-video fglrx $CMDLINE_OPTS
#install nvidia /sbin/lrm-video nvidia $CMDLINE_OPTS
install nvidia_legacy /sbin/lrm-video nvidia_legacy
$CMDLINE_OPTS
install nvidia_new /sbin/lrm-video nvidia_new $CMDLINE_OPTS

Change the permissions back to read-only with:

sudo chmod go=r lrm-video

8) Now restart Gnome with:

sudo /etc/init.d/gdm start

(You should hopefully see an Nvidia logo flash on screen).

And login at the graphical prompt.

9) You may see a warning about [not] using 'restricted drivers'
pop up at this point. Click to get rid of it. (Hopefully it
shouldn't appear again).

Open a terminal prompt and type:

sudo nvidia-settings

Click on the 'X Server Display Configuration' option,
then set your resolution and colour depth as appropriate.
(If you set it to 'auto', it should switch to your max.
resolution automatically).

Don't forget to click on the 'Save to X Configuration File'
button to make sure your settings are stored for next time.

10) If you know what you're doing, you might want to tidy
up your /etc/X11/xorg.conf file at this point, removing
the old & now unwanted monitor, device & screen sections.
From the terminal prompt, type:

sudo gedit /etc/X11/xorg.conf

As a rough guide, keep the sections with the identifiers
'Monitor0', 'Videocard0' and 'Screen0'.

(Or you could leave it alone; it still seems to work OK).
这里再感谢一下那位外国朋友!


就这样进入ubuntu,一切正常,视觉效果里可以保存设置。我查了一下ubuntu的版本,一看是9.04,晕,怎么升级连系统版本也升级了。我以为只是打补丁升级软件而已。

有生以来第一次发这么长的帖子,希望大家支持一下哈~ :em06


最后由 ailai55 编辑于 2009-04-09 13:03,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 一个菜鸟的遭遇~
帖子发表于 : 2009-04-09 12:51 
头像

注册: 2006-09-10 22:36
帖子: 10663
地址: 北京
送出感谢: 1
接收感谢: 16
不要重复发帖,否则按恶意灌水处理~~~


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 一个菜鸟的遭遇~
帖子发表于 : 2009-04-09 12:56 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
楼主写了这么多,真不容易,支持下! :em09
多半是不小心把源改了,所以变成904了,也是好事呀,又多了个小白做测试! :em05


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-09 13:23 
头像

注册: 2008-02-17 23:47
帖子: 22106
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 81
支持 :em06 支持


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-09 13:34 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
发这多字也不容易啊 :em03


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-09 13:42 
头像

注册: 2006-12-17 13:34
帖子: 1818
地址: 武汉
送出感谢: 1
接收感谢: 0 次
:em11 :em11 支持 lz。。很强的帖子。。。


_________________
人生长恨水长东;
远近高低各不同.


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-09 13:52 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
好麻烦。。。我就用了个源就装上了。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-09 14:19 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
LZ码字辛苦了!


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-11 15:55 

注册: 2007-11-12 10:37
帖子: 189
送出感谢: 0 次
接收感谢: 0 次
楼主辛苦了。等我啥时换新机器时一定向你请教全过程,来好好配置一下。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-11 17:17 
头像

注册: 2008-05-31 17:27
帖子: 1025
地址: SUES
送出感谢: 0 次
接收感谢: 0 次
:em04 其实可以换9。04源~这样轻松又愉快~


_________________
我的Ubuntu相关
--------------------
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 一个菜鸟的遭遇~NVIDIA的可以来看看
帖子发表于 : 2009-04-11 21:52 

注册: 2008-04-13 9:39
帖子: 62
地址: china
送出感谢: 0 次
接收感谢: 0 次
:em11


_________________
Linux c ,it is now my favourite.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译