当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : Ubuntu9.04正式版硬盘安装之后不能启动(已解决)
帖子发表于 : 2009-04-25 1:39 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
我昨天下载的Ubuntu9.04 ISO镜像,以前有Ubuntu8.10 嫌升级太慢就用硬盘安装
我把镜像文件放在C盘下,将其中 casper文件夹解压放在C盘根目录下,将capser中的vmlinuz,initrd.gz复制到C:\
我在/boot/grub/menu.lst 中添加了下面命令:
引用:
title Ubuntu 9.04 LiveCD
root (hd0,0)
kernel /vmlinuz boot=casper iso-scan/filename=/Ubuntu.iso ro quiet splash locale=zh_CN.UTF-8
initrd /initrd.gz
boot

然后成功启动LiveCD
启动后,打开终端,输入以下命令:
引用:
#sudo umount -l /isodevice
$sudo umount -l /cdrom

没有提示出错,
然后双击桌面上的安装,开始安装,

我之前的分区方案是这样的

共20GB
5GB第一分区(主分区) 卷标:winxp 格式:fat32 装的我的XP系统
5GB第二分区(逻辑分区) 卷标:software 格式:fat32 装软件,文档
9GB第三分区(逻辑分区) 卷标:Ubuntu 格式ext3 挂载点 /
730MB 第四分区(逻辑分区)格式 swap

为了体验EXT4系统我重新分区如下(diskgenius识别EXT4为EXT3):
附件:
文件注释: 分区情况 使用软件 diskgenius
.JPG
.JPG [ 31.81 KiB | 被浏览 683 次 ]


5GB第一分区(主分区) 卷标:winxp 格式:fat32 装的我的XP系统..........不变
5GB第二分区(逻辑分区) 卷标:software 格式:fat32 装软件,文档..........不变
128MB第三分区(逻辑分区) 格式 EXT3 挂载点: /boot
9GB第四分区(逻辑分区) 格式 EXT4 挂载点: /
730MB 第五分区(逻辑分区)格式 swap

然后进行安装,期间没有出现错误,安装完成重启,发现grub 菜单里面只有
Ubuntu 9.04, memtest86+ 一项 不能进入系统
于是用livecd进系统,查看menu.lst内容如下:

引用:
## ## End Default Options ##

title Ubuntu 9.04, memtest86+
uuid bd6cea9d-5d72-45bf-87c6-bce6a0905d7a
kernel /memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

没有其他项目。
于是查看boot分区下的文件表如下:
附件:
2.JPG
2.JPG [ 46.98 KiB | 被浏览 686 次 ]



/boot/grub/下(我后来编辑过menu.lst):
附件:
3.JPG
3.JPG [ 41.26 KiB | 被浏览 669 次 ]



我把重要的信息全部放在这里了,希望高手帮我解决这个问题。 多谢!


最后由 w99991888 编辑于 2009-06-02 15:58,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-25 11:03 

注册: 2006-11-19 21:42
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
我现在也是这个问题了,同样期待高手帮忙解决,好像用硬盘安装很多问题啊,而且有很多问题都没人帮忙解决的了的,郁闷啊


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-25 11:28 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
高手帮忙解决呀,好像这个问题很普遍的! :em06


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-26 13:09 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
自己顶!!!!!!!!!!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-27 12:28 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
顶顶顶顶顶顶!!!!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-27 12:40 
头像

注册: 2007-05-06 8:19
帖子: 7433
送出感谢: 0 次
接收感谢: 4
你重装GRUB没,小心不装它不认识ext4,可是你的boot是ext3,应该没影响;
menu里没904就自己写一个? :em11


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-27 12:40 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
DiskGenius不能识别EXT4里的内容,伤心。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-27 12:42 
头像

注册: 2008-02-17 23:47
帖子: 22108
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 82
用liveCD进去,输入
代码:
sudo grub
find stage1

看输出信息,比如如果显示 hd(0,5),就继续执行
代码:
root (hd0,5)
setup (hd0)

如果提示成功就exit退出,重启看看


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-27 12:56 
头像

注册: 2008-10-14 21:54
帖子: 880
送出感谢: 0 次
接收感谢: 2
楼主问题解决了吗? :em11


_________________
地狱可以想象,天堂却无法描述。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-04-27 13:09 

注册: 2007-01-19 19:36
帖子: 66
送出感谢: 0 次
接收感谢: 0 次
:em06 我也出现过这个问题,折腾了半天没解决,最后直接装Ubuntu 8.10然后升级到9.04 唉。。。。 :em04 :em04


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-05-03 19:09 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
冲浪板 写道:
你重装GRUB没,小心不装它不认识ext4,可是你的boot是ext3,应该没影响;
menu里没904就自己写一个? :em11

貌似boot下就没有内核,写上去也没什么用。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-05-09 17:41 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
后来我用同样的方法安装Ubuntu8.10 出现的问题和9.04完全一样


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-05-09 18:09 

注册: 2009-04-29 21:22
帖子: 1081
送出感谢: 3
接收感谢: 1
不知你用的什么东西分的区,是安装的时候手动分的区吗?


页首
 用户资料  
 
14 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-05-09 18:25 

注册: 2007-10-04 15:23
帖子: 147
送出感谢: 0 次
接收感谢: 0 次
从8.10就是这个问题。。。。
有人认为是sudo umount -l /isodevice引起的,不过没解决方案
后来我用alternate装成功了,LZ不妨试试


页首
 用户资料  
 
15 楼 
 文章标题 : Re: Ubuntu9.04正式版硬盘安装之后不能启动
帖子发表于 : 2009-05-10 10:03 

注册: 2008-08-23 14:12
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
问题终于解决了!!!!!!!!!!!!!!!
原来是用安装前多用了一条命令:
代码:
sudo umount -l /cdrom


我晕 :em06
/cdrom是虚拟光驱,要是把他卸掉那当然安装不了了。 :em05
谁让咱们是菜鸟....


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译