当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-27 0:02 

注册: 2009-04-26 23:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我下载了kscope-1.9.4.tar.gz,准备安装,安正常情况,解压后,cd到解压目录,然后
./configure
make
make install
安装,但是解压后的目录里没有configure,只有一个config文件。因为没有 makefile ,所以也编译不了,是在不知道怎么办了 :em20 ,第一次 在ubuntu 下装软件就碰到这样的问题,头大了。软件的压缩包,在附件里。那位大哥,帮小弟看看,感激不尽。最好能帮忙写个详细的步骤。谢谢。 :em06
本来装 kscope 直接 sudo apt-get install kscope 就能自动安装,但是不知道怎么回事,就是安装不了。下面是打印出的消息。

book@book-desktop:~$ sudo apt-get install kscope
[sudo] password for book:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
cscope exuberant-ctags graphviz kate kdelibs-data kdelibs4c2a libarts1c2a
libartsc0 libaudio2 libavahi-qt3-1 libgd2-xpm libgraphviz3 liblua50
liblualib50 libopenexr2c2a libqt3-mt
Suggested packages:
cbrowser vim nvi elvis vile emacsen msttcorefonts graphviz-doc kate-plugins
khelpcenter konsole fam nas libgd-tools libqt3-mt-psql libqt3-mt-mysql
libqt3-mt-odbc
Recommended packages:
kregexpeditor perl-suid libarts1-akode
The following NEW packages will be installed:
cscope exuberant-ctags graphviz kate kdelibs-data kdelibs4c2a kscope
libarts1c2a libartsc0 libaudio2 libavahi-qt3-1 libgd2-xpm libgraphviz3
liblua50 liblualib50 libopenexr2c2a libqt3-mt
0 upgraded, 17 newly installed, 0 to remove and 294 not upgraded.
Need to get 25.6MB of archives.
After unpacking 81.3MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
cscope exuberant-ctags libgd2-xpm libgraphviz3 graphviz libartsc0 libaudio2
libqt3-mt libarts1c2a libavahi-qt3-1 liblua50 liblualib50 libopenexr2c2a
kdelibs-data kdelibs4c2a kate kscope
Install these packages without verification [y/N]? y
Err http://cn.archive.ubuntu.com gutsy/universe cscope 15.6-3
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main exuberant-ctags 1:5.7-1
404 Not Found
Err http://cn.archive.ubuntu.com gutsy-updates/main libgd2-xpm 2.0.34-1ubuntu1.1
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main libgraphviz3 2.12-4ubuntu3
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main graphviz 2.12-4ubuntu3
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main libartsc0 1.5.8-0ubuntu1
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main libaudio2 1.9-2
404 Not Found
Err http://cn.archive.ubuntu.com gutsy-updates/main libqt3-mt 3:3.3.8really3.3.7-0ubuntu11.1
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main libarts1c2a 1.5.8-0ubuntu1
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main liblua50 5.0.3-2build1
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main liblualib50 5.0.3-2build1
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/main libopenexr2c2a 1.2.2-4.3ubuntu2
404 Not Found
Err http://cn.archive.ubuntu.com gutsy-updates/main kate 4:3.5.8-0ubuntu2.2
404 Not Found
Err http://cn.archive.ubuntu.com gutsy/universe kscope 1.5.2-1
404 Not Found
Err http://security.ubuntu.com gutsy-security/main libgd2-xpm 2.0.34-1ubuntu1.1
404 Not Found
Err http://security.ubuntu.com gutsy-security/main libavahi-qt3-1 0.6.20-2ubuntu3.4
404 Not Found
Err http://security.ubuntu.com gutsy-security/main kdelibs-data 4:3.5.8-0ubuntu3.4
404 Not Found
Err http://security.ubuntu.com gutsy-security/main kdelibs4c2a 4:3.5.8-0ubuntu3.4
404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 3_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb 404 Not Found
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 3_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 3_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 2_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb 404 Not Found
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 4_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 2_i386.deb 404 Not Found
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... .4_all.deb 404 Not Found
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 4_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 2_i386.deb 404 Not Found
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb 404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
book@book-desktop:~$


附件:
文件注释: kscope 1.9.4 的安装压缩包
kscope-1.9.4.tar.gz [124.89 KiB]
被下载 202 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-28 9:28 

注册: 2009-04-26 23:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
没人回应,自己顶起来!!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-28 9:28 

注册: 2009-04-26 23:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我再顶


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-28 9:29 

注册: 2009-04-26 23:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
再再顶


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-28 9:34 

注册: 2009-04-26 23:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
在黑暗中摸索,迷茫啊,摸不到一根稻草 :em20


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-29 11:15 

注册: 2008-08-30 15:45
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
楼主,加油!

我正找这方面的资料呢。你搞定了要记得回来说一声哦。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-29 12:54 

注册: 2008-08-30 15:45
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
楼主,我搞定了。过程如下:

1. 下载kscope1.94,http://debian.cs.binghamton.edu/debian/pool/main/k/kscope/kscope_1.9.4-1+b1_i386.deb
运行安装提示需要libqscintilla2-5;
2. 下载libqscintilla2-5,http://linux.cdpa.nsysu.edu.tw/debian/pool/main/q/qscintilla2/libqscintilla2-5_2.3.2-1.1_i386.deb
顺利完成安装;
3. 重新运行安装kscope1.94,提示需要cscope;
4. 开新立得安装cscope;
5. 重新运行安装kscope1.94,完成。

效果:
附件:
kscope.png
kscope.png [ 129.84 KiB | 被浏览 673 次 ]



页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-30 15:27 

注册: 2009-04-30 15:24
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
怎么功能这么少阿,源码也才100多K?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-30 16:22 

注册: 2009-04-26 23:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
cookiefj,非常感谢你,你是我在此论坛遇到的第一个热心人。再次感谢。 :em01
我看的还是有点迷惑,能否麻烦写详细些,包括输入哪些命令?
我刚接触ubuntu,菜的很。辛苦哈! :em06


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-30 16:25 

注册: 2009-04-26 23:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我上面附件里的那个kscope-1.9.4.tar.gz,cookiefj能用那个试试安装吗?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-04-30 16:46 

注册: 2009-04-30 15:24
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
justgg 写道:
我上面附件里的那个kscope-1.9.4.tar.gz,cookiefj能用那个试试安装吗?


1. 不使用新立得、通过命令安装:
$ sudo apt-get install libqtcore4 libqtgui4
$ sudo dpkg -i libqscintilla2-5_2.3.2-1.1_i386.deb
$ sudo dpkg -i kscope_1.9.4-1+b1_i386.deb
(执行 dpkg 的时候如果仍提示缺少一些包,输入 $ sudo apt-get -f install 也许可以将它们一起安装,我就是这样)

2. .tar.gz的那个源码包应该是需要使用 qmake 命令编译,不过似乎比较麻烦

:em02


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-05-01 18:52 

注册: 2008-08-30 15:45
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
debian系统还是尽量下载deb包安装吧,省事,你那个要编译的我就不尝试了。你用我贴的连接下载deb包安装应该没有问题的。

kscope用起来还是不错的。


justgg 写道:
我上面附件里的那个kscope-1.9.4.tar.gz,cookiefj能用那个试试安装吗?


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 安装 kscope-1.9.4 的疑问,大哥们帮忙。
帖子发表于 : 2009-06-05 11:44 

注册: 2008-04-22 14:33
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
1.9.4很多功能都不能用,现在还是1.6比较成熟好用
http://zhubangbing.blog.163.com/blog/st ... 915459486/


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译