当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 文档出现乱码如何解决呢
帖子发表于 : 2009-04-28 15:38 

注册: 2009-02-25 12:24
帖子: 414
地址: metwork
送出感谢: 0 次
接收感谢: 0 次
在windows下的txt文档进入ubuntu下打开,中文的都变成乱码,怎么解决呢 :em20


_________________
network


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-28 16:14 
头像

注册: 2008-07-28 19:51
帖子: 805
地址: 长沙
送出感谢: 1
接收感谢: 2
ubuntu下面默认是utf-8编码(LANG=zh_CN.UTF-8),看文档的时候用gbk编码就行


_________________
我的乌斑兔儿:http://zhanggang.net/m/b/b1/ubuntu右键选择在新的窗体打开
右边有一只黄手 ----> 或者注册Dropbox中文版感谢我


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-28 22:43 

注册: 2009-02-25 12:24
帖子: 414
地址: metwork
送出感谢: 0 次
接收感谢: 0 次
:em20 文档如何设置呢


_________________
network


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-28 22:53 

注册: 2008-04-08 0:14
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
或者转换一下编码,将文件转换为UTF-8编码

代码:
$iconv -f GBK -t UTF-8 filename.txt


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-28 22:58 

注册: 2009-02-25 12:24
帖子: 414
地址: metwork
送出感谢: 0 次
接收感谢: 0 次
:em20 楼上的方法好像每一次都要转换啊,有没有简单方便的,下次使用其它文档也是GBK编码呢


_________________
network


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-29 9:49 
头像

注册: 2009-03-20 1:29
帖子: 39
系统: ubuntu12.04
送出感谢: 0 次
接收感谢: 0 次
按alt+f2,输入gconf-editor,选择apps--->gedit-2--->preferences--->encodings,在右边的auto_detected项目的键值栏里鼠标双击,然后添加GBK18030,GBK,GB2312


_________________
主板: 华硕F1A75-V-PRO
内存: 金士顿 骇客神条 8G X 4(1600MHz)
硬盘: 西捷 2T
显示器:AOC 21“
cpu: AMD Apu3870k
机箱: 先马 夜鹰2
电源: 先马 省电王400(BTX-400-3)
系统: Ubuntu12.04


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-29 11:32 

注册: 2008-04-08 0:14
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
补充楼上,

添加GB18030,GBK,GB2312,另外一定要把这几中编码移到最前面去。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-29 11:35 
头像

注册: 2008-10-08 13:48
帖子: 3476
送出感谢: 0 次
接收感谢: 1
viewtopic.php?f=35&t=193612


_________________
--------------------------------------
论坛精华贴全集:http://forum.ubuntu.org.cn/viewtopic.php?f=48&t=199845
book:http://forum.ubuntu.org.cn/viewtopic.php?f=21&t=198286


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-29 16:50 

注册: 2009-04-27 12:40
帖子: 60
送出感谢: 2
接收感谢: 0 次
借个地方问一下,vi乱码咋办呢?


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-29 17:08 

注册: 2009-02-25 12:24
帖子: 414
地址: metwork
送出感谢: 0 次
接收感谢: 0 次
:em20 没有直接的方法吗,似乎每次都要转换,可以安装其它的记事本软件吗


_________________
network


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-29 17:10 
头像

注册: 2009-04-29 13:53
帖子: 1487
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
ccwdky 写道:
在windows下的txt文档进入ubuntu下打开,中文的都变成乱码,怎么解决呢 :em20

用ooo打开可以吗?


_________________
UbuntuABC


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-30 12:00 

注册: 2009-02-25 12:24
帖子: 414
地址: metwork
送出感谢: 0 次
接收感谢: 0 次
qingwashaoye 写道:
按alt+f2,输入gconf-editor,选择apps--->gedit-2--->preferences--->encodings,在右边的auto_detected项目的键值栏里鼠标双击,然后添加GBK18030,GBK,GB2312



:em03 非常感谢,成功了


_________________
network


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-30 21:54 

注册: 2007-10-06 0:56
帖子: 139
送出感谢: 0 次
接收感谢: 0 次
六楼和七楼的意见正确!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 文档出现乱码如何解决呢
帖子发表于 : 2009-04-30 22:20 

注册: 2009-02-25 12:24
帖子: 414
地址: metwork
送出感谢: 0 次
接收感谢: 0 次
文档和windows编码(utf-8默认)不同,出现乱码
解决:
-----按alt+f2
-----输入gconf-editor
-----选择apps--->gedit-2--->preferences-->encodings
-----在右边的auto_detected项目的键值栏里鼠标双击
-----然后添加GBK18030,GBK,GB2312
-----添加GB18030,GBK,GB2312,另外一定要把这几中编码移到最前面去

:em11


_________________
network


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译