当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-07 8:54 

注册: 2009-04-28 8:09
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
安装deb文件本来在Ubuntu里就像在windows里安装exe文件一样,但现在出现所谓依赖关系不存在,是否是系统没有完全update导致?Ubuntu刚安装好进行升级更新并不能一下子成功,常常要反复几次才行。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-07 9:02 
头像

注册: 2008-07-23 19:06
帖子: 746
送出感谢: 0 次
接收感谢: 0 次
提示缺什么装什么阿


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-07 14:46 

注册: 2009-04-28 8:09
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
朋友,如你说的那么简单就好,问题是缺的文件无法安装啊。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-07 14:48 
头像

注册: 2008-06-23 15:19
帖子: 3030
地址: 北欧某国
系统: ���������
送出感谢: 21
接收感谢: 6
是不是软件源的问题?


_________________
http://noie.name 网站改版中。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-07 15:33 

注册: 2007-03-17 1:15
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
Hello World! 写道:
是不是软件源的问题?


我觉得很有可能


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-07 16:00 

注册: 2009-04-28 8:09
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
这个问题如我估计的,经过大半天的艰难升级,更新软件管理,虽然还没有完全更新好,但是现在可以安装mplayer了,这在上午是不行的,Ubuntu的升级更新速度非常低,还常常失败,你非要有耐心不可,这就是Ubuntu和windows的差距之一,希望Ubuntu的发展更迅速一点。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-08 0:15 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
依赖关系与升不升级是没有关系的.
楼主可以这么来理解依赖, 如果有三个软件分别为:a,b,c, 而且都需要一个"工具" W (linux的人一般称之为"库"), 才能运行的话, 你机子里只要装有一个W 库, 库W就可以共享给a;b;c用. 这样可以减少很多不必要的麻烦, 而且大大节约了磁盘.
以上纯属个人理解, 如有不对之处, 还请楼下纠正.. :em03


_________________
In a world without walls who needs Windows?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-08 1:46 
头像

注册: 2008-10-08 13:48
帖子: 3476
送出感谢: 0 次
接收感谢: 1
xh26bw 写道:
朋友,如你说的那么简单就好,问题是缺的文件无法安装啊。

:em04 不是提示少什么你就能装上,得看哪个包里有这个文件,然后装这个包……


_________________
--------------------------------------
论坛精华贴全集:http://forum.ubuntu.org.cn/viewtopic.php?f=48&t=199845
book:http://forum.ubuntu.org.cn/viewtopic.php?f=21&t=198286


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-08 9:27 

注册: 2009-04-28 8:09
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
各位朋友,谢谢你们关心,根据我个人经历,程序安装的依赖关系与升级更新是有关系的,因为昨天我刚安装了Ubuntu,没法安装一些程序,只好耐心升级更新,半天后自然能够安装了。这个源在安装光盘上是没有完全的,是不充分的,只能安装好后联网升级更新,水到自然成就。凭心而论,这个Ubuntu或其他linux系统,在使用上网上服务上无法与windows比,但他是我们学习linux的好工具。如果Ubuntu能支持3d大型游戏,windows就日子难过了,霸主地位就没了。虽然,Ubuntu现在只能当学习工具,娱乐方面功能弱,但前途是大大的有啊。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-08 9:38 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
更新慢那就换源啊,装好系统后请先看wiki,快速指南等等


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-08 9:41 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
楼主搞错了吧。只有windows/mac才会去兼容程序,linux不会对程序做出让步。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 安装deb文件出现依赖关系不足?
帖子发表于 : 2009-05-08 12:54 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
可能是一些不会打包的人做的吧。像我不会打包————做出来的的deb没法解决依赖问题。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译