当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-14 8:53 

注册: 2009-04-29 21:22
帖子: 1081
送出感谢: 3
接收感谢: 1
曾经用这个命令 ,成功地把8.10版升级到了9.04版,现在却升级不了。那次升级也没有提示重启,这次还有提示重启。但重启依旧。如何处置。命令 结果如下:


~$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在筹划升级... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 5 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 linux-image-2.6.28-12-generic (2.6.28-12.43) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.28-12-generic
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.28-12-generic
Found kernel: /boot/vmlinuz-2.6.28-11-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... /usr/sbin/update-grub: line 1516: /boot/grub/menu.lst: Permission denied
User postinst hook script [/sbin/update-grub] exited with value 1
dpkg:处理 linux-image-2.6.28-12-generic (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 linux-restricted-modules-2.6.28-12-generic 的配置工作不能继续:
linux-restricted-modules-2.6.28-12-generic 依赖于 linux-image-2.6.28-12-generic;然而:
软件包 linux-image-2.6.28-12-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-2.6.28-12-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-image-generic 的配置工作不能继续:
linux-image-generic 依赖于 linux-image-2.6.28-12-generic;然而:
软件包 linux-image-2.6.28-12-generic 还没有被配置。
dpkg:处理 linux-image-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-generic 的配置工作不能继续:
linux-restricted-modules-generic 依赖于 linux-restricted-modules-2.6.28-12-generic;然而:
软件包 linux-restricted-modules-2.6.28-12-generic 还没有被配置。
dpkg:处理 linux-restricted-modNo apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
ules-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-generic 的配置工作不能继续:
linux-generic 依赖于 linux-image-generic (= 2.6.28.12.16);然而:
软件包 linux-image-generic 还没有被配置。
linux-generic 依赖于 linux-restricted-modules-generic (= 2.6.28.12.16);然而:
软件包 linux-restricted-modules-generic 还没有被配置。
dpkg:处理 linux-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
linux-image-2.6.28-12-generic
linux-restricted-modules-2.6.28-12-generic
linux-image-generic
linux-restricted-modules-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-14 8:56 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
想不出,试试换源,或者刷新列表先。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-14 22:59 

注册: 2009-04-29 21:22
帖子: 1081
送出感谢: 3
接收感谢: 1
eexpress 写道:
想不出,试试换源,或者刷新列表先。


确认与源无关和刷新列表无关。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-14 23:49 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
在图形界面升级?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-14 23:51 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
据说在命令行妥当一点。
在WUBI用命令成功升级过
现在用904等下次升级试试


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-15 8:36 

注册: 2008-03-05 13:25
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
换源以后成功在命令行界面升级到9.10


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-15 8:40 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
升级建议使用 sudo do-release-upgrade

对于 ubuntu,apt-get dist-upgrade 是用来更新的,不是用来升级的。

当然,一般来说 do-release-upgrade 要 beta 版出了之后才能用,现在 alpha 期还不能用。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-15 8:44 

注册: 2009-04-29 21:22
帖子: 1081
送出感谢: 3
接收感谢: 1
poet 写道:
升级建议使用 sudo do-release-upgrade

对于 ubuntu,apt-get dist-upgrade 是用来更新的,不是用来升级的。

当然,一般来说 do-release-upgrade 要 beta 版出了之后才能用,现在 alpha 期还不能用。

现在用sudo do-release-upgrade的确不能升级。命令 的结果是:

Checking for a new ubuntu release
No new release found


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-15 8:45 

注册: 2009-04-29 21:22
帖子: 1081
送出感谢: 3
接收感谢: 1
kavanayy 写道:
换源以后成功在命令行界面升级到9.10


我这不是一个源的问题 。因为已经成功下载,是下载后不能安装而已。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-15 9:07 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
先执行
代码:
sudo dpkg --configure -a


代码:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

我次升级时Xorg不能配置,后来用这样搞好的.


_________________
Grub2 基础教程


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 用sudo apt-get dist-upgrade 不能成功实现发行版升级
帖子发表于 : 2009-05-15 9:19 

注册: 2009-04-29 21:22
帖子: 1081
送出感谢: 3
接收感谢: 1
smallapple 写道:
先执行
代码:
sudo dpkg --configure -a


代码:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

我次升级时Xorg不能配置,后来用这样搞好的.


问题 依旧。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译