当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 9:31 
头像

注册: 2009-03-29 21:28
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
我也不知怎么回事,导致火狐安装不上了,我把xulrunner-1.9给卸载了,然后又重装,总是在最后的时候说没有安装成功,之后又装火狐,然而火狐也是装不上。装xulrunner-1.9的时候出现以下:
引用:
tony@tony-desktop:~$ sudo apt-get -f install xulrunner-1.9
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
xulrunner-1.9
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/7547kB of archives.
After this operation, 20.9MB of additional disk space will be used.
Selecting previously deselected package xulrunner-1.9.
(Reading database ... 137297 files and directories currently installed.)
Unpacking xulrunner-1.9 (from .../xulrunner-1.9_1.9.0.10+nobinonly-0ubuntu0.8.10.1_i386.deb) ...
Setting up xulrunner-1.9 (1.9.0.10+nobinonly-0ubuntu0.8.10.1) ...
/usr/lib/xulrunner-1.9.0.10/xulrunner-bin: error while loading shared libraries: libplds4.so.0d: cannot open shared object file: No such file or directory
dpkg: error processing xulrunner-1.9 (--configure):
subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
xulrunner-1.9
E: Sub-process /usr/bin/dpkg returned an error code (1)

到底是哪里出问题了呢?望高手给予指点,谢谢了先。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 12:14 
头像

注册: 2009-03-29 21:28
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
怎么没人理啊? :em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 12:22 
头像

注册: 2008-04-07 17:36
帖子: 4010
地址: 泰安人在阜新
送出感谢: 0 次
接收感谢: 0 次
说是丢了个文件

你试试重装 下

这个软件包

sudo apt-get reinstall libnspr4-0d


我的是64位的系统

显示 ia32-libs也包括这个文件,如果你也是64位的系统,可以也试试重装下这个

记下这个命令 dpkg --search


_________________
宇宙数学物理 sssssssss Ubuntu 桌面培训 sssssssss 问打包的问题之前先看
和我一样的新手请看,我看过了,腰不酸了,腿不疼了,上楼也有劲了
想去IRC的点这里——一个比QQ群好N多的东西


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 12:32 
头像

注册: 2009-03-29 21:28
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
还是不行啊,显示这样:
引用:
tony@tony-desktop:~$ sudo apt-get install libnspr4-0d
Reading package lists... Done
Building dependency tree
Reading state information... Done
libnspr4-0d is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up xulrunner-1.9 (1.9.0.10+nobinonly-0ubuntu0.8.10.1) ...
/usr/lib/xulrunner-1.9.0.10/xulrunner-bin: error while loading shared libraries: libplds4.so.0d: cannot open shared object file: No such file or directory
dpkg: error processing xulrunner-1.9 (--configure):
subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
xulrunner-1.9
E: Sub-process /usr/bin/dpkg returned an error code (1)

如何是好?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 12:32 
头像

注册: 2009-03-29 21:28
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
还是不行啊,显示这样:
引用:
tony@tony-desktop:~$ sudo apt-get install libnspr4-0d
Reading package lists... Done
Building dependency tree
Reading state information... Done
libnspr4-0d is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up xulrunner-1.9 (1.9.0.10+nobinonly-0ubuntu0.8.10.1) ...
/usr/lib/xulrunner-1.9.0.10/xulrunner-bin: error while loading shared libraries: libplds4.so.0d: cannot open shared object file: No such file or directory
dpkg: error processing xulrunner-1.9 (--configure):
subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
xulrunner-1.9
E: Sub-process /usr/bin/dpkg returned an error code (1)

如何是好?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 12:58 
头像

注册: 2008-04-07 17:36
帖子: 4010
地址: 泰安人在阜新
送出感谢: 0 次
接收感谢: 0 次
reinstall!!!!!!re!!!!!!


_________________
宇宙数学物理 sssssssss Ubuntu 桌面培训 sssssssss 问打包的问题之前先看
和我一样的新手请看,我看过了,腰不酸了,腿不疼了,上楼也有劲了
想去IRC的点这里——一个比QQ群好N多的东西


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 13:24 
头像

注册: 2009-03-29 21:28
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
wzssyqa 写道:
reinstall!!!!!!re!!!!!!

然后又这样了:
引用:

tony@tony-desktop:~$ sudo apt-get install --reinstall libnspr4-0d
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B/126kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libnspr4-0d
Install these packages without verification [y/N]? y
(Reading database ... 137649 files and directories currently installed.)
Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu5~0mt1 (using .../libnspr4-0d_4.7.1+1.9-0ubuntu5~0mt1_i386.deb) ...
Unpacking replacement libnspr4-0d ...
Setting up libnspr4-0d (4.7.1+1.9-0ubuntu5~0mt1) ...

Setting up xulrunner-1.9 (1.9.0.10+nobinonly-0ubuntu0.8.10.1) ...
/usr/lib/xulrunner-1.9.0.10/xulrunner-bin: error while loading shared libraries: libssl3.so.1d: cannot open shared object file: No such file or directory
dpkg: error processing xulrunner-1.9 (--configure):
subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
xulrunner-1.9
E: Sub-process /usr/bin/dpkg returned an error code (1)
哎,搞死了。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 13:34 
头像

注册: 2008-04-07 17:36
帖子: 4010
地址: 泰安人在阜新
送出感谢: 0 次
接收感谢: 0 次
哦,是32位的和64位的不一样

你执行下

sudo dpkg --search libplds4.so.0d

帖出结果来看看


_________________
宇宙数学物理 sssssssss Ubuntu 桌面培训 sssssssss 问打包的问题之前先看
和我一样的新手请看,我看过了,腰不酸了,腿不疼了,上楼也有劲了
想去IRC的点这里——一个比QQ群好N多的东西


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 我的xulrunner-1.9不能安装,导致火狐也不能装上。惨啊!
帖子发表于 : 2009-05-25 14:31 
头像

注册: 2009-03-29 21:28
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
我应该是少了很多/usr/lib下的很多东西,估计是我不小心给删除了。当我把libplds4.so.0d复制到/usr/lib下时,又少了libsmime3.so.1d,哎,我再复制一下试试。谢谢楼上的了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译