当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请大家来帮帮我~!
帖子发表于 : 2009-06-07 11:45 

注册: 2009-05-28 23:52
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
我现在是用ubuntu 9.04, 但是我想在它那里做点东西,比如说我想学C语言。至于GNU/Linux gdb等那工具,我不知道我自己怎么也找不到。不知道哪个高手来告诉它们在Linux 什么地方,或者去哪里下载。。。

Thanks all your help


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请大家来帮帮我~!
帖子发表于 : 2009-06-07 12:13 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
http://wiki.ubuntu.org.cn/
看看先吧


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请大家来帮帮我~!
帖子发表于 : 2009-06-07 12:14 

注册: 2008-07-09 0:39
帖子: 353
送出感谢: 1
接收感谢: 0 次
Linux C编程一站式学习
http://learn.akae.cn/media/index.html


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请大家来帮帮我~!
帖子发表于 : 2009-06-07 12:51 

注册: 2009-01-30 18:18
帖子: 319
地址: 湖北十堰
送出感谢: 5
接收感谢: 3
http://man.chinaunix.net

Man.ChinaUnix.net,ChinaUnix.net技术文档手册中心,旨在学习和分享的资源中心,欢迎您的使用


ubuntu8.04系列七--软件开发篇

文章欢迎转载,转载请注明出处:嘉骏苑http://luckiss.blogcn.com

Linux是开发者的乐园

1。安装JAVA环境支持

sudo apt-get install sun-java6-jre

如果空间富裕,建议安装一个JDK:

sudo apt-get install sun-java6-jdk

提示:安装过程中需要你回答是否同意使用协议(终端中红蓝色的提示界面),此时按tab键至OK,再按回车即可正常安装。

设置当前默认的java解释器:

sudo update-alternatives --config java

执行后会出现类似如下的画面:

There are 2 alternatives which provide `java'.

Selection Alternative

-----------------------------------------------

1 /usr/bin/gij-wrapper-4.1

*+ 2 /usr/lib/jvm/java-6-sun/jre/bin/java

# Press enter to keep the default, or type selection number:

输入有包含 "sun" 的行的前面的数字。如上面显示,则输入2,然后回车确定。

配置JAVA环境变量:

sudo gedit /etc/environment

在其中添加如下两行:

CLASSPATH=.:/usr/lib/jvm/java-6-sun/lib

JAVA_HOME=/usr/lib/jvm/java-6-sun

sudo gedit /etc/jvm

将文件中的

/usr/lib/jvm/java-6-sun

这一行填入到配置块的顶部

安装浏览器的JAVA Plugin(可选):

sudo apt-get install sun-java6-plugin

java中文支持(或乱码的解决):java程序是跨平台的,但需要解决中文支持问题。

方法很简单,就是在java安装目录下放进去一个中文字体即可。

cd /usr/lib/jvm/java-6-sun/jre/lib/fonts

  sudo mkdir fallback

  cd fallback

  sudo ln -s ~/.fonts/fireflysung.ttf(我选了最新的文泉驿夸父字体,/usr/share/fonts/wenquanyi/wqy-zenhei/wqy-zenhei.ttf)

  sudo mkfontdir

  sudo mkfontscale

2.搭建ubuntu下的C++编程环境:

编译器:sudo apt-get install build-essential gcc make autoconf automake libtool gdb g++

编辑器,任选一个:

sudo apt-get install emacs

sudo apt-get install vim

vim默认语法染色功能是关闭的,我们可以编辑/etc/vim/vimrc文件

把syntax on 前面的符号去掉,然后保存。就可以启动vim的语法染色功能。

构建Gnome 开发环境:

sudo apt-get install gnome-devel

eclipse也是不错的选择:建议到以下地址直接下载eclipse for cpp:

http://www.eclipse.org/downloads/

关于启动eclipse出现:JVM terminated. Exit code=13错误的解决方法:

首先用命令选择正确的java版本:

sudo update-alternatives --config java

然后把 ~/workspace目录中的.metadata目录删除就可以了

下载c/c++版本的

选择最快的镜像点:[Korea, Republic Of] Daum Communications Corp. (http)

3。构建KDE开发环境

sudo apt-get install kdevelop kdesdk

这个IDE有很多组件,主要是用于QT编程的,里面有一个KDevelop助手的工具可以当作类似MSDN的工具来使用^_^

4。安装codeblocks

可以到http://www.codeblocks.org下载,

也可以把deb http://lgp203.free.fr/ubuntu/ hardy universe加入源,更新源后然后:

sudo apt-get install codeblocks

这个软件也是一个不错的C++ IDE,在windows上用过DEV的朋友估计会听过这个软件

5。安装openGL开发所必须的库freeglut3-dev,

它会将依赖的包都装上:

sudo apt-get install freeglut3-dev

6。安装LaTeX:

sudo apt-get install texlive

安装IDE 介面:

sudo apt-get install texmaker

如果够专业的话,装上完整版,空间消耗425M/884M:

sudo apt-get install texlive-full

7。UML建模软件

sudo apt-get install umbrello

8。版本管理软件

sudo apt-get cvs subversion git-core libwnck-dev

9。流程图绘制软件

sudo apt-get install dia


_________________
愿意同大家一起学习分享linux知识


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 请大家来帮帮我~!
帖子发表于 : 2009-06-07 13:29 

注册: 2009-03-25 13:17
帖子: 206
送出感谢: 1
接收感谢: 0 次
可以安装Code::Blocks


_________________
生命诚可贵
不因虚度年华而悔恨
Dropbox: http://db.tt/zYrxtyj


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译