当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu9.04 CD版问题
帖子发表于 : 2009-06-13 15:04 

注册: 2009-06-12 11:58
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
ubuntu CD版 安装完 以后 在装软件 需要编译的时候 缺少 gtk+-2.0 ……
我再去 安装 gtk+-2.0 ,又缺少 这些文件……
依赖: libglib2.0-dev 但是此软件包将不会被安装
依赖: libpango1.0-dev 但是此软件包将不会被安装
依赖: libatk1.0-dev 但是此软件包将不会被安装
依赖: libcairo2-dev 但是此软件包将不会被安装
依赖: libx11-dev 但是此软件包将不会被安装
依赖: libxext-dev 但是此软件包将不会被安装
依赖: libxinerama-dev 但是此软件包将不会被安装
依赖: libxi-dev 但是此软件包将不会被安装
依赖: libxrandr-dev 但是此软件包将不会被安装
依赖: libxcursor-dev 但是此软件包将不会被安装
依赖: libxfixes-dev 但是此软件包将不会被安装
依赖: libxcomposite-dev 但是此软件包将不会被安装
依赖: libxdamage-dev 但是此软件包将不会被安装

我又放弃 装 gtk+-2.0 去装 libglib2.0-dev ,又告诉我缺少 东西……

我晕死! 谁能告诉我怎么一次装完所有需要的东西!!!! 这样搞的我 不知道先 装哪一个了!!!!!

谁帮帮我?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu9.04 CD版问题
帖子发表于 : 2009-06-13 15:08 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
你用什么命令安装的?


你只要加入源, 更新, 再用 apt-get 安装,只要没出现版本依赖错误,就会自动安装需要的包


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu9.04 CD版问题
帖子发表于 : 2009-06-13 15:10 

注册: 2009-06-12 11:58
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu9.04 CD版问题
帖子发表于 : 2009-06-13 15:13 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
软件名能透露一下么?搞这么神秘


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu9.04 CD版问题
帖子发表于 : 2009-06-13 15:49 

注册: 2009-06-12 11:58
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
ps:软件名能透露一下么?搞这么神秘

ubuntu-tweak-0.4.7.1

我再去 文件夹里找 麻烦~ 不是神秘!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu9.04 CD版问题
帖子发表于 : 2009-06-13 15:51 

注册: 2009-06-12 11:58
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我擦! 装 sudo apt-get install gstreamer0.10-*
怎么又出现那么多依赖关系???
gstreamer0.10-ffmpeg: 依赖: libavcodec52 (>= 3:0.svn20090303-1) 但却无法安装它 或
libavcodec-unstripped-52 (>= 3:0.svn20090303-1) 但却无法安装它
依赖: libavformat52 (>= 3:0.svn20090303-1) 但是 3:0.svn20080206-12ubuntu3.1 正要被安装 或
libavformat-unstripped-52 (>= 3:0.svn20090303-1) 但是它将不会被安装
依赖: libavutil49 (>= 3:0.svn20090303-1) 但是 3:0.svn20080206-12ubuntu3.1 正要被安装 或
libavutil-unstripped-49 (>= 3:0.svn20090303-1) 但是它将不会被安装
依赖: libpostproc51 (>= 3:0.svn20090303-1) 但是 3:0.svn20080206-12ubuntu3.1 正要被安装 或
libpostproc-unstripped-51 (>= 3:0.svn20090303-1) 但是它将不会被安装
依赖: libswscale0 (>= 3:0.svn20090303-1) 但是它将不会被安装 或
libswscale-unstripped-0 (>= 3:0.svn20090303-1) 但是它将不会被安装
gstreamer0.10-packagekit: 依赖: packagekit (= 0.3.14-0ubuntu4) 但是它将不会被安装
gstreamer0.10-plugins-bad: 冲突: gstreamer0.10-fluendo-mpegdemux 但是 0.10.15-1 正要被安装
冲突: gstreamer0.10-fluendo-mpegmux 但是 0.10.4-1 正要被安装
gstreamer0.10-plugins-bad-multiverse: 依赖: libmjpegtools0c2a (>= 1:1.8.0) 但是它将不会被安装
gstreamer0.10-plugins-base-dbg: 依赖: gstreamer0.10-alsa (= 0.10.21-3ubuntu0.1) 但是 0.10.22-5 正要被安装
依赖: gstreamer0.10-gnomevfs (= 0.10.21-3ubuntu0.1) 但是 0.10.22-5 正要被安装
依赖: gstreamer0.10-plugins-base (= 0.10.21-3ubuntu0.1) 但是 0.10.22-5 正要被安装
依赖: gstreamer0.10-x (= 0.10.21-3ubuntu0.1) 但是 0.10.22-5 正要被安装
依赖: libgstreamer-plugins-base0.10-0 (= 0.10.21-3ubuntu0.1) 但是 0.10.22-5 正要被安装
gstreamer0.10-plugins-good-dbg: 依赖: gstreamer0.10-plugins-good (= 0.10.10.4-1ubuntu1.1) 但是 0.10.14-1 正要被安装
依赖: gstreamer0.10-pulseaudio (= 0.10.10.4-1ubuntu1.1) 但是 0.10.14-1 正要被安装
libgstreamer0.10-0-dbg: 依赖: libgstreamer0.10-0 (= 0.10.21-4) 但是 0.10.22-1 正要被安装
libgstreamer0.10-dev: 依赖: libgstreamer0.10-0 (= 0.10.21-4) 但是 0.10.22-1 正要被安装
依赖: libglib2.0-dev 但是它将不会被安装
依赖: libxml2-dev 但是它将不会被安装

怎么把那些依赖关系 全部都搞定??????????????????????????????????

我都快发疯了~!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译