当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 9.04无法识别U盘
帖子发表于 : 2009-06-22 21:15 

注册: 2009-06-22 19:37
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
实在受不了win的病毒,看网上说ubuntu不错,今天花了一天的时间终于安装、升级好系统和软件,什么都齐了,接着准备把一些刚备份的文件从U盘拷到新系统。发生如下情况:
插上去,U盘闪。
U盘盘符出现,点击U盘,提示“无法加载”
一会U盘盘符自动消失。。。。。。。。

反反复复几次都这样,后来又查询了网上,用命令查看了一下
lsmod |grep usb
usb_storage 99520 0
usbhid 42336 0

dmesg
[ 8945.568163] usb 1-5: new high speed USB device using ehci_hcd and address 32
[ 8945.703727] usb 1-5: configuration #1 chosen from 1 choice
[ 8945.708125] scsi9 : SCSI emulation for USB Mass Storage devices
[ 8945.709236] usb-storage: device found at 32
[ 8945.709242] usb-storage: waiting for device to settle before scanning
[ 8950.708656] usb-storage: device scan complete
[ 8950.709223] scsi 9:0:0:0: CD-ROM Super Name 1.00 PQ: 0 ANSI: 2
[ 8950.709708] scsi 9:0:0:1: Direct-Access Super Name 1.00 PQ: 0 ANSI: 2
[ 8950.725050] sr1: scsi-1 drive
[ 8950.725280] sr 9:0:0:0: Attached scsi CD-ROM sr1
[ 8950.725421] sr 9:0:0:0: Attached scsi generic sg2 type 5
[ 8950.726307] sd 9:0:0:1: [sdb] 14654324 512-byte hardware sectors: (7.50 GB/6.98 GiB)
[ 8950.726924] sd 9:0:0:1: [sdb] Write Protect is off
[ 8950.726930] sd 9:0:0:1: [sdb] Mode Sense: 23 00 00 00
[ 8950.726936] sd 9:0:0:1: [sdb] Assuming drive cache: write through
[ 8950.738567] sd 9:0:0:1: [sdb] 14654324 512-byte hardware sectors: (7.50 GB/6.98 GiB)
[ 8950.739171] sd 9:0:0:1: [sdb] Write Protect is off
[ 8950.739178] sd 9:0:0:1: [sdb] Mode Sense: 23 00 00 00
[ 8950.739185] sd 9:0:0:1: [sdb] Assuming drive cache: write through
[ 8950.739196] sdb:
[ 8950.969250] sd 9:0:0:1: [sdb] Attached SCSI removable disk
[ 8950.969400] sd 9:0:0:1: Attached scsi generic sg3 type 0
[ 8951.584723] usb 1-5: reset high speed USB device using ehci_hcd and address 32
[ 8966.696149] usb 1-5: device descriptor read/64, error -110

看网上说大多都是rmmod ehci_hcd方法,我不管3721,也来使用,结果提示
ERROR: Module ehci_hcd does not exist in /proc/modules
难道是我的系统里面没有ehci_hcd吗,晕阿,继续又查网上,查了好久,也没有找到办法。实在没法了只有向论坛的高手没请教了。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-22 21:19 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
似乎是有错误。不挂载,先fsck试试。
device descriptor read/64, error -110


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-22 21:56 

注册: 2009-06-22 19:37
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
fsck了,还是不行
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda1 is mounted.

WARNING!!! Running e2fsck on a mounted filesystem may cause
SEVERE filesystem damage.

Do you really want to continue (y/n)? yes

/dev/sda1: recovering journal
Clearing orphaned inode 580047 (uid=1000, gid=1000, mode=0100600, size=0)
Clearing orphaned inode 580363 (uid=0, gid=0, mode=0100644, size=7624)
/dev/sda1: clean, 133257/610800 files, 863580/2441872 blocks
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda7 is mounted.

WARNING!!! Running e2fsck on a mounted filesystem may cause
SEVERE filesystem damage.

Do you really want to continue (y/n)? yes

/dev/sda7: recovering journal
/dev/sda7: clean, 38846/642112 files, 203736/2564359 blocks

另外补充一下,刚才忘了说,我的优盘是8个G的,其中量产了一个光驱。不知道这个有没有影响


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-22 22:02 
头像

注册: 2009-02-25 18:18
帖子: 2229
送出感谢: 0 次
接收感谢: 0 次
zxjnfs 写道:
fsck了,还是不行
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda1 is mounted.

WARNING!!! Running e2fsck on a mounted filesystem may cause
SEVERE filesystem damage.

Do you really want to continue (y/n)? yes

/dev/sda1: recovering journal
Clearing orphaned inode 580047 (uid=1000, gid=1000, mode=0100600, size=0)
Clearing orphaned inode 580363 (uid=0, gid=0, mode=0100644, size=7624)
/dev/sda1: clean, 133257/610800 files, 863580/2441872 blocks
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda7 is mounted.

WARNING!!! Running e2fsck on a mounted filesystem may cause
SEVERE filesystem damage.

Do you really want to continue (y/n)? yes

/dev/sda7: recovering journal
/dev/sda7: clean, 38846/642112 files, 203736/2564359 blocks

另外补充一下,刚才忘了说,我的优盘是8个G的,其中量产了一个光驱。不知道这个有没有影响

木有影响,我的U,16G量产一光驱一移动,工作正常。

刚看了一下你检查的,根本没检查U盘啊 :em20 你把U盘插别的机器上看看。


_________________
在中国搞IT的谁不知道Ctrl+C,Ctrl+V啊~


最后由 AngelMAX 编辑于 2009-06-22 23:03,总共编辑了 1 次

页首
 用户资料  
 
5 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-22 22:06 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
http://ubuntuforums.org/archive/index.php/t-163716.html


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-22 23:05 
头像

注册: 2009-02-25 18:18
帖子: 2229
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
http://ubuntuforums.org/archive/index.php/t-163716.html

2年的bug? :em20
我的是8.10工作正常 :em06


_________________
在中国搞IT的谁不知道Ctrl+C,Ctrl+V啊~


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-22 23:10 

注册: 2009-06-22 19:37
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
http://ubuntuforums.org/archive/index.php/t-163716.html


费劲的看了很久,好像是个BUG,没有解决的办法?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-23 9:08 

注册: 2009-06-22 19:37
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
高手们,有没有办法帮我解决阿,工作、生活中用电脑离不开U盘阿,如果ubuntu不识别,只能又回win了


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-23 9:17 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
额,球猫还搞出一个bug的事件?
用u盘,可从来没碰过。
可以试试去掉光驱的。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-23 15:37 

注册: 2009-06-22 19:37
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
奇怪了,装了KDE,在KDE下能识别,访问,就是不能安全卸载。

linux,还是很多地方都不懂阿 :em20


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-24 15:38 

注册: 2009-06-14 13:30
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
zxjnfs 写道:
实在受不了win的病毒,看网上说ubuntu不错,今天花了一天的时间终于安装、升级好系统和软件,什么都齐了,接着准备把一些刚备份的文件从U盘拷到新系统。发生如下情况:
插上去,U盘闪。
U盘盘符出现,点击U盘,提示“无法加载”
一会U盘盘符自动消失。。。。。。。。

反反复复几次都这样,后来又查询了网上,用命令查看了一下
lsmod |grep usb
usb_storage 99520 0
usbhid 42336 0

dmesg
[ 8945.568163] usb 1-5: new high speed USB device using ehci_hcd and address 32
[ 8945.703727] usb 1-5: configuration #1 chosen from 1 choice
[ 8945.708125] scsi9 : SCSI emulation for USB Mass Storage devices
[ 8945.709236] usb-storage: device found at 32
[ 8945.709242] usb-storage: waiting for device to settle before scanning
[ 8950.708656] usb-storage: device scan complete
[ 8950.709223] scsi 9:0:0:0: CD-ROM Super Name 1.00 PQ: 0 ANSI: 2
[ 8950.709708] scsi 9:0:0:1: Direct-Access Super Name 1.00 PQ: 0 ANSI: 2
[ 8950.725050] sr1: scsi-1 drive
[ 8950.725280] sr 9:0:0:0: Attached scsi CD-ROM sr1
[ 8950.725421] sr 9:0:0:0: Attached scsi generic sg2 type 5
[ 8950.726307] sd 9:0:0:1: [sdb] 14654324 512-byte hardware sectors: (7.50 GB/6.98 GiB)
[ 8950.726924] sd 9:0:0:1: [sdb] Write Protect is off
[ 8950.726930] sd 9:0:0:1: [sdb] Mode Sense: 23 00 00 00
[ 8950.726936] sd 9:0:0:1: [sdb] Assuming drive cache: write through
[ 8950.738567] sd 9:0:0:1: [sdb] 14654324 512-byte hardware sectors: (7.50 GB/6.98 GiB)
[ 8950.739171] sd 9:0:0:1: [sdb] Write Protect is off
[ 8950.739178] sd 9:0:0:1: [sdb] Mode Sense: 23 00 00 00
[ 8950.739185] sd 9:0:0:1: [sdb] Assuming drive cache: write through
[ 8950.739196] sdb:
[ 8950.969250] sd 9:0:0:1: [sdb] Attached SCSI removable disk
[ 8950.969400] sd 9:0:0:1: Attached scsi generic sg3 type 0
[ 8951.584723] usb 1-5: reset high speed USB device using ehci_hcd and address 32
[ 8966.696149] usb 1-5: device descriptor read/64, error -110

看网上说大多都是rmmod ehci_hcd方法,我不管3721,也来使用,结果提示
ERROR: Module ehci_hcd does not exist in /proc/modules
难道是我的系统里面没有ehci_hcd吗,晕阿,继续又查网上,查了好久,也没有找到办法。实在没法了只有向论坛的高手没请教了。


我和你有一模一样的问题,同求解~~
奇怪的是,插了其他人的一个U盘,却能识别,见鬼


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-24 16:19 

注册: 2009-06-14 13:30
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
摸索着搞定了
搜到一个做法,引用如下:
1、插入U盘
2、输入 fdisk -l /dev/sda 查看输出结果,比如我的是这样的: # fdisk -l /dev/sda Disk /dev/sda: 131 MB, 131104768 bytes 3 heads, 32 sectors/track, 2667 cylinders Units = cylinders of 96 * 512 = 49152 bytes Device Boot Start End Blocks Id System /dev/sda1 * 1 2668 128016 6 FAT16 注意:如果您的硬盘是 SCSI 接口的话,可能要将 sda 改成 sdb, sdc, sdd 等,以此类推。
3、看了上面的输出就知道U盘所在的设备了,比如我的就是/dev/sda1,接着便是挂载了,假设我将U盘挂载到/mnt/usb目录中,
就是 mount -t auto -o iocharset=cp936 /dev/sda1 /mnt/usb/
4、打开/mnt/usb 就可以看到你的U盘里的东西了!

按照上面的做法,看不到U盘是哪个,即使把sda1改成sdb,sdc,后面也走不同,走通了最后也提示/mnt/usb目录不存在

于是:
sudo fdisk -l
看到我的U盘是/dev/sdb1,(根据U盘大小来判断的),既然/mnt/usb/目录不存在,那就建一个目录,
sudo mkdir /media/U
sudo mount /dev/sdb1 /media/U -t vfat -o iocharset=utf8

搞定


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 9.04无法识别U盘
帖子发表于 : 2009-06-26 10:54 

注册: 2009-06-22 19:37
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
passioni 写道:
摸索着搞定了
搜到一个做法,引用如下:
1、插入U盘
2、输入 fdisk -l /dev/sda 查看输出结果,比如我的是这样的: # fdisk -l /dev/sda Disk /dev/sda: 131 MB, 131104768 bytes 3 heads, 32 sectors/track, 2667 cylinders Units = cylinders of 96 * 512 = 49152 bytes Device Boot Start End Blocks Id System /dev/sda1 * 1 2668 128016 6 FAT16 注意:如果您的硬盘是 SCSI 接口的话,可能要将 sda 改成 sdb, sdc, sdd 等,以此类推。
3、看了上面的输出就知道U盘所在的设备了,比如我的就是/dev/sda1,接着便是挂载了,假设我将U盘挂载到/mnt/usb目录中,
就是 mount -t auto -o iocharset=cp936 /dev/sda1 /mnt/usb/
4、打开/mnt/usb 就可以看到你的U盘里的东西了!

按照上面的做法,看不到U盘是哪个,即使把sda1改成sdb,sdc,后面也走不同,走通了最后也提示/mnt/usb目录不存在

于是:
sudo fdisk -l
看到我的U盘是/dev/sdb1,(根据U盘大小来判断的),既然/mnt/usb/目录不存在,那就建一个目录,
sudo mkdir /media/U
sudo mount /dev/sdb1 /media/U -t vfat -o iocharset=utf8

搞定


还是没搞定,fdisk 后还是只显示硬盘的分区,没有发现U盘


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译