当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-02 22:58 
头像

注册: 2009-02-22 21:05
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
比如我在终端下使用rar命令,终端就会报出如下的错误提示:

/lib/libc.so.6: version `GLIBC_2.7' not found


我在 /lib/ 下看见也有/lib/libc.so.6 啊,怎么处理呢? 是更新系统的库的版本吗? 是的话命令又是什么呢?


:em20 哪位大哥指导我吧!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-04 6:44 

注册: 2008-05-24 8:30
帖子: 1453
送出感谢: 2
接收感谢: 30
你用源里的 rar 应该不会有这个问题吧?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-04 20:04 
头像

注册: 2009-02-22 21:05
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
aerofox:你用源里的 rar 应该不会有这个问题吧?

源指的是? 对不起,我不懂行话,还请点明,谢谢! :em03


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-04 20:44 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
你的rar怎么安装的?是使用新立得安装的吗?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-04 22:38 
头像

注册: 2009-02-22 21:05
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
不是,是一个压缩包rarlinux-3.8.b1.tar.gz, 解压缩后的目录叫 rar, 目录里面有 rar 这个命令,

>ldd rar
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00002b59b4098000)
libm.so.6 => /lib/libm.so.6 (0x00002b59b43a3000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00002b59b4624000)
libc.so.6 => /lib/libc.so.6 (0x00002b59b4832000)
/lib64/ld-linux-x86-64.so.2 (0x00002b59b3e790)
应该这样就能用的,
>rar x chaoxing.rari


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-04 23:02 

注册: 2008-05-24 8:30
帖子: 1453
送出感谢: 2
接收感谢: 30
那就换源里的吧


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-05 20:17 
头像

注册: 2009-02-22 21:05
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
又来了,俺都说了, 不知道你们说的 "源" 指的是什么?

“那就换源里的吧“ ,怎么换呢? :em20


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-05 20:18 
头像

注册: 2005-12-28 1:16
帖子: 3916
地址: 火星
系统: Ubuntu 12.10 X64
送出感谢: 1
接收感谢: 0 次
prayer163 写道:
又来了,俺都说了, 不知道你们说的 "源" 指的是什么?

“那就换源里的吧“ ,怎么换呢? :em20


你不看wiki吗?


_________________
目前负债150多万


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-05 20:55 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
楼主,“源”就是软件仓库,wiki就是Ubuntu中文知识库,在本论坛的右上角的wiki卡片,一点进去了。 :em05
另外,多看看各板块的置顶贴,会有很多收获的。刚接触一个新系统,不用急,慢慢学,多放狗,很快就入门了。 :em09


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 动态链接库与 命令要的版本对不上,怎么办?
帖子发表于 : 2009-07-07 21:54 
头像

注册: 2009-02-22 21:05
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
thank wangdu2002 , thanks! :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译