当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : build-essential 安装问题..
帖子发表于 : 2009-07-18 16:10 

注册: 2009-07-16 15:16
帖子: 47
送出感谢: 1
接收感谢: 1
引用:
$sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
build-essential: 依赖: g++ (>= 4:4.3.1) 但是它将不会被安装
依赖: dpkg-dev (>= 1.13.5) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

然后就这样咯。
g++ 依赖于 g++-4.3 ,后者又依赖于g++-4.3-base。最后者又说没有包。。。
阿阿。。。


请教一下。如何。。。
Ubuntu 8.10
谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: build-essential 安装问题..
帖子发表于 : 2009-07-18 17:18 
头像

注册: 2008-06-29 13:18
帖子: 371
送出感谢: 1
接收感谢: 3
不是很清楚。。

我在用810.904的时候也出现过有些依赖包装不上的问题
去http://packages.ubuntu.com/上把缺少的包装上基本上都能解决问题


页首
 用户资料  
 
3 楼 
 文章标题 : Re: build-essential 安装问题..
帖子发表于 : 2009-07-21 14:17 

注册: 2009-07-16 15:16
帖子: 47
送出感谢: 1
接收感谢: 1
恩,谢谢,我去找找。
估计是我换的更新源里的包补全。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译