当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-19 15:46 

注册: 2009-07-19 15:38
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
根据提示,安装Ubuntu 9.04到U盘,而且在安装时提示不改动现有硬盘的信息,但是后来发现如果不插入U盘,硬盘上的XP无法正常启动,而这台计算机是我与老婆共用,她不会使用Ubuntu。虽然,可以通过修改menu.lst改变缺省启动顺序,但是老婆每次都需要插入U盘启动毕竟不方便,请问各位高手有什么办法解决上述问题,谢谢!
此外,如果不插入U盘,系统启动时会显示:Grub loading, Error 25。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-19 15:55 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
你把grub半到硬盘的mbr上了,修复硬盘mbr。


_________________
Grub2 基础教程


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-19 16:02 
头像

注册: 2008-06-23 15:19
帖子: 3030
地址: 北欧某国
系统: ���������
送出感谢: 21
接收感谢: 6
恢复win所使用的mbr,然后在U盘上重新安装grub,让U盘可以单独起动。


_________________
http://noie.name 网站改版中。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-22 20:32 

注册: 2009-07-19 15:38
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
谢谢指教!
我可以采用 fdisk -mbr恢复硬盘的MBR,可是如何在U盘安装grub呢?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-22 20:37 

注册: 2008-03-05 13:05
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
心静自然凉 写道:
谢谢指教!
我可以采用 fdisk -mbr恢复硬盘的MBR,可是如何在U盘安装grub呢?


可以参考wiki里面关于grub修复的文章,应该可以解决的


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-22 20:38 
头像

注册: 2009-03-10 13:04
帖子: 7803
送出感谢: 1
接收感谢: 0 次
setup 命令


_________________
广告位招租


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-22 20:44 
头像

注册: 2007-03-15 16:58
帖子: 2796
地址: 湖北武汉
送出感谢: 2
接收感谢: 4
奇怪的问题


_________________
引用:


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-22 21:02 

注册: 2009-07-19 15:38
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
nuanhuai 写道:
setup 命令



我在终端上运行grub,之后输入setup命令,但是不成功,提示
Error 12: Invalid device requested


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 安装Ubuntu到U盘,安装选择不改动硬盘,后来发现如果不插入U盘则无法从硬盘启动
帖子发表于 : 2009-07-22 22:36 
头像

注册: 2008-06-23 15:19
帖子: 3030
地址: 北欧某国
系统: ���������
送出感谢: 21
接收感谢: 6
心静自然凉 写道:
nuanhuai 写道:
setup 命令


我在终端上运行grub,之后输入setup命令,但是不成功,提示
Error 12: Invalid device requested


我以前用过这个命令,但是现在忘了怎么用了。
您运行grub的时候,用sudo前缀了吗?
setup好像需要指定安装的位置,请指定U盘的位置。
其他的我就帮不了您了。


_________________
http://noie.name 网站改版中。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译