当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我新添加配置项 deb http://cn.archive.ubuntu.com/ubuntu/ 没法更新
帖子发表于 : 2009-08-02 21:03 

注册: 2009-08-02 20:45
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
请教高手,我新添加配置项 deb http://cn.archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse 后
运行 apt-get update没法更新
gao@gao-desktop:~$ apt-get update
E: 无法打开锁文件 /var/lib/apt/lists/lock - open (13 Permission denied)
E: 无法对状态列表目录加锁
运行gao@gao-desktop:~$ sudo apt-get update
后很多错误
错误 http://cn.archive.ubuntu.com feisty/main Packages
404 Not Found
错误 http://cn.archive.ubuntu.com feisty/restricted Packages
404 Not Found
忽略 http://download.skype.com stable Release
命中 http://download.skype.com stable/non-free Packages
错误 http://cn.archive.ubuntu.com feisty/universe Packages
404 Not Found
错误 http://cn.archive.ubuntu.com feisty/multiverse Packages
404 Not Found
错误 http://cn.archive.ubuntu.com feisty/restricted Sources
404 Not Found
错误 http://cn.archive.ubuntu.com feisty/universe Sources
404 Not Found
错误 http://cn.archive.ubuntu.com feisty/multiverse Sources
404 Not Found
这是怎么回事?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 我新添加配置项 deb http://cn.archive.ubuntu.com/ubuntu/ 没法更新
帖子发表于 : 2009-08-02 21:34 
头像

注册: 2009-06-21 19:38
帖子: 210
地址: CUMT
送出感谢: 0 次
接收感谢: 0 次
要么是网络问题要么是源已经......了 :em09


_________________
代码:
sudo apt-get install girlfriend
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。
下列的信息可能会对解决问题有所帮助:
下列的软件包有不能满足的依赖关系:
girlfriend: 依赖: house但是它将不会被安装
girlfriend: 依赖: car但是它将不会被安装
house,car: 依赖: money但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 我新添加配置项 deb http://cn.archive.ubuntu.com/ubuntu/ 没法更新
帖子发表于 : 2009-08-02 23:50 
头像

注册: 2007-12-17 21:41
帖子: 773
送出感谢: 67
接收感谢: 22
feisty =ubuntu 7.04, 版本过低,已不再支持,可换用以下源(国外源)
代码:
deb http://old-releases.ubuntu.com/ubuntu/  feisty main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ feisty-security main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ feisty-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ feisty-proposed main restricted universe multiverse

也可自己试试国内163的源,应该也行
http://mirrors.163.com

其实只要到网站查看一下就会明白,feisty 已经从以下网站删除了
http://cn.archive.ubuntu.com/ubuntu/dists/


_________________
* 日本人说:就算我们不拜靖国神社,韩国人也不会买我们的东西;
就算我们拜靖国神社,中国人照样买我们的东西。

* 历史不相信眼泪。能挡住狼的不是篱笆,而是棍子和猎枪。
--------------
Careone <emacslocale^126.com>
https://sourceforge.net/projects/emacslocale/files/


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 我新添加配置项 deb http://cn.archive.ubuntu.com/ubuntu/ 没法更新
帖子发表于 : 2009-08-04 19:54 

注册: 2009-08-02 20:45
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
非常感谢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译