当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu安装e17出现了依赖问题。
帖子发表于 : 2009-08-04 9:43 

注册: 2009-07-28 14:25
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我的Ubuntu版本是8.04.1\n \l 内核是2.6.24-19-generic gcc版本 4.2.3

安装e17的步骤也是按照网上的文章走的,设置好源之后,下载了公匙 ,添加公钥,更新,安装了cvs

之后安装e17 apt-get install e17 就出现了如下问题:初次安装e17,麻烦各位了。

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
e17: 依赖: exchange 但是它将不会被安装
依赖: libasound2 (> 1.0.18) 但是 1.0.15-3ubuntu4 正要被安装
依赖: libecore-con-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libecore-evas-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libecore-file-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libecore-imf-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libecore-input-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libecore-ipc-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libecore-x-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libedbus-svn-01 (>= 0.5.0.060) 但是它将不会被安装
依赖: libedje-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libeet1 (>= 1.0.0) 但是它将不会被安装
依赖: libefreet-svn-01 但是它将不会被安装
依赖: libevas-svn-01 (>= 0.9.9.060) 但是它将不会被安装
依赖: libgnutls26 (>= 2.5.9-0) 但却无法安装它
依赖: libevas-engines 但是它将不会被安装
依赖: libedje-bin 但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu安装e17出现了依赖问题。
帖子发表于 : 2009-08-04 10:43 

注册: 2009-04-19 21:09
帖子: 86
送出感谢: 0 次
接收感谢: 0 次
请用aptitude install e17


_________________
沉默是金。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu安装e17出现了依赖问题。
帖子发表于 : 2009-08-04 11:50 
头像

注册: 2007-04-14 11:17
帖子: 1035
送出感谢: 0 次
接收感谢: 2
apt-get和aptitude难道还是不一样的?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu安装e17出现了依赖问题。
帖子发表于 : 2009-08-04 12:13 

注册: 2009-04-19 21:09
帖子: 86
送出感谢: 0 次
接收感谢: 0 次
dwl301 写道:
apt-get和aptitude难道还是不一样的?

aptitude虽然没有apt-get的超级牛力但是它比apt-get好,我有一些apt-get装不上的包用aptitude装上了


_________________
沉默是金。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu安装e17出现了依赖问题。
帖子发表于 : 2009-08-05 9:12 

注册: 2009-07-28 14:25
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
按照2楼的指点,我试了下, # aptitude install e17

过程在下面:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
Reading extended state information
Initializing package states... 完成
Building tag database... 完成
The following packages are BROKEN:
e17 libecore-con-svn-01 libedje-bin libedje-svn-01 libeet1
libefreet-svn-01 libevas-svn-01
The following packages have been automatically kept back:
linux-headers-2.6.24-19 linux-headers-2.6.24-19-generic
linux-restricted-modules-common
The following NEW packages will be automatically installed:
e17-data exchange libecore-evas-svn-01 libecore-fb-svn-01
libecore-file-svn-01 libecore-imf-svn-01 libecore-input-svn-01
libecore-ipc-svn-01 libecore-job-svn-01 libecore-svn-01
libecore-txt-svn-01 libecore-x-svn-01 libedbus-svn-01 libeina-svn-01
libembryo-bin libembryo0 libevas-engines libgif4
The following packages have been kept back:
acpi-support acpid alacarte anacron app-install-data-commercial apparmor
apparmor-utils apport apport-gtk apt apt-utils avahi-autoipd avahi-daemon
base-files bind9-host bsdutils compiz-fusion-plugins-main console-setup
cpp-4.2 cron cupsys cupsys-bsd cupsys-client cupsys-common dbus dbus-x11
deskbar-applet dhcp3-client dhcp3-common dnsutils doc-base eject eog
evince evolution evolution-common evolution-data-server
evolution-data-server-common evolution-exchange evolution-plugins file
firefox firefox-3.0 firefox-3.0-gnome-support firefox-gnome-support
foo2zjs foomatic-filters gcalctool gcc-4.2 gcc-4.2-base gdb gdm gedit
gedit-common ghostscript ghostscript-x gksu gnome-about gnome-cards-data
gnome-desktop-data gnome-games gnome-games-data gnome-panel
gnome-panel-data gnome-power-manager gnome-system-monitor
gnome-system-tools grub gstreamer0.10-plugins-good gstreamer0.10-tools
gtk2-engines gtk2-engines-murrine gtk2-engines-pixbuf
gtk2-engines-ubuntulooks gtkhtml3.14 guidance-backends gvfs gvfs-backends
gvfs-fuse hal hal-info hpijs hplip hplip-data initramfs-tools initscripts
iproute jockey-common jockey-gtk language-pack-en language-pack-en-base
language-pack-gnome-en language-pack-gnome-en-base libavahi-client3
libavahi-common-data libavahi-common3 libavahi-compat-libdnssd1
libavahi-core5 libavahi-glib1 libavahi-ui0 libbind9-30 libc6 libc6-i686
libcamel1.2-11 libcupsimage2 libcupsys2 libcurl3 libcurl3-gnutls
libdbus-1-3 libebook1.2-9 libecal1.2-7 libedata-book1.2-2
libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8
libegroupwise1.2-13 libexchange-storage1.2-3 libexif12 libffi4
libfreetype6 libgadu3 libgcc1 libgdata-google1.2-1 libgdata1.2-1
libgksu2-0 libglib2.0-0 libglibmm-2.4-1c2a libgnome-desktop-2 libgnutls13
libgomp1 libgphoto2-2 libgphoto2-port0 libgs8 libgstreamer0.10-0
libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtkhtml3.14-19
libgtksourceview2.0-0 libgtksourceview2.0-common libgvfscommon0
libgweather-common libgweather1 libhal-storage1 libhal1 libicu38 libisc32
libisccc30 libisccfg30 libjasper1 libkrb53 liblcms1 libldap-2.4-2
liblwres30 libmagic1 libmagick10 libnautilus-extension1 libnm-glib0
libnm-util0 libnspr4-0d libnss3-1d libntfs-3g23 libpanel-applet2-0
libpango1.0-0 libpango1.0-common libparted1.7-1 libpcre3 libperl5.8
libpng12-0 libpoppler-glib2 libpoppler2 libpulse-browse0 libpulse0
libpulsecore5 libpurple0 libsasl2-2 libsasl2-modules libsmbclient
libsmbios1 libsndfile1 libsnmp-base libsnmp15 libsoup2.4-1 libssl0.9.8
libstdc++6 libtiff4 libvolume-id0 libvorbis0a libvorbisenc2
libvorbisfile3 libwmf0.2-7 libwnck-common libwnck22 libxml2 libxml2-utils
libxslt1.1 linux-generic linux-headers-generic
linux-image-2.6.24-19-generic linux-image-generic
linux-restricted-modules-2.6.24-19-generic
linux-restricted-modules-generic logrotate lsb-base lsb-release
module-init-tools myspell-en-gb myspell-en-us myspell-en-za nautilus
nautilus-data nautilus-sendto nautilus-share network-manager
network-manager-gnome ntfs-3g ntpdate openoffice.org-base-core
openoffice.org-calc openoffice.org-common openoffice.org-core
openoffice.org-draw openoffice.org-gnome openoffice.org-gtk
openoffice.org-help-en-gb openoffice.org-help-en-us
openoffice.org-impress openoffice.org-l10n-common
openoffice.org-l10n-en-gb openoffice.org-l10n-en-za
openoffice.org-style-human openoffice.org-thesaurus-en-us
openoffice.org-writer openssl parted passwd pciutils perl perl-base
pidgin pidgin-data pm-utils poppler-utils procps pulseaudio
pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-hal
pulseaudio-module-x11 pulseaudio-utils python-apport python-apt
python-gobject python-gtkhtml2 python-libxml2 python-problem-report
python-uno python2.5 python2.5-minimal rdesktop readahead samba-common
smbclient sudo sysv-rc sysvutils tasksel tasksel-data
thunderbird-locale-en-gb totem totem-common totem-gstreamer totem-mozilla
totem-plugins ttf-opensymbol tzdata ubuntu-docs udev ufw update-manager
update-manager-core update-notifier update-notifier-common util-linux
util-linux-locales vim-common vim-tiny vinagre xfonts-scalable xkb-data
xserver-xorg-video-amd xserver-xorg-video-ati xserver-xorg-video-geode
xserver-xorg-video-intel xsltproc xterm xulrunner-1.9
xulrunner-1.9-gnome-support yelp
The following NEW packages will be installed:
e17-data exchange libecore-evas-svn-01 libecore-fb-svn-01
libecore-file-svn-01 libecore-imf-svn-01 libecore-input-svn-01
libecore-ipc-svn-01 libecore-job-svn-01 libecore-svn-01
libecore-txt-svn-01 libecore-x-svn-01 libedbus-svn-01 libeina-svn-01
libembryo-bin libembryo0 libevas-engines libgif4
0 packages upgraded, 25 newly installed, 0 to remove and 302 not upgraded.
Need to get 2969kB/5410kB of archives. After unpacking 13.5MB will be used.
The following packages have unmet dependencies:
e17: 依赖: libasound2 (> 1.0.18) but 1.0.15-3ubuntu4 is installed.
依赖: libgnutls26 (>= 2.5.9-0) which is a virtual package.
libevas-svn-01: 依赖: libgnutls26 (>= 2.5.9-0) which is a virtual package.
依赖: librsvg2-2 (>= 2.22.3) but 2.22.2-2 is installed.
libeet1: 依赖: libgnutls26 (>= 2.5.9-0) which is a virtual package.
libecore-con-svn-01: 依赖: libgnutls26 (>= 2.5.9-0) which is a virtual package.
libedje-bin: 依赖: libgnutls26 (>= 2.5.9-0) which is a virtual package.
libedje-svn-01: 依赖: libgnutls26 (>= 2.5.9-0) which is a virtual package.
libefreet-svn-01: 依赖: libgnutls26 (>= 2.5.9-0) which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
e17 [Not Installed]
exchange [Not Installed]
libecore-con-svn-01 [Not Installed]
libecore-evas-svn-01 [Not Installed]
libecore-file-svn-01 [Not Installed]
libecore-imf-svn-01 [Not Installed]
libecore-input-svn-01 [Not Installed]
libecore-ipc-svn-01 [Not Installed]
libecore-x-svn-01 [Not Installed]
libedbus-svn-01 [Not Installed]
libedje-bin [Not Installed]
libedje-svn-01 [Not Installed]
libeet1 [Not Installed]
libefreet-svn-01 [Not Installed]
libevas-engines [Not Installed]
libevas-svn-01 [Not Installed]

Score is -9746

Accept this solution? [Y/n/q/?] Y 这里我选择的Y继续。
The following packages have been automatically kept back:
linux-headers-2.6.24-19 linux-headers-2.6.24-19-generic
linux-restricted-modules-common
The following packages have been kept back:
acpi-support acpid alacarte anacron app-install-data-commercial apparmor
apparmor-utils apport apport-gtk apt apt-utils avahi-autoipd avahi-daemon
base-files bind9-host bsdutils compiz-fusion-plugins-main console-setup
cpp-4.2 cron cupsys cupsys-bsd cupsys-client cupsys-common dbus dbus-x11
deskbar-applet dhcp3-client dhcp3-common dnsutils doc-base eject eog
evince evolution evolution-common evolution-data-server
evolution-data-server-common evolution-exchange evolution-plugins file
firefox firefox-3.0 firefox-3.0-gnome-support firefox-gnome-support
foo2zjs foomatic-filters gcalctool gcc-4.2 gcc-4.2-base gdb gdm gedit
gedit-common ghostscript ghostscript-x gksu gnome-about gnome-cards-data
gnome-desktop-data gnome-games gnome-games-data gnome-panel
gnome-panel-data gnome-power-manager gnome-system-monitor
gnome-system-tools grub gstreamer0.10-plugins-good gstreamer0.10-tools
gtk2-engines gtk2-engines-murrine gtk2-engines-pixbuf
gtk2-engines-ubuntulooks gtkhtml3.14 guidance-backends gvfs gvfs-backends
gvfs-fuse hal hal-info hpijs hplip hplip-data initramfs-tools initscripts
iproute jockey-common jockey-gtk language-pack-en language-pack-en-base
language-pack-gnome-en language-pack-gnome-en-base libavahi-client3
libavahi-common-data libavahi-common3 libavahi-compat-libdnssd1
libavahi-core5 libavahi-glib1 libavahi-ui0 libbind9-30 libc6 libc6-i686
libcamel1.2-11 libcupsimage2 libcupsys2 libcurl3 libcurl3-gnutls
libdbus-1-3 libebook1.2-9 libecal1.2-7 libedata-book1.2-2
libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8
libegroupwise1.2-13 libexchange-storage1.2-3 libexif12 libffi4
libfreetype6 libgadu3 libgcc1 libgdata-google1.2-1 libgdata1.2-1
libgksu2-0 libglib2.0-0 libglibmm-2.4-1c2a libgnome-desktop-2 libgnutls13
libgomp1 libgphoto2-2 libgphoto2-port0 libgs8 libgstreamer0.10-0
libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtkhtml3.14-19
libgtksourceview2.0-0 libgtksourceview2.0-common libgvfscommon0
libgweather-common libgweather1 libhal-storage1 libhal1 libicu38 libisc32
libisccc30 libisccfg30 libjasper1 libkrb53 liblcms1 libldap-2.4-2
liblwres30 libmagic1 libmagick10 libnautilus-extension1 libnm-glib0
libnm-util0 libnspr4-0d libnss3-1d libntfs-3g23 libpanel-applet2-0
libpango1.0-0 libpango1.0-common libparted1.7-1 libpcre3 libperl5.8
libpng12-0 libpoppler-glib2 libpoppler2 libpulse-browse0 libpulse0
libpulsecore5 libpurple0 libsasl2-2 libsasl2-modules libsmbclient
libsmbios1 libsndfile1 libsnmp-base libsnmp15 libsoup2.4-1 libssl0.9.8
libstdc++6 libtiff4 libvolume-id0 libvorbis0a libvorbisenc2
libvorbisfile3 libwmf0.2-7 libwnck-common libwnck22 libxml2 libxml2-utils
libxslt1.1 linux-generic linux-headers-generic
linux-image-2.6.24-19-generic linux-image-generic
linux-restricted-modules-2.6.24-19-generic
linux-restricted-modules-generic logrotate lsb-base lsb-release
module-init-tools myspell-en-gb myspell-en-us myspell-en-za nautilus
nautilus-data nautilus-sendto nautilus-share network-manager
network-manager-gnome ntfs-3g ntpdate openoffice.org-base-core
openoffice.org-calc openoffice.org-common openoffice.org-core
openoffice.org-draw openoffice.org-gnome openoffice.org-gtk
openoffice.org-help-en-gb openoffice.org-help-en-us
openoffice.org-impress openoffice.org-l10n-common
openoffice.org-l10n-en-gb openoffice.org-l10n-en-za
openoffice.org-style-human openoffice.org-thesaurus-en-us
openoffice.org-writer openssl parted passwd pciutils perl perl-base
pidgin pidgin-data pm-utils poppler-utils procps pulseaudio
pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-hal
pulseaudio-module-x11 pulseaudio-utils python-apport python-apt
python-gobject python-gtkhtml2 python-libxml2 python-problem-report
python-uno python2.5 python2.5-minimal rdesktop readahead samba-common
smbclient sudo sysv-rc sysvutils tasksel tasksel-data
thunderbird-locale-en-gb totem totem-common totem-gstreamer totem-mozilla
totem-plugins ttf-opensymbol tzdata ubuntu-docs udev ufw update-manager
update-manager-core update-notifier update-notifier-common util-linux
util-linux-locales vim-common vim-tiny vinagre xfonts-scalable xkb-data
xserver-xorg-video-amd xserver-xorg-video-ati xserver-xorg-video-geode
xserver-xorg-video-intel xsltproc xterm xulrunner-1.9
xulrunner-1.9-gnome-support yelp
0 packages upgraded, 0 newly installed, 0 to remove and 302 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] Y 这里也选择的继续
Writing extended state information... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
Reading extended state information
Initializing package states... 完成
Building tag database... 完成


最后这里显示的情况也不知道安装成功没有。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译